Package Details: cinnamon-screensaver-git 119.8de7ff0-1

Git Clone URL: https://aur.archlinux.org/cinnamon-screensaver-git.git (read-only)
Package Base: cinnamon-screensaver-git
Description: Screensaver for cinnamon desktop
Upstream URL: https://github.com/linuxmint/cinnamon-screensaver
Licenses: GPL
Conflicts: cinnamon-screensaver
Provides: cinnamon-screensaver
Submitter: twa022
Maintainer: realex
Last Packager: realex
Votes: 4
Popularity: 0.000056
First Submitted: 2013-01-17 04:27
Last Updated: 2015-06-08 15:59

Latest Comments

twa022 commented on 2013-09-12 05:04

@Elethiomel: changed depends to cinnamon-git (which depends on cinnamon-desktop-git)

Elethiomel commented on 2013-09-11 15:38

checking for CINNAMON_SCREENSAVER... no
configure: error: Package requirements (x11 >= 1.0
gtk+-3.0 >= 2.99.3
dbus-glib-1 >= 0.30
cinnamon-desktop >= 1.0.0) were not met:

No package 'cinnamon-desktop' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CINNAMON_SCREENSAVER_CFLAGS
and CINNAMON_SCREENSAVER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

fax commented on 2013-01-25 08:54

BTW, once the screensaver activates, I am getting a segmentation failure and this error message on the console:

(cinnamon-screensaver:2937): GLib-GIO-ERROR **: Settings schema 'org.cinnamon.screensaver' is not installed

twa022 commented on 2013-01-25 04:42

@freethinker: automake problem known, needs to be fixed in gnome-common upstream/packaging (see https://bugs.archlinux.org/task/33285)

Anonymous comment on 2013-01-25 02:33

Automake-1.9 should be a dependency as well. Meanwhile it can be installed from AUR - yaourt --noconfirm -S automake-1.9

fax commented on 2013-01-24 15:30

Thanks, it installed now. I had to manually resolve two issues however:

1. The build checks for automake-1.9, 1.10, 1.11 and 1.12. It failed because I had only installed automake-1.13.

2. The package fails to install because it tries to overwrite /etc/xdg/autostart/cinnamon-screensaver.desktop, which is owned by package cinnamon 1.6.7-4.

twa022 commented on 2013-01-24 13:40

@fax, should be fixed now

twa022 commented on 2013-01-24 13:40

@fax, should be fixed now

fax commented on 2013-01-23 08:42

I am not getting very far with the installation:

$ yaourt -S cinnamon-screensaver-git

==> Downloading cinnamon-screensaver-git PKGBUILD from AUR...
x PKGBUILD
x cinnamon-screensaver.pam
cinnamon-screensaver-git 20130116-1 (Thu Jan 17 06:27:56 EET 2013)
...
==> Building and installing package
==> Determining latest git revision...
-> Version found: 20130123
==> Making package: cinnamon-screensaver-git 20130123-1 (Wed Jan 23 10:40:49 EET 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found cinnamon-screensaver.pam
==> Validating source files with sha256sums...
cinnamon-screensaver.pam ... Passed
==> Extracting Sources...
==> Starting build()...
==> Connecting to GIT server....
Cloning into 'cinnamon-screensaver'...
remote: Counting objects: 581, done.
remote: Compressing objects: 100% (239/239), done.
remote: Total 581 (delta 365), reused 546 (delta 330)
Receiving objects: 100% (581/581), 1.22 MiB | 1.05 MiB/s, done.
Resolving deltas: 100% (365/365), done.
==> GIT checkout done or server timeout
==> Starting build...
Cloning into 'cinnamon-screensaver-build'...
done.
/tmp/yaourt-tmp-ritzfa/aur-cinnamon-screensaver-git/./PKGBUILD: line 36: ./configure: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build cinnamon-screensaver-git.