Package Details: cirkuit 0.4.3-5

Git Clone URL: https://aur.archlinux.org/cirkuit.git (read-only, click to copy)
Package Base: cirkuit
Description: Cirkuit is a KDE4 GUI for the Circuit macros by Dwight Aplevich, for drawing high-quality line diagrams to include in TeX, LaTeX, for similar documents.
Upstream URL: https://wwwu.uni-klu.ac.at/magostin/cirkuit.html
Licenses: GPL
Submitter: swiftscythe
Maintainer: None
Last Packager: TheGoliath
Votes: 30
Popularity: 0.000000
First Submitted: 2009-06-22 10:45 (UTC)
Last Updated: 2020-02-09 20:06 (UTC)

Latest Comments

1 2 3 Next › Last »

dreieck commented on 2018-05-02 18:48 (UTC)

cirkuit-kf5-git seems to work for me, too.

Should this package here be flagged out of date, so that people migrate to cirkuit-kf5?

Shino commented on 2017-12-30 22:36 (UTC)

I installed the package. However it prints following error:

"A KDE text-editor component could not be found; please check your KDE installation."

Can anyone help? I don't know how to provide the missing component. Thank you

gondsman commented on 2017-11-17 14:31 (UTC)

@Zentos: I uploaded the new package here: https://aur.archlinux.org/packages/cirkuit-kf5-git/ Please, report if it's working for you as well.

Zentos commented on 2017-10-29 03:15 (UTC)

@gondsman I would appreciate a cirkuit-kf5-git AUR package! Or even the PKGBUILD.

gondsman commented on 2017-10-25 08:55 (UTC)

Apparently there is a new branch on github with a Qt5/KF5 port of cirkuit. I've compiled it and it works fine, although there might be bugs I didn't notice. I can share a PKGBUILD of it if anyone's interested (or even create a cirkuit-kf5-git AUR package). I think this is the only graphical frontend for circuit macros available, so I'm very happy to see deveolpment on it.

XavierCLL commented on 2015-09-27 15:04 (UTC)

I could not contact with the developer :( I don't use this software anymore, if anyone know how fix it do it, I orphan the package for this.

XavierCLL commented on 2015-09-26 19:58 (UTC)

Yeah pnobel, this problem is present, this is not a packaging bug, but I contacted with the developer for fix it...

pnobel commented on 2015-09-26 16:38 (UTC)

CMake Error at /usr/share/apps/cmake/modules/FindGettext.cmake:232 (ADD_CUSTOM_TARGET): add_custom_target cannot create target "pofiles" because another target with the same name already exists. The existing target is a custom target created in source directory "/tmp/yaourt-tmp-parth/aur-cirkuit/src/cirkuit-0.4.3/po/lt". See documentation for policy CMP0002 for more details. Call Stack (most recent call first): po/ug/CMakeLists.txt:2 (GETTEXT_PROCESS_PO_FILES)

XavierCLL commented on 2014-05-27 21:57 (UTC)

fixed, thanks @gondsman.

gondsman commented on 2014-05-27 21:41 (UTC)

Hi, I noticed that this package owns the file /usr/share/apps/katepart/syntax/gnuplot.xml which is also owned by kdebase-katepart. Is it necessary for this package?