Package Details: citra-canary-bin 2777.20240211.1f707b0-1

Git Clone URL: https://aur.archlinux.org/citra-canary-bin.git (read-only, click to copy)
Package Base: citra-canary-bin
Description: Nintendo 3DS emulator - additional features still under review
Upstream URL: https://github.com/citra-emu/citra-canary
Keywords: 3ds canary emulator nintendo
Licenses: GPL-2.0-or-later
Conflicts: citra, citra-git, citra-qt, citra-qt-git
Provides: citra, citra-qt
Submitter: chabad360
Maintainer: xiota
Last Packager: xiota
Votes: 3
Popularity: 0.002519
First Submitted: 2019-08-30 05:40 (UTC)
Last Updated: 2024-02-11 01:55 (UTC)

Pinned Comments

xiota commented on 2024-02-11 02:01 (UTC) (edited on 2024-02-11 02:02 (UTC) by xiota)

  • This is a self-updating package. It automatically checks for and uses the latest upstream AppImage.

    • Flagging for occasional version bumps is acceptable, but unnecessary.
      • Please wait about a month since the last update.
      • Do not comment to request version bumps.
  • Avoid commenting and flagging at the same time for the same issue.

    • Flag for common issues with standard solutions.
    • Comment for issues that require explanation or debugging.
      • When requesting dependencies, include a brief, relevant excerpt from the error message.
      • Use a pastebin for blocks of text more than a few lines.
  • canary vs nightly

    • Canary = "additional features still under review"
    • Nightly = "reviewed and tested features"
  • Other notes:

    • This package unpacks the AppImage. This reduces overhead and startup times, but may or may not affect in-game performance.
    • This package checks for new releases when rebuilt so users do not have to wait for maintainer bumps.
    • This package uses traditional naming conventions.

Latest Comments

1 2 Next › Last »

xiota commented on 2024-02-11 02:01 (UTC) (edited on 2024-02-11 02:02 (UTC) by xiota)

  • This is a self-updating package. It automatically checks for and uses the latest upstream AppImage.

    • Flagging for occasional version bumps is acceptable, but unnecessary.
      • Please wait about a month since the last update.
      • Do not comment to request version bumps.
  • Avoid commenting and flagging at the same time for the same issue.

    • Flag for common issues with standard solutions.
    • Comment for issues that require explanation or debugging.
      • When requesting dependencies, include a brief, relevant excerpt from the error message.
      • Use a pastebin for blocks of text more than a few lines.
  • canary vs nightly

    • Canary = "additional features still under review"
    • Nightly = "reviewed and tested features"
  • Other notes:

    • This package unpacks the AppImage. This reduces overhead and startup times, but may or may not affect in-game performance.
    • This package checks for new releases when rebuilt so users do not have to wait for maintainer bumps.
    • This package uses traditional naming conventions.

Timothee commented on 2023-11-11 19:43 (UTC)

Hello, thanks for your work !

I have an error : citra-qt: error while loading shared libraries: libQt6Multimedia.so.6: cannot open shared object file: No such file or directory

I have installed the qt6-multimedia package and it's fix the problem. May be you to change the depends for qt6-multimedia instead qt5-multimedia ? :)

Neptune650 commented on 2022-12-08 18:07 (UTC)

Updated.

chabad360 commented on 2021-08-09 18:27 (UTC)

Just updated the package.

@FalconProgrammer, I've attempted to fix the issue you've encountered.

In regards to dependencies, there are some issues with them and I do not have the time to resolve these issues (or find the better version), so I'm going to orphan this package. If someone want's to take it up, feel free.

FalconProgrammer commented on 2021-08-09 17:09 (UTC) (edited on 2021-08-09 17:10 (UTC) by FalconProgrammer)

I'm also having another issue:

makepkg -i

==> WARNING: The package group has already been built, installing existing packages...

==> Installing citra-canary-bin package group with pacman -U...

loading packages...

resolving dependencies...

looking for conflicting packages...

error: unresolvable package conflicts detected

error: failed to prepare transaction (conflicting dependencies)

:: citra-canary-bin and citra-qt-canary-bin are in conflict

==> WARNING: Failed to install built package(s).

FalconProgrammer commented on 2021-08-09 16:53 (UTC)

I can confirm that the SHA256 is still an issue.

@aquova Thanks for the correct SHA256 - will use until the package gets updated.

aquova commented on 2021-08-01 21:38 (UTC)

Installation fails due to incorrect SHA256 for citra.desktop. It looks like it was edited in mid-June, the correct SHA256 should be b4c9433fbcbb1b9ddf19f009252e89d8d653ebac7f67d5d0beb49259f583ab69.

chabad360 commented on 2020-12-21 15:05 (UTC)

They're being built again, so we're back in business.