Package Details: ckbcomp 1.208-1

Git Clone URL: https://aur.archlinux.org/ckbcomp.git (read-only, click to copy)
Package Base: ckbcomp
Description: Compile a XKB keyboard description to a keymap suitable for loadkeys or kbdcontrol
Upstream URL: http://anonscm.debian.org/cgit/d-i/console-setup.git/
Keywords: keymap
Licenses: GPL2
Submitter: Binero
Maintainer: funilrys
Last Packager: funilrys
Votes: 15
Popularity: 0.96
First Submitted: 2015-11-04 14:43 (UTC)
Last Updated: 2022-06-15 03:43 (UTC)

Latest Comments

dreieck commented on 2022-08-06 11:45 (UTC)

The error → reported on 2022-06-09 by @gamezalda is an error in xkeyboard-config which is now → reported at the Arch Linux bugtracker.

yochananmarqos commented on 2022-06-09 22:49 (UTC) (edited on 2022-06-09 22:49 (UTC) by yochananmarqos)

FYI, the ckbcomp script has not been updated in 9 months, so updating to anything newer than 1.206 won't make any difference.

gamezelda commented on 2022-06-09 22:17 (UTC)

Both 1.207 and 1.208 fail to parse the new rules in xkeyboard-config 2.36-1 for Arch:

$ ckbcomp en_US
WARNING: Syntax error in the following line in "rules/base":
WARNING: armada asus_laptop benqx btc5090 btc6301urf btc9019u /
Died at /usr/bin/ckbcomp line 3228, <RULES> line 105.

Looks more like an xkeyboard-config issue though.

To work around it, either edit the file (/usr/share/X11/xkb/rules/base) to replace those trailing / to \ or downgrade to xkeyboard-config 2.35.1-1.

killajoe commented on 2022-06-09 21:30 (UTC)

http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.208.tar.xz is there already ;)

TheCynicalLiger commented on 2021-08-02 18:56 (UTC)

@talos767 also 1.205 also does the job

talos767 commented on 2021-07-26 18:32 (UTC)

Getting a 404 on the download for this (version 1.202-1):

curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.202.tar.xz

When I attempt to edit the pkgbuild to use 1.191 as @VeryGeneric suggests, I get:

==> Validating source files with sha512sums...
    console-setup_1.191.tar.xz ... FAILED
==> ERROR: One or more files did not pass the validity check!
error downloading sources: ckbcomp

Is this upstream's issue, or a packaging issue?

VeryGeneric commented on 2021-07-17 02:33 (UTC)

For anyone building this, it seems debian wants us to use 1.191 now.

funilrys commented on 2021-04-18 11:23 (UTC)

@TechXero, fixed.

TechXero commented on 2021-04-18 11:00 (UTC) (edited on 2021-04-18 11:00 (UTC) by TechXero)

@funilrys I cannot build keep getting file not found error xD

lifo2 commented on 2020-11-16 12:04 (UTC)

195 is removed. I switched to 198 and also had to change the cd command as the directory in the tar file is console-setup-1.198 now, not console-setup.

octal commented on 2020-11-04 03:42 (UTC) (edited on 2020-11-04 04:24 (UTC) by octal)

How to fix the 404 error "oneliner" style:
yay -G ckbcomp ; cd ckbcomp ; curl -o PKGBUILD https://hastebin.com/raw/uxomutereh > PKGBUILD ; makepkg -si

hayao commented on 2019-12-01 11:51 (UTC)

The build will fail midway.

==> ERROR: Failure while downloading http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.193.tar.xz Aborting...

aNewDay commented on 2019-08-14 21:59 (UTC)

Please update to http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.193.tar.xz

192 is removed.

commented on 2018-02-24 19:08 (UTC)

Please update the source This will work in the meantime.

https://pastebin.com/HAi0c86u

djnakudo commented on 2018-01-20 23:36 (UTC)

Please update the source to http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.175.tar.xz

ultraviolet commented on 2018-01-06 23:00 (UTC)

http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.174.tar.xz

tukanoid commented on 2017-12-05 20:53 (UTC)

http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.172.tar.xz

frederic2ec commented on 2017-11-18 01:46 (UTC)

Please update to version 1.170. Get 404 error

funilrys commented on 2017-07-22 10:21 (UTC)

@empijei Please hit the button `Flag package out-of-date` when it's happening. Updated.

empijei commented on 2017-07-19 10:29 (UTC)

This does not work anymore, should be updated to v1.166 (http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.166.tar.xz) with sha512sum == 9c3c9ee8402f148117a8fe4e7091604b0aa4d91764abf0dcff698ee2c8d938fc589966ba3b993f3565112290ea392446bedd82f084cb412d544403448a253f65

funilrys commented on 2017-06-28 20:15 (UTC)

Updated to v1.165

funilrys commented on 2017-02-28 12:09 (UTC) (edited on 2017-02-28 12:11 (UTC) by funilrys)

Updated to v1.162 Thanks @spsf64

funilrys commented on 2017-02-14 16:50 (UTC)

@djanos @gregor Updated to v1.160 ==> You can use the 'Out of Date' button to signal me when it's happen

djanos commented on 2017-01-16 10:03 (UTC)

v1.157 available sha512sums=('ec4a31ac122563cf7da28baf8f5c4e5309f45a0be3bbec0989160219d2aff07b65dad8d46f3f12697cdc858f76e1474352cf0e319cab3716af82603b13c0794e')

gregor commented on 2016-12-27 15:34 (UTC)

http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.155.tar.xz is the newest one, please update

spsf64 commented on 2016-11-24 20:00 (UTC)

@funilrys, this one was fast! Thanks!

funilrys commented on 2016-11-24 19:56 (UTC)

Updated after 12 minutes :D thanks for the flag @spsf64

Binero commented on 2016-08-25 02:56 (UTC)

Disowned the package. Feel free to update.

swiftgeek commented on 2016-08-06 13:45 (UTC)

http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.148.tar.xz is the newest one, please update