Package Details: clamtk 5.20-1

Git Clone URL: https://aur.archlinux.org/clamtk.git (read-only)
Package Base: clamtk
Description: GUI front-end for ClamAV using Perl and Gtk libraries. It is designed to be an easy-to-use, on-demand scanner for Linux systems
Upstream URL: https://github.com/dave-theunsub/clamtk/
Licenses: GPL
Submitter: blaztinn
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 253
Popularity: 3.352662
First Submitted: 2008-05-05 15:43
Last Updated: 2015-09-12 18:29

Latest Comments

WFV commented on 2016-06-11 22:13

Fails to launch after pacman -Syyu with errors:
Can't locate FOOBAR.pm in @INC (you may need to install the Glib module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/vendor_perl/ClamTk/Analysis.pm line 14.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/ClamTk/Analysis.pm line 14.
Compilation failed in require at /usr/bin/clamtk line 22.
BEGIN failed--compilation aborted at /usr/bin/clamtk line 22.
Initially it was giving a perl handshake error. Followed corrections from https://bbs.archlinux.org/viewtopic.php?id=213408 which fixed the perl handshake error. Had to reinstall all the perl packages that were requested, lastly pango-perl. Perhaps this may be faster https://lists.archlinux.org/pipermail/arch-dev-public/2016-May/028034.html

ninian commented on 2016-06-10 22:31

Failing to launch here too, with error:
Icon 'gtk-new' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 283.

notuxius commented on 2016-03-12 07:36

ClamTk failed to launch:
Icon 'gtk-directory' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 511.

mikhailnov commented on 2016-02-14 21:16

> Using Xfce with the Adwaita theme, which does not include the gtk-* icons. Installing all the icon themes mentioned below didn't help, of course.

Installing gnome-icon-theme did help but I had to go to KDE settings and GTK applications settings an set this icon theme as a reserve one.

chappjc commented on 2015-10-30 22:04

Using Xfce with the Adwaita theme, which does not include the gtk-* icons. Installing all the icon themes mentioned below didn't help, of course. Fortunately, the ugly solution of copying gtk-{new,network,properties,refresh,goto-bottom,file,directory,find}.png to /usr/share/pixmaps/ was enough to satisfy clamtk. Not pretty, but effective.

feio commented on 2015-09-11 00:33

Installing gnome-icon-theme (https://www.archlinux.org/packages/extra/any/gnome-icon-theme/) will solve the issue

moonman commented on 2015-08-24 15:44

This KDE solution (editing index.theme and not installing a particular theme) needs to be added to the wiki. This is ridiculous to post if you don't know what theme you are using. Look it up in preferences. Read comments. We are not Ubuntu distro.

raulicci commented on 2015-08-24 15:35

extra/adwaita-icon-theme 3.16.2.1-1 (gnome) [installed]
I have installed and selected Adwaita

FadeMind commented on 2015-08-24 06:16

For GTK apps better is using GNOME/Adwaita icon set... or another customized (and compatible).

FadeMind commented on 2015-08-24 06:15

raulicci

clamtk required FULL gnome icon set using, if any icon from gnome stock icon set is missing, clamtk just show this error. In Your situation breeze don't provide gnome's icon gtk-new.

raulicci commented on 2015-08-24 02:44

Hi, i have plasma and brezee theme
I can't open clamtk

$ clamtk
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "es:en_US",
LC_ALL = (unset),
LC_MONETARY = "es_MX.UTF-8",
LC_NUMERIC = "es_MX.UTF-8",
LC_COLLATE = "es_MX.UTF-8",
LC_MEASUREMENT = "es_MX.UTF-8",
LC_TIME = "es_MX.UTF-8",
LANG = "es_419.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale. at /usr/lib/perl5/vendor_perl/Gtk2.pm line 126.
Icon 'gtk-new' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 283.
thanx for help

firekage commented on 2015-04-27 21:02

I don't know which theme i'm using, and what's that for this apps.I use KDE and that's all.

gustawho commented on 2015-04-25 22:06

As previously said by some users, try editing the index.theme of the icon theme you're using. For instance, if you're using Breeze, edit

/usr/share/icons/breeze/index.theme

And change the line

Inherits=

To:

Inherits=gnome

firekage commented on 2015-04-25 15:24

There is still problem with starting clamtk because of gtk-new icon bug. Does anybody have solution for it?

Azul commented on 2015-04-24 21:02

Hmm I'm getting a weird error. Clamtk won't start and is giving me this as output when I try to start it via the terminal.

Illegal instruction (core dumped)

Ideas?

Azul commented on 2015-04-23 20:19

5.17 looks to be out.

pcxz commented on 2015-03-08 19:17

@moonman
Very thanks ..now work ok.
:)

@gustawho
Yes i use Kde with oxygen icon theme.

moonman commented on 2015-03-08 18:36

@pcxz see my comment from april 2014 below if you are on kde

moonman commented on 2015-03-08 18:35

@pcxz see my comment from august 2014 below if you are on kde

gustawho commented on 2015-03-08 17:03

@pcxz Are you running KDE? it seems ClamTk have some issues detecting the official GNOME icon theme files on KDE. Furthermore, it seems unable to link the correct images when using an icon theme which doesn't use the same filenames for its icons (E.g. "gtk-preferences" is "configure" in Breeze).

pcxz commented on 2015-03-08 06:25

Not work.
Icona �gtk-new� non presente nel tema at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 280.

Any help? ..thx.

gustawho commented on 2015-02-22 04:05

Done :)

oxalin commented on 2015-02-22 03:32

Gustawho, since you became the maintainer, could you remove the cron dependency? ClamAV is the one that should rely on cron or systemd, not ClamTK. Since clamAV is already providing two services for systemd (one for the AV and the other for the database update service), there is no need for cron to be installed with neither packages.

oxalin commented on 2015-02-20 21:04

Is it me or should cron be an optional package? A user could use clamtk, which is a GUI without any use of a scheduler, no?

By the way, I might be interested to step up as a maintainer.

blaztinn commented on 2015-02-20 11:45

Disowned the package, hope some other maintainer can step up.

waitnsea commented on 2014-12-19 04:25

Doesn't work anymore : error message = L'ic�ne ��gtk-new�� n'est pas pr�sente dans le th�me at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 262
means : **gtk-new** icon isn't in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 262

nothy commented on 2014-10-10 14:01

update clamtk package to new version 5.10

tmh commented on 2014-09-05 12:27

Can anyone update clamtk package to new version 5.09?

tancrackers commented on 2014-08-29 23:40

OK, what moonman suggested worked, but Clamtk is amazingly sluggish (I haven't used it in a while, so I honestly don't know if the program is that great anymore)

I added:
My oxygen theme had:
Inherits=hicolor

I changed it to:
Inherits=hicolor,gnome

tancrackers commented on 2014-08-28 14:36

I updated Clamtk to 5.08.1
KDE problem still present; I'm going to try the workarounds listed below later tonight

tmh commented on 2014-08-28 06:59

Can anyone update clamtk package to new version 5.08?

moonman commented on 2014-08-22 01:58

@tancrackers and @Ravior have you read comments below?

tancrackers commented on 2014-08-21 05:40

I can verify that Clamtk does not load under KDE 4.14 for the same reason as Ravior's
From Konsole:
[john@john-archlinux ~]$ clamtk
Icon 'gtk-new' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 258.

Ravior commented on 2014-08-08 18:02

Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 258.
Icon „gtk-new” is not present in the theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 258.

That should be the aproximate message in english.
some_gtk-icon-theme dependency is not valid anymore.

mokkurkalve commented on 2014-06-22 16:15

Recompiling against the newly updated perl 5.20.0-5 seems to fix it....

blaztinn commented on 2014-06-19 08:07

Hm, no success with previous link. Does anybody have a solution to the error @mokkurkalve pasted here?

blaztinn commented on 2014-06-19 06:43

I think this could be the problem:
https://www.archlinux.org/news/perl-updated-to-520/

It's not working even on my machine, haven't had time to try the linked sollution...

mokkurkalve commented on 2014-06-18 14:12

On i686, I only get:

:~$ clamtk
Invalid version format (non-numeric data) at /usr/share/perl5/core_perl/File/Path.pm line 3.
BEGIN failed--compilation aborted at /usr/share/perl5/core_perl/File/Path.pm line 3.
Compilation failed in require at /usr/lib/perl5/vendor_perl/ClamTk/Prefs.pm line 19.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/ClamTk/Prefs.pm line 19.
Compilation failed in require at /usr/bin/clamtk line 28.
BEGIN failed--compilation aborted at /usr/bin/clamtk line 28.

gojun077 commented on 2014-06-18 10:40

The sha256sum for clamtk-5.07.tar.gz:

983a0862eed5af31f6e9f230d5081abc2a744ed8c5ac622f310d1c07dac4f9cb

moonman commented on 2014-04-10 08:12

Damn, after I figured all this out I found a bugreport on this: https://bugs.kde.org/show_bug.cgi?id=325966

moonman commented on 2014-04-10 08:01

I finally found a good solution, though it is still manual. Fortunately I use a custom theme (from kde-looks) and as I modify it, it won't get overwritted with a package update.

The soltuion:
1. Make sure you have the gnome icon theme installed
2. Go to system settings -> Application Appearance -> Icons and take a note of the theme you are using.
3. Now find the theme files. They will either be under /usr/share/icons/<theme name>
or under ~/.kde4/share/icons/<theme name>
4. Open the index.theme in a text editor
5. Now you need ti add "Inherits=gnome" under [Icon Theme] section (usually at the very top). For example for me the line already existed for the H2O theme:
"Inherits=hicolor"
so I added gnome to the variable:
"Inherits=gnome,hicolor"
Now the beginning of the file looks like this:

[Icon Theme]
Name=H2O
Comment=Rogério de Souza
DisplayDepth=32
Inherits=gnome,hicolor
Example=folder
...

6. Reloaded the theme from Application Appearance (chose a different icon theme then went back to my H2O again) and viola, clamtk works.

hannibal_l commented on 2014-04-09 21:48

Ladies and gentlemen; if your icon theme in KDE is KFaenza, please copy these lines and paste it in an empty text editor file, save it and run the script.
The lines start just below:

#!/bin/sh
sudo ln -s /usr/share/icons/KFaenza/places/16/network-workgroup.png /usr/share/icons/KFaenza/places/16/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/22/network-workgroup.png /usr/share/icons/KFaenza/places/22/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/32/network-workgroup.png /usr/share/icons/KFaenza/places/32/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/48/network-workgroup.png /usr/share/icons/KFaenza/places/48/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/64/network-workgroup.png /usr/share/icons/KFaenza/places/64/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/128/network-workgroup.png /usr/share/icons/KFaenza/places/128/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/256/network-workgroup.png /usr/share/icons/KFaenza/places/256/gtk-network.png
sudo ln -s /usr/share/icons/KFaenza/places/scalable/network-workgroup.png /usr/share/icons/KFaenza/places/scalable/gtk-network.png

blaztinn commented on 2014-04-09 21:06

I removed gnome-icon-* from the dependencies. Since it looks like it depends which DE you are running I added a note in optdepends that the proper package is needed for diplaying icons. Hope this is OK. If anybody has a better solution please do tell.

Shadow86sk commented on 2014-04-09 20:09

Downloading:
community/faenza-icon-theme
community/faience-icon-theme
community/mate-icon-theme-faenza
community/mate-themes

Fixed the:
Icon 'gtk-properties' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 239.

Thank you moonman

They should be made depedences. :)

Shadow86sk commented on 2014-04-09 20:08

Downloading:
community/faenza-icon-theme
community/faience-icon-theme
community/mate-icon-theme-faenza
community/mate-themes

Fixed the:
Icon 'gtk-properties' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 239.

Thank you moonman

Anonymous comment on 2014-03-19 03:11

5.05 out: https://bitbucket.org/dave_theunsub/clamtk/downloads/clamtk-5.05.tar.gz

moonman commented on 2014-02-26 12:39

Yeah this is a mystery to me...
Ubuntu's package doesn't have *.svg's too: http://packages.ubuntu.com/precise-updates/all/gnome-icon-theme-full/filelist

EDIT: Could this be the package?! https://www.archlinux.org/packages/extra/any/icon-naming-utils/

blaztinn commented on 2014-02-26 11:29

I ran the command and I guees I don't have any gtk-new.svg icons on my system, just gtk-new.png icons. But clamtk still runs ok and doesn't report any errors here.

moonman commented on 2014-02-26 11:16

I think it makes sense. Clamtk uses gtk2, gnome that we have is gtk3, mate on the other hand is gtk2 because it is a fork of gnome2

moonman commented on 2014-02-26 10:58

# find /usr/share/icons/ -iname "*gtk-properties*"
/usr/share/icons/ContrastHigh-SVG/scalable/actions/gtk-properties.svg
/usr/share/icons/mate/24x24/actions/gtk-properties.png
/usr/share/icons/mate/22x22/actions/gtk-properties.png
/usr/share/icons/mate/16x16/actions/gtk-properties.png
/usr/share/icons/mate/32x32/actions/gtk-properties.png
/usr/share/icons/mate/48x48/actions/gtk-properties.png
/usr/share/icons/mate/256x256/actions/gtk-properties.png
/usr/share/icons/gnome/24x24/actions/gtk-properties.png
/usr/share/icons/gnome/22x22/actions/gtk-properties.png
/usr/share/icons/gnome/16x16/actions/gtk-properties.png
/usr/share/icons/gnome/32x32/actions/gtk-properties.png
/usr/share/icons/gnome/48x48/actions/gtk-properties.png
/usr/share/icons/gnome/256x256/actions/gtk-properties.png

It is fine there. Yeah I don't know why gtk-properties error came up, but I think gtk-new was the main one. Pacman would tell me if the same file is owned by multiple packages so that isn't the problem.

See if you can find gtk-new.svg on your system because I couldn't before I installed that mate-themes package. I could only see gtk-new.png before.
find /usr/share/ -name gtk-new.svg
Then if you do find one, see which package it belongs to.

blaztinn commented on 2014-02-26 09:31

Great that you found a solution but sadly it doesn't help our package because we can't force faenza icon theme on all users :)

Could you try running:
find /usr/share/icons/ -iname "*gtk-properties*"
and check the output. For me it finds:
/usr/share/icons/gnome/16x16/actions/gtk-properties.png
/usr/share/icons/gnome/22x22/actions/gtk-properties.png
/usr/share/icons/gnome/24x24/actions/gtk-properties.png
/usr/share/icons/gnome/32x32/actions/gtk-properties.png
/usr/share/icons/gnome/48x48/actions/gtk-properties.png
/usr/share/icons/gnome/256x256/actions/gtk-properties.png
And they are all owned by gnome-icon-theme package (checked by pacman -Qo filename).

Could it be that you have some other package instaled that replaces gnome-icon-theme and doesn't provide those files?

Other possible problem could be, that you have set a default gtk icon theme that doesn't have gtk-properties icon defined (and the theme doesn't inherit from one that does).

moonman commented on 2014-02-26 09:19

Actually, I might have found a solution:

# pkgfile gtk-new.svg
community/faenza-icon-theme
community/faience-icon-theme
community/mate-icon-theme-faenza
community/mate-themes

Installed mate-themes (with a bunch of (probably unneeded) dependencies) and it works again.

moonman commented on 2014-02-26 09:11

Well, now the one that worked fine is giving this:
Icon 'gtk-properties' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 239.

Weird. I give up

moonman commented on 2014-02-25 23:09

The problem is strage. one PC is fine, the other has this problem. I am gonna try and compare the packages installed. Maybe one of the aur dependencies needs a rebuild

dave_m commented on 2014-02-19 14:28

If the gtk icon issue is still happening, can someone find a different gtk icon not already in use that is available? Then we can have ClamTk determine that if one is not present, use the other. Thanks!

moonman commented on 2014-02-14 04:11

Still the same problem with kde for me:
Icon 'gtk-new' not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 239.

blaztinn commented on 2014-01-20 10:11

I've updated to the latest version (5.03) and added gnome-icon-theme, gnome-icon-theme-extras and gnome-icon-theme-symbolic as dependencies since there is no gnome-icon-theme-full package. These are all the gnome-icon-theme* packages so I hope this covers all the icons used in this app.

dave_m commented on 2014-01-16 23:04

Hi, it appears that gnome-icon-theme-full is the correct requirement, and not gnome-icon-theme. I will update the changes on my end. Apologies for any confusion.

dave_m commented on 2014-01-07 17:27

@mustafakilic, if you're still having issues, please email me or file a bug report (http://code.google.com/p/clamtk/issues/list). Running "clamtk" (without the quotes) at the commandline will let us know what error messages are popping up. Thanks!

mustafakilic commented on 2014-01-07 17:09

Still won't start in KDE

dave_m commented on 2014-01-07 17:00

Just a heads up - 5.03 will bring back the cronie (for crontab) requirement due to user requests to bring back the scheduling functionality. Thanks!

FadeMind commented on 2013-12-31 10:43

Please update PKGBUILD to 5.02 version.

dave_m commented on 2013-11-25 13:29

Sorry, I should have posted this earlier, but all build-related files are here:

https://bitbucket.org/dave_theunsub/build_files/

Thanks,

blaztinn commented on 2013-11-25 13:01

Updated the package.

I removed the perl-* packages dave_m listed and udev too. I'll check at each release if the udev becomes a dependency again.
gnome-icon-theme dependency was left since it will be a dependency in the next release.

dave_m commented on 2013-11-25 12:49

Hi,

You can remove perl-date-calc (we use Time::Piece now), perl-file-find-rule, and perl-net-dns from the requirements. It is possible to also remove udev for now, but it may be re-added later due to requests for device scanning. The gnome-icon-theme requirement will be added for 5.02.

Thanks,

mustafakilic commented on 2013-11-16 19:06

for KDE https://code.google.com/p/clamtk/wiki/UpdateNotesWarning#I'm_using_Kubuntu_13.04,_and_won't_start!

felmur commented on 2013-11-16 11:00

I use KDE.

Seems that it doesn't found some icons (gtk-new, gtk-network). I've already tried to add gnome-icons.

Use of the encoding pragma is deprecated at /usr/bin/clamtk line 37.
Icona �gtk-new� non presente nel tema at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 233.

rectec commented on 2013-10-13 00:58

Can't believe this package has gone so long without getting into the main repos.

moonman commented on 2013-05-28 03:02

version 4.45 is available. Please Update.

Anonymous comment on 2013-05-15 04:37

FVDI is last generation diagnostic interface for vehicles and trucks
produced from our company. It works the same as AVDI(ABRITES Vehicle Diagnostic Interface).
Currently FVDI is distributed with following diagnostic software:
1. ABRITES Commander for VAG - VW, Audi, Seat, Skoda
2. ABRITES Commander for Porsche
3. ABRITES Commander for Mercedes/Smart/Maybach
4. ABRITES Commander for OPEL/VAUXHALL
5. ABRITES Commander for BMW
6. ABRITES Commander for Peugeot/Citroen
7. ABRITES Commander for Fiat/Alfa/Lancia
8. Abrites Commander for Renault
9. Abrites Commander for Toyota/Lexus
10. Abrites Commander for Hyundai/KIA
11. Abrites Commander for Nissan/Infiniti
12. ABRITES TAG Key Tool

Welcome to www.joyoauto.com

blaztinn commented on 2012-12-06 21:15

FF automatically spamming AUR :). No problem, I removed the flag.

Kyrias commented on 2012-12-06 20:55

Whops, the flag URL was in my history and FF felt like going to it instead of the package page itself.

Sorry.

blackhole commented on 2012-06-04 01:38

Now OK , after updating perl.

blaztinn commented on 2012-06-03 21:54

@blackhole: Have you tried updating Perl? I have version 5.16.0-2 and I don't get this error.

blackhole commented on 2012-06-02 12:13

clamtk
Perl API version v5.16.0 of Locale::gettext does not match v5.14.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 213.
Compilation failed in require at /usr/lib/perl5/vendor_perl/ClamTk/App.pm line 22.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/ClamTk/App.pm line 22.
Compilation failed in require at /usr/bin/clamtk line 20.
BEGIN failed--compilation aborted at /usr/bin/clamtk line 20.

postblue commented on 2012-04-24 11:23

For the 4.39 :
pkgname=clamtk
pkgver=4.39
pkgrel=1
pkgdesc="ClamTk is a GUI front-end for ClamAV using gtk2-perl. It is designed to be an easy-to-use, lightweight, point-and-click desktop viru$
arch=('any')
url="http://clamtk.sourceforge.net/"
license=('GPL')
depends=('clamav' 'perl' 'gtk2-perl' 'udev' 'perl-date-calc' 'perl-locale-gettext' 'perl-file-find-rule' 'perl-libwww' 'perl-net-dns' 'perl-http-message')
install='clamtk.install'
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('d32651709064b42a047807820cdfa085')

postblue commented on 2012-04-24 11:22

For the 4.39 :
pkgname=clamtk
pkgver=4.39
pkgrel=1
pkgdesc="ClamTk is a GUI front-end for ClamAV using gtk2-perl. It is designed to be an easy-to-use, lightweight, point-and-click desktop viru$
arch=('any')
url="http://clamtk.sourceforge.net/"
license=('GPL')
depends=('clamav' 'perl' 'gtk2-perl' 'udev' 'perl-date-calc' 'perl-locale-gettext' 'perl-file-find-rule' 'perl-libwww' 'perl-net-dns' 'perl-h$
install='clamtk.install'
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('d32651709064b42a047807820cdfa085')

blackhole commented on 2011-10-26 10:32

Problems with file associations! Now If I double click a file not already associated to some app clamtk will start. How do I fix this?

blaztinn commented on 2011-10-19 06:12

Thx for reporting. I think it should be fixed now.

Anonymous comment on 2011-10-18 23:55

install file isn't an array, gives error " ==> ERROR: install file (('clamtk.install')) does not exist. "

blaztinn commented on 2011-08-21 20:30

perl-libwww should be enough because perl-http-message is a depency of perl-libwww.

Anonymous comment on 2011-08-21 19:26

Now Work! Add perl-http-message to the dependency!

Anonymous comment on 2011-08-21 19:23

Now Work! Add perl-http-message to the dependency!

blaztinn commented on 2011-08-21 17:46

Do you have a file /usr/share/perl5/vendor_perl/HTTP/Request.pm? It's owned by perl-http-message, a dependency of perl-libwww. Because path /usr/share/perl5/vendor_perl is in @INC, HTTP/Request.pm should be found if it is there.

Anonymous comment on 2011-08-21 15:59

~$ clamtk
Can't locate HTTP/Request.pm in @INC (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/perl5/vendor_perl/LWP/UserAgent.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/LWP/UserAgent.pm line 10.
Compilation failed in require at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 28.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 28.
Compilation failed in require at /usr/bin/clamtk line 22.
BEGIN failed--compilation aborted at /usr/bin/clamtk line 22.

~$ yaourt -Ss gtk2-perl
extra/gtk2-perl 1.222-3 [installed]
Gtk2-Perl allows Perl developers to write GTK+ 2.x applications.
aur/clamtk 4.34-1 [installed] (282)
ClamTk is a GUI front-end for ClamAV using gtk2-perl. It is designed to be an easy-to-use, lightweight, point-and-click desktop
virus scanner for Linux.

~$ yaourt -Ss perl-libwww
testing/perl-libwww 6.02-1 [installed]
The World-Wide Web library for Perl
extra/perl-libwww 5.837-1 [installed: 6.02-1]
A set of Perl modules which provides a simple and consistent API to the WWW

macxcool commented on 2011-05-02 17:05

4.32 is out as of April 25

flow commented on 2011-01-10 13:07

466df1699b0e726c36bd119712e32335 clamtk-4.31.tar.gz

blaztinn commented on 2010-08-20 16:09

Updated the package and removed inode/directory from clamtk.desktop. I think this should fix the problems you are having.

alphazo commented on 2010-08-19 21:04

I get the same problem as described in this post: https://bbs.archlinux.org/viewtopic.php?id=96701
Basically all my folders found my "Places" can no longer be accessed with Nautilus from this convenient menu. Instead, clamtk shows up and scan the directory.

blaztinn commented on 2010-07-13 09:04

On authors webpage there is for '4.27 release' written: "...A dependency on hal was added...".
Nevertheless I moved hal to optional dependencies because it seems to work without it. If anyone notices any problem please notify me.

zhuk_av, thx for the info.

zhuk_av commented on 2010-07-13 08:41

Is 'hal' really needed as a dependency here? I've built clamtk without 'hal' and it's working fine. Maybe 'hal' should be moved to optional dependencies if it's usage adds some features and is not essentional for main functions.