Package Details: cloak-gtk2-gtk3-theme 3.20.2_04172016-2

Git Clone URL: https://aur.archlinux.org/cloak-gtk2-gtk3-theme.git (read-only)
Package Base: cloak-gtk2-gtk3-theme
Description: A clean dark theme for GTK3 / GTK2, Gnome-Shell-Theme, Metacity Theme
Upstream URL: http://killhellokitty.deviantart.com/art/Cloak-3-20-2-04172016-603341133?q=gallery%3Akillhellokitty%2F26771632&qo=0
Keywords: GTK2 GTK3 Theme
Licenses: CC
Submitter: warlock9000
Maintainer: warlock9000
Last Packager: warlock9000
Votes: 7
Popularity: 0.014126
First Submitted: 2016-04-18 06:40
Last Updated: 2016-05-10 05:30

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

abdulhakeem commented on 2018-11-16 09:18

I think this could use an update, it's been like 2 years since it's been updated. Whenever I do anything GUI related from terminal, I get all kinds of GTK errors. Example:

(python:3849): Gtk-WARNING **: 03:15:51.474: Theme parsing error: gtk-contained.css:3521:55: Using one color stop with linear-gradient() is deprecated.

Better example: https://imgur.com/Hzm4DnX

This particular example was from trying to run a python program that uses pyperclip.

I guess something about this theme is deprecated? So if it could be updated/fixed that would be super helpful. Thanks!

EDIT: It looks like there is an updated version here, updated for GTK 3.22: https://github.com/killhellokitty/Cloak-3.22

Any way we can get this AUR package updated with the newest version? I'd do it myself but I don't know how

warlock9000 commented on 2016-05-10 05:32

GI_Jack, ok

GI_Jack commented on 2016-04-27 14:37

also replace dependency gnome-shell-extension-user-theme with gnome-shell-extensions which includes user theme

GI_Jack commented on 2016-04-27 14:06

please remove the following line from this PKGBUILD:

chmod 644 -R "$pkgdir/usr/share/themes"

do not set directory permissions 644, ever. directories always need the eXecute bit or they simply do not work.

http://accc.uic.edu/service/shell-accounts/basic-unix

jo-shva commented on 2016-04-26 11:45

Hello, I am killhellokitty the creator of this theme. First, I would like to say I appreciate your enthusiasm in posting my theme on the AUR. However, it is considered polite to ask the artists permission first. I would have given it to you as I prefer not to manage repos. In the future please speak with the artist first explaining your intentions. Next, the package is 2 versions behind the master. If you wish to manage the repos, please keep it up to date. I do make changes quickly in the initial phases of building the theme. Next the license is wrong, it is GPL3. Also the package permissions are incorrect, they are currently 644, they need to be 755. Again, thank you for your enthusiasm, and I look forward to hearing from you.
Killhellokitty - cheers!