Package Details: cloog 0.20.0-1

Git Clone URL: (read-only)
Package Base: cloog
Description: Library that generates loops for scanning polyhedra
Upstream URL:
Keywords: lib
Licenses: GPL
Submitter: haawda
Maintainer: aaronfischer (nougad)
Last Packager: aaronfischer
Votes: 66
Popularity: 0.088288
First Submitted: 2014-11-19 12:18
Last Updated: 2018-09-10 18:22

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

aaronfischer commented on 2018-03-07 08:18

@gmes78: Oh, thank you! I've made a mistake on the last commit. Should be installed without conflicting files now.

gmes78 commented on 2018-03-06 00:28

Now the cloog package conflicts with the isl package, as it installs /usr/lib/, /usr/lib/pkgconfig/isl.pc and /usr/include/isl/*.

It would be better to make a separate isl 0.18 package and depend on it, or statically link to isl 0.18 (not sure how good of an idea that is, though).

aaronfischer commented on 2018-03-05 22:23

@gmes78: Thanks for reporting that. I've changed the build process so the bundled isl version is used (0.18x). This should fix the problem for now until the bug is fixed upstream.

gmes78 commented on 2018-03-05 21:16

cloog fails to build with isl 0.19, giving a bunch of undefined reference errors.

millerl commented on 2017-05-23 13:30

For what it's worth, this worked for me:
$ sudo pacman -Rdd isl15; yaourt -Syua

marcvangend commented on 2017-05-04 10:26

Circular dependency problem: I could not replace isl15 with isl because cloog depends on it. I could not update cloog because it needs isl>=0.18. I ended up building isl with my AUR tool (I use Trizen) and installing it while ignoring all dependency checks: `sudo pacman -U -dd isl-0.18-1-x86_64.pkg.tar.xz`. After that I was able to update cloog (just `trizen -Syu`).

win_chen commented on 2017-05-04 01:47

isl and isl15 are in conflict.

aaronfischer commented on 2017-05-03 22:14

Thanks to the error reporting. I've added strict version dependency to isl.

cfr42 commented on 2017-05-03 22:05

The problem is that isl15 provides isl, so it isn't enough for cloog to declare a dependency on isl. It needs to give a suitable version specification.

bitsfritz commented on 2017-05-03 14:31

cloog stops working with isl15:

installing recent isl(0.18-1) solves the issue, but isl15 is still mentioned as sufficient dependency. Thus update isn't required and cloog doesn't compile.