Package Details: closure-compiler 20181210-1

Git Clone URL: https://aur.archlinux.org/closure-compiler.git (read-only)
Package Base: closure-compiler
Description: Performs checking, instrumentation and optimizations on Javascript code.
Upstream URL: https://developers.google.com/closure/compiler/
Licenses: Apache
Submitter: Barthalion
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 2
Popularity: 0.029215
First Submitted: 2018-01-06 19:14
Last Updated: 2018-12-15 21:20

Latest Comments

aaronfischer commented on 2018-12-15 21:21

Thank you for your suggestion @milaxnuts.

milaxnuts commented on 2018-12-09 16:55

same here

[WARNING] Unable to autodetect 'javac' path, using 'javac' from the environment.
[INFO]    [ERROR] Hint: Check that your module inherits 'com.google.gwt.core.Core'

javac -version
javac 10.0.2

readlink -f $(which javac)
/usr/lib/jvm/java-10-openjdk/bin/javac

pacman -Qqs ^jdk
jdk10-openjdk

sudo pacman -S jdk8-openjdk

PATH="/usr/lib/jvm/java-8-openjdk/bin:$PATH" javac -version
javac 1.8.0_192

PATH="/usr/lib/jvm/java-8-openjdk/bin:$PATH" pikaur -S closure-compiler

hard-coding that path into pkgbuild should be fine
since jdk8-openjdk is the only jdk8 in arch repos

Flesh commented on 2018-04-19 01:05

They switched to JDK8, it is not in conflict with 7 and will not install with that in there, so please remove it, I need 7, and 7 and 8 can be installed at the same time; that is normal in fact; noticed comment below about having to remove it, when that should not be case, you should be able to install all versions of Java at the same time, that was why they did it the way they did, I tested it and it works fine once I edited the package and removed the conflict.

Thanks

aaronfischer commented on 2018-04-18 19:24

Thank you @fabb for the error report and the steps to fix that. I've pinned the java version to 8 and update the package.

fabb commented on 2018-03-14 03:55

Hi.

I had the same issue as itsme mentioned. First I did test with the new version of closure-compiler (20180204) by changing the version in PKGBUILD and its sha256sums but I had the same issue

Then I've seen that I had had bits of jdk 7 and jre 7 installed at the same time as version 8. I removed all the versions 7 and closure-compiler package built fine.

If it helps someone.

Regards, Fabrice

itsme commented on 2018-02-07 08:36

https://pastebin.com/d2U91nFk