Package Details: cloud-print-connector-git v1.16.r7.gcee4c3e-2

Git Clone URL: https://aur.archlinux.org/cloud-print-connector-git.git (read-only, click to copy)
Package Base: cloud-print-connector-git
Description: Share printers from your Windows, Linux, FreeBSD or OS X computer with ChromeOS and Android devices, using the Cloud Print Connector
Upstream URL: https://github.com/google/cloud-print-connector
Licenses: BSD
Conflicts: gcp-cups-connector
Provides: cloud-print-connector
Replaces: gcp-cups-connector
Submitter: grimsock
Maintainer: kxuan
Last Packager: kxuan
Votes: 9
Popularity: 0.000000
First Submitted: 2018-06-07 11:16
Last Updated: 2020-05-27 06:52

Latest Comments

1 2 3 Next › Last »

kxuan commented on 2020-05-27 06:55

I applys the pull request (https://github.com/google/cloud-print-connector/pull/475). It seems work.

dirtbag commented on 2020-04-12 17:07

Cant some brave soul fix this broke package? ;)

-db

archer1337 commented on 2020-01-12 22:19

Currently, the build fails. Here is the output from makepkg -si:

cups.c: In function ‘getIPPRequestStatusCode’:
cups.c:42:12: error: dereferencing pointer to incomplete type ‘ipp_t’ {aka ‘struct _ipp_s’}
   42 |  return ipp->request.status.status_code;
      |            ^~
cups.c: In function ‘getAttributeDateValue’:
cups.c:47:13: error: dereferencing pointer to incomplete type ‘ipp_attribute_t’ {aka ‘struct _ipp_attribute_s’}
   47 |  return attr->values[i].date;
      |             ^~

Nowaker commented on 2018-10-11 04:51

Can you change the pkgdesc to the below one? It will help those who search by Google Cloud Print. Thanks!

pkgdesc="Share printers from your Windows, Linux, FreeBSD or OS X computer with ChromeOS and Android devices, using the Google Cloud Print Connector"

ejona86 commented on 2018-06-17 23:12

This package fails to "provides=('gcp-cups-connector')". That means it does not satisfy the dependencies necessary for the previous version of gcp-cups-connector-systemd during an upgrade.

ejona86 commented on 2018-04-07 19:50

Since there's been releases for a while now, would it make sense to convert this to a non-git package?

ejona86 commented on 2018-01-06 22:21

https://github.com/satori/go.uuid/issues/66 discusses the breakage. I manually ran git checkout 0ef6afb2^ in src/github.com/satori/go.uuid to workaround.

ejona86 commented on 2018-01-06 20:12

'gcp-connector-util update-config' isn't an option any longer.

I'm seeing the build failure. It seems an up-stream problem: src/github.com/google/cups-connector/gcp-connector-util/init.go:417:26: multiple-value uuid.NewV4() in single-value context

grimsock commented on 2017-12-27 21:54

@lesto Package updated. Try now.

lesto commented on 2017-11-10 19:15

# github.com/google/cloud-print-connector/cups
cgo-gcc-prolog: In function ‘_cgo_36557f5c9d03_Cfunc_memset’:
cgo-gcc-prolog:380:4: internal compiler error: Segmentation fault