Package Details: cndrvcups-lb 3.70-1

Git Clone URL: https://aur.archlinux.org/cndrvcups-lb.git (read-only)
Package Base: cndrvcups-lb
Description: CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
Upstream URL: https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
Keywords: Canon Printer
Licenses: custom
Conflicts: cndrvcups-lb-cpca
Submitter: Lone_Wolf
Maintainer: severach (Lone_Wolf)
Last Packager: severach
Votes: 78
Popularity: 0.013597
First Submitted: 2012-04-22 13:50
Last Updated: 2019-02-18 09:06

Dependencies (10)

Required by (0)

Sources (3)

Pinned Comments

Lone_Wolf commented on 2016-02-24 20:33

i'm not surprised pacaur (and likely any aur helper) has problems building this.

The reason for the versioned dependency on cndrvcups-common-lb is that a cndrvcups-lb version ONLY works with 1 specific cndrvcups-common-lb version .

The correct way to build them goes like this :

build new cndrvcups-common-lb
remove old cndrvcups-lb version (if present on system)
install new cndrcups-common-lb
build & install new cndrvcups-lb version

Easiest way to build this with pacaur : use 2 commands like this :
pacaur -S cndrvcups-common-lb
pacaur -S cndrvcups-lb

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

zespri commented on 2018-01-29 21:19

Can confirm your solution, @severach. Thank you!

Edit 2018-02-01: Aaaand it's broken again, probably after the last cups updates.

severach commented on 2018-01-28 09:44

I recompiled glibc and lib32-glibc 2.26 with all protection turned off and that didn't work.

https://askubuntu.com/questions/314833/diagnosing-the-problem-when-canon-printer-fails-to-print-under-ubuntu

This can be fixed by downgrading or substituting the crashing segfault /usr/bin/cnpkmoduleufr2 from an old version. cnpkmoduleufr2 3.00 - 3.20 are tested and working. Newer versions are likely to break less printers. cnpkmoduleufr2 versions >3.20 - 3.40 are tested and do not work. No problems with a current version of c3pldrv.

I have cndrvcups-lb-bin printing UFR II on a Canon imageRUNNER iR1730.

I also packaged canon-cque for those with the PXL and PS licenses.

The SELinux problem is because cnpkmoduleufr2 is suid. There is no code in the RPM to register the binary with SELinux or AppArmor.

https://www.reddit.com/r/linux4noobs/comments/7tiemc/canon_mf4320_printer_does_not_print_and_cpu_hangs/

Lone_Wolf commented on 2018-01-24 16:41

The problem cause is most likely the removal of deprecated functionality in glibc 2.26+ .

Verify whether dmesg/journal show segfaults with the cnpkmoduleufr2 . If that's the case, try the downgrade described in NPL' comment from 2017-10-01 21:53

Ergo commented on 2018-01-23 20:25

Hi guys, after a long time without printing in the canoin ir3235N I tried today and I figured out that I can't. I get the c3pldrv process using 100% of CPU, no errors and not print job sent. I see that many people here got the same error and some propose different solutions (downgrade and so on). Could any of you tell me what's the actual working approach?

In a Centos forum someone related this error with selinux, but this is arch, selinux is not even supported.

I have an updated system and the latest driver version. Any solution or workaround?

Thanks in advance

axanar commented on 2017-12-13 14:00

@NPL thx for trying to help. I almost gave up printing and then problem was resolved by system update and remaking printer in CUPS web interface with PCL driver and ipp...

johnnybegood commented on 2017-12-01 10:10

@giostark
If you have problems with UFRII driver because of the latest gcc updates (as it's already been discussed in this thread), using CQue driver with PCL should be fine as long as you have sicgsfilter installed (as you do).

What I do when I use the PCL driver from CQue is that I look for the ppd file in the folder and I choose the option to add ppd file directly from that folder. I don't think you should have any problems by doing this. The driver is in:

https://www.canon-europe.com/support/products/imagerunner/irc3580-i.aspx?type=drivers&driverdetailid=tcm:13-1185460&os=Linux (64-bit)&language=EN

If you unzip it and open the ppd folder, you will find your model.

giostark commented on 2017-11-29 11:46

Hi
@johnnybegood :-)
I had a look here : Differences in Operation with UFR II, PCL, PS, and Direct Print Printers
http://ug.oipsrv.net/USRMA-0963-zz-CS-enUS/contents/CS5560_prset_0004.html
In the drivers list (3 for 3025Ne) the first was UFRII the other 2 are PCL, and I tried that one as first but it didnt work at all. (printed just few lines of strange characters even without the *** if you can read this...*** message)
I tried also all the rest and no one drivers print without that file.
@Lone_Wolf
Yep :-) Without cups and the canon drivers and sicgsfilter nothing work.


johnnybegood commented on 2017-11-25 19:43

As far as my knowledge goes, sicgsfilter has nothing to do with UFRII driver. It's a binary filter used by CQue driver, without which you cannot print. CQue is used to print in PCL5, PCL6 (PXL) and PostScript languages while UFRII uses a native language designed for Canon printers.

DoXer commented on 2017-11-18 18:53

Because giostark's link is broken...The full link is:
https://rpm.pbone.net/index.php3?stat=26&dist=0&size=33620&name=sicgsfilter-2.0.6-1.slc6.x86_64.rpm

Lone_Wolf commented on 2017-11-17 23:25

interesting find, giostark .

For some printers canon provides a cque driver that's supposed to work with cups & foomatic . sicgsfilter is included in that driver .

afaik there's no archlinux package for cque, when i looked into it a few months ago it seemed to be intended for manual installation by a user and not suited for a systemwide install.
Are you sure cups is using the cndrvcups-lb driver to connect with your printer and not the cque driver ?