Package Details: cndrvcups-lb 3.70-1

Git Clone URL: https://aur.archlinux.org/cndrvcups-lb.git (read-only)
Package Base: cndrvcups-lb
Description: CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
Upstream URL: https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
Keywords: Canon Printer
Licenses: custom
Conflicts: cndrvcups-lb-cpca
Submitter: Lone_Wolf
Maintainer: severach (Lone_Wolf)
Last Packager: severach
Votes: 78
Popularity: 0.013781
First Submitted: 2012-04-22 13:50
Last Updated: 2019-02-18 09:06

Dependencies (10)

Required by (0)

Sources (3)

Pinned Comments

Lone_Wolf commented on 2016-02-24 20:33

i'm not surprised pacaur (and likely any aur helper) has problems building this.

The reason for the versioned dependency on cndrvcups-common-lb is that a cndrvcups-lb version ONLY works with 1 specific cndrvcups-common-lb version .

The correct way to build them goes like this :

build new cndrvcups-common-lb
remove old cndrvcups-lb version (if present on system)
install new cndrcups-common-lb
build & install new cndrvcups-lb version

Easiest way to build this with pacaur : use 2 commands like this :
pacaur -S cndrvcups-common-lb
pacaur -S cndrvcups-lb

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 15 Next › Last »

Lone_Wolf commented on 2013-04-16 08:15

Recently i got a few emails from people asking if i could update this package.
This indicates that there is a demand for a maintained canon driver for their LBR/IR/MF printer.
Since no one stepped up to take care fo this package, i've decided to see if i can help out again.
As cndrvcups-common and cdnrvcups-lb need to be the same version, i'll focus on creating a cndrvcups-common 2.60 pacakge first.

Anonymous comment on 2013-04-07 16:47

==>Install or build missing dependencies for cndrvcups-lb:
оerror: the goal is not found: cndrvcups-common=2.40
==> Restart building cndrvcups-lb ? [y/N]
==> -------------------------------------
Help me please.
Canon MF 4410

Anonymous comment on 2013-04-07 15:52

Not working. The PKGBUILD seems to be for 2.40, whereas the package downloaded from the specified URL is 2.60. If you fix this, you'll run into another problem. The autotools seem to be too new and not backwards compatible or something. Changing in each autogen.sh the aclocal to aclocal-1.10 and automake to automake-1.10 seems to fix the problem. I still can't get my printer to work (I never have managed to get this MF4410 to print from Linux), but at least the package now compiles.

Lone_Wolf commented on 2013-03-29 09:26

https://aur.archlinux.org/packages/libx32-libxml2/

Anonymous comment on 2013-03-28 13:56

I am getting the message "Dependency `lib32-libxml2' of `cndrvcups-lb' does not exist."

aLambda commented on 2013-03-11 09:40

Not working. The PKGBUILD seems to be for 2.40, whereas the package downloaded from the specified URL is 2.60. If you fix this, you'll run into another problem. The autotools seem to be too new and not backwards compatible or something. Changing in each autogen.sh the aclocal to aclocal-1.10 and automake to automake-1.10 seems to fix the problem. I still can't get my printer to work (I never have managed to get this MF8330Cdn to print from Linux), but at least the package now compiles.

leduck commented on 2013-02-04 17:48

Working with Canon printers, I am lover of Arch linux and already use for some time. I decided today seeing the need of many, take responsibility for this package. Today I tested the driver and is working properly in a 64-bit system, only ask all some time to correctly packaging the driver and then I can help everyone. Sorry for my bad English.

Lone_Wolf commented on 2012-07-24 16:32

I am orphaning this package as there are too many problems with the canon drivers.

The canon printer of a friend of mine that used to work, hasn't been able to print anything for 2 months.
No error messages are found, downgrading to a 3.2 kernel and downgrading cups have all been in vain.
The printer doesn't work with the latest versions of Mint & opensuse.

I'll advise my friend to sell the printer to someone who only uses windows.

Anonymous comment on 2012-07-20 06:29

Regarding the ufrii-2.1 package status, it goes not. The old versions of the drivers won't compile at all now. The binary versions don't work either. To boot, the latest version of the cups-filters package is completely broken on all five of my office systems across both i686 and AMD64, and the previous version doesn't work with the new glibc package (which was a mess all on its own, and completely failed to update on two of my installs despite following the directions to the letter). I'd post a comment about the breakage of cups-filters through the proper channels, but I give up on this package and on Arch. I'm declaring the old drivers and this new cups-filters bug unmanagable, moving all eight of my computers to a different distro (probably Fedora), and never buying or selling a Canon printer again. If someone else wants to pick it up, great. None of my code does anything useful, though, and I've got nothing to contribute as a result. I'm not angry at anyone here, just thoroughly frustrated and tired of the battles Arch and Canon have forced me to fight time and again. I appreciate the support you've shown, but feel it's better that I just walk away now. Good luck to whomever may pick up the torch, and may they find themselves better luck than mine.

Lone_Wolf commented on 2012-07-03 12:21

using my packages as templates is fine, and i expect maintenance will be limited to building it a few times per year to verify if it still builds/works with new versions of it's dependencies / new cups versions.

Please check what canon calls the driver/where things should go (the rpm .spec file in the source is very handy for that).