Package Details: cndrvcups-lb 3.70-1

Git Clone URL: https://aur.archlinux.org/cndrvcups-lb.git (read-only)
Package Base: cndrvcups-lb
Description: CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
Upstream URL: https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
Keywords: Canon Printer
Licenses: custom
Conflicts: cndrvcups-lb-cpca
Submitter: Lone_Wolf
Maintainer: severach (Lone_Wolf)
Last Packager: severach
Votes: 78
Popularity: 0.012992
First Submitted: 2012-04-22 13:50
Last Updated: 2019-02-18 09:06

Dependencies (10)

Required by (0)

Sources (3)

Pinned Comments

Lone_Wolf commented on 2016-02-24 20:33

i'm not surprised pacaur (and likely any aur helper) has problems building this.

The reason for the versioned dependency on cndrvcups-common-lb is that a cndrvcups-lb version ONLY works with 1 specific cndrvcups-common-lb version .

The correct way to build them goes like this :

build new cndrvcups-common-lb
remove old cndrvcups-lb version (if present on system)
install new cndrcups-common-lb
build & install new cndrvcups-lb version

Easiest way to build this with pacaur : use 2 commands like this :
pacaur -S cndrvcups-common-lb
pacaur -S cndrvcups-lb

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

giostark commented on 2017-11-17 21:49

This is just a communication about how i managed to solve this damn trick. To connect and make work this imageRUNNER 3025 network printer.
Why i post? Im a noob and I wasted so much time because the message of error printed was misleading.

Arch last -Syu. On Plasma desktop.
Cups wiki applied for service , user group and permissions, ecc ecc

How to reproduce the problem:
1)Install from aur ("cndrvcups-lb") or by hand (ppd from Canon site) the printer manufacturer drivers for the iR series (and model)
2)Configure the network printer.
3)Try to print receiving this message on every self test printed. None other sheet was printed:

*** if you can read this you are using the wrong driver for your printer ***

This make you think the error is in the drivers it self. Damn not at all.
In the printer queue the error that appear is "filter failed". This make me think something must be investigated:

# tail /var/log/cups/error_log
D [17/Nov/2017:16:54:28 +0100] [Job 53] /bin/bash: sicgsfilter: command not found
D [17/Nov/2017:16:54:28 +0100] [Job 53] renderer exited with status 127
D [17/Nov/2017:16:54:28 +0100] [Job 53] Kid3 exit status: 1
D [17/Nov/2017:16:54:28 +0100] [Job 53] PID 1275 (/usr/lib/cups/filter/foomatic-rip) stopped with status 9.
D [17/Nov/2017:16:54:28 +0100] [Job 53] Hint: Try setting the LogLevel to "debug" to find out more.
D [17/Nov/2017:16:54:28 +0100] [Job 53] PID 1276 (/usr/lib/cups/backend/socket) exited with no errors.
D [17/Nov/2017:16:54:28 +0100] [Job 53] End of messages
D [17/Nov/2017:16:54:28 +0100] [Job 53] printer-state=3(idle)
D [17/Nov/2017:16:54:28 +0100] [Job 53] printer-state-message="Filter failed"
D [17/Nov/2017:16:54:28 +0100] [Job 53] printer-state-reasons=none

Fine ,where damn i found this "sicgsfilter"?
https://rpm.pbone.net/index.php3?stat=26&dist=0&size=33620&name=sicgsfilter-2.0.6-1.slc6.x86_64.rpm
"$ rpmextract.sh sicgsfilter-2.0.6-1.slc6.x86_64.rpm"
Copied the sicgsfilter executable in /usr/local/bin .
Linked in /bin with :
"$ ln -s /usr/local/bin/sicgsfilter /bin"

The main drivers need this executable for work but is missing.

Now the damn printer print what i send to it.

NPL commented on 2017-11-12 14:07

@axanar, I didn't see your message. Sorry. Did you resolve your problem ?

Maybe you have to delete all the dependencies with yaourt --remove :
cndrvcups-common-lb
cndrvcups-lb
lib32-libxml2
libxml2

Then try to upgrade your system : yaourt -Syuu

After that, you have to downgrade lib32-glibc package : pacman -U /var/cache/pacman/pkg/glibc-2.25-7-x86_64.pkg.tar.xz

And at the end you can restart cupsd : sudo systemctl restart org.cups.cupsd.service

axanar commented on 2017-10-30 09:18

@NPL I updated all the packages and then downgraded lib32-glibc to 2.25-7, restarted but i have same problem. I tried reinstalling drivers and making new printer but no luck... What am i missing? I really want this to work :-/

NPL commented on 2017-10-29 15:03

Lone_Wolf, I try to update all the packages, then I was not able to print.

So I downgraded only lib32-glibc to 2.25-7 version and printing works again. That's a good thing ! Hope to see an updade from Canon very soon

If people want it, the lib32-glibc package is here http://martchus.no-ip.biz/repo/arch/official/os/x86_64/lib32-glibc-2.25-7-x86_64.pkg.tar.xz

johnnybegood commented on 2017-10-10 12:01

Unfortunately, C libraries are very important for the system and downgrading them is generally not a good idea. I really hope the next version released by Canon fixes this issue.
I have managed to fix sddm, which also stopped working after the latest update, with 'glibc' and 'binutils' up to date. The only package that remains downgraded is 'lib32-glibc' (2.25-7) and printing seems to be working so far.

operating commented on 2017-10-06 11:40

Used downgrade method, until today lightdm stopped working because glibc was <2.26 so had to give up printing in order to use X server :D

axanar commented on 2017-10-02 07:01

Downgrading libxml2, binutils, glibc and lib32-glibc is not working for me. I cant print and get 100% CPU when i start CUPS. What should i try next?

NPL commented on 2017-10-01 19:53

I had the same error with c3pldrv process hanging 100% cpu without end.

Downgrade libxml2 did not work for me but thanks to johnnybegood, I downgrade 'binutils', 'glibc' and 'lib32-glibc' to previous versions (2.28 and 2.25) :

$ sudo pacman -U /var/cache/pacman/pkg/binutils-2.28.0-4-x86_64.pkg.tar.xz
$ sudo pacman -U /var/cache/pacman/pkg/lib32-glibc-2.25-7-x86_64.pkg.tar.xz
$ sudo pacman -U /var/cache/pacman/pkg/glibc-2.25-7-x86_64.pkg.tar.xz

I restarted cupds and everything seems to get back to normal like I can print again.

johnnybegood commented on 2017-09-22 10:37

I got the following error:

[ 6026.818234] cnpkmoduleufr2[3639]: segfault at 0 ip 00000000f757eb63 sp 00000000fff01b10 error 4 in libc-2.26.so[f74fe000+1cf000]

After downgrading 'binutils', 'glibc' and 'lib32-glibc' to previous versions (2.28 and 2.25), everything seems to get back to normal again.

operating commented on 2017-09-22 08:43

Yes, have same error messages as DoXer:

Sep 14 15:00:19 zen systemd-coredump[4304]: Process 4302 (cnpkmoduleufr2) of user 2 dumped core.

Stack trace of thread 4302:
#0 0x00000000f7dc2b63 __strtok_r (libc.so.6)
#1 0x000000000805931d n/a (cnpkmoduleufr2)
#2 0x000000000804a8ec n/a (cnpkmoduleufr2)
#3 0x0000000008049547 n/a (cnpkmoduleufr2)
#4 0x0000000008049ea0 n/a (cnpkmoduleufr2)
-- Subject: Process 4302 (cnpkmoduleufr2) dumped core