Package Details: cndrvcups-lb 3.70-1

Git Clone URL: https://aur.archlinux.org/cndrvcups-lb.git (read-only)
Package Base: cndrvcups-lb
Description: CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
Upstream URL: https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
Keywords: Canon Printer
Licenses: custom
Conflicts: cndrvcups-lb-cpca
Submitter: Lone_Wolf
Maintainer: severach (Lone_Wolf)
Last Packager: severach
Votes: 78
Popularity: 0.023146
First Submitted: 2012-04-22 13:50
Last Updated: 2019-02-18 09:06

Dependencies (10)

Required by (0)

Sources (3)

Pinned Comments

Lone_Wolf commented on 2016-02-24 20:33

i'm not surprised pacaur (and likely any aur helper) has problems building this.

The reason for the versioned dependency on cndrvcups-common-lb is that a cndrvcups-lb version ONLY works with 1 specific cndrvcups-common-lb version .

The correct way to build them goes like this :

build new cndrvcups-common-lb
remove old cndrvcups-lb version (if present on system)
install new cndrcups-common-lb
build & install new cndrvcups-lb version

Easiest way to build this with pacaur : use 2 commands like this :
pacaur -S cndrvcups-common-lb
pacaur -S cndrvcups-lb

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

johnnybegood commented on 2017-09-21 21:16

I have exactly the same problem: Processing - "Unsupported booklet value None, using booklet=off!" However, I have seen this error previously and you can fix it by modifying the corresponding ppd file (changing from None to Off in the Booklet option). It is not the real problem, it is simply a warning.

There must have been some update that has made this UFRII driver suddenly stop working. I have tried downgrading a few packages with no luck. Hopefully we will find a solution soon.

operating commented on 2017-09-21 16:35

Seems I recently have problems printing on canon ir2022 using this package. Everytime I try to print process cnpkmoduleufr2 dumps core, and c3pldrv process stays hanging (100% cpu), strace shows it is trying to read something :) Kernel versions dont influence it, dont have ideas where to start looking. Contact me in case you need more info. Thanks!

Lone_Wolf commented on 2017-09-21 13:38

The booklet option sounds like it could come from an office application.

Testing with plain pure text helps to determnine whether a problem is related to a specific documenttype or application.
If that works, basic printer functionality is intact.

to get more info about the problem :
print something, check /var/log/cups/error.log .
if the info there is not enough, set cups loglevel to debug (see cups troubleshooting page in wiki) and print again.
post the log somewhere.


axanar commented on 2017-09-21 12:41

Downgrading libxml2 did not work for me.

@Lone_Wolf
If pure text does not print, does that mean that problem might be elsewhere?

Lone_Wolf commented on 2017-09-21 10:11

@echonitrix :
try downgrading libxml2 to see if that helps.

If it doesn't, try printing a pure text document, like /etc/pacman.conf .

zespri commented on 2017-09-21 09:21

@axanar: Did you try to downgrade this package?

axanar commented on 2017-09-21 07:02

No SELinux on my system. I found "upgraded libxml2 (2.9.5rc2+0+g69936b12-1 -> 2.9.5+6+g07e227ed-1)" in logs and there is libxml2 listed in dependencies. Can this update be the cause of the problem?

zespri commented on 2017-09-20 13:09

Yes, printing stopped working here, too. Culprit seems to be a crashing c3pldrv using 100% of a core. Found a similar issue here: https://www.centos.org/forums/viewtopic.php?t=50701
I don't have SELinux enabled on my system though, so that solution is none here. Anyone can confirm?

echinotrix commented on 2017-09-20 10:59

axanar: "For some reason this stopped to work for me and i do not know to fix it. CUPS status gives : Processing - "Unsupported booklet value None, using booklet=off! Please help."

Same here. I cannot print since last system update.

axanar commented on 2017-09-20 07:51

For some reason this stopped to work for me and i do not know to fix it. CUPS status gives : "Processing - "Unsupported booklet value None, using booklet=off!"
Please help.