Package Details: cnijfilter-mg5300 3.60-8

Git Clone URL: https://aur.archlinux.org/cnijfilter-mg5300.git (read-only)
Package Base: cnijfilter-mg5300
Description: Canon IJ Printer Driver (for mg5300 series)
Upstream URL: http://support-au.canon.com.au/contents/AU/EN/0100392802.html
Licenses: custom
Conflicts: cnijfilter-common
Submitter: hermes14
Maintainer: Sonic-Y3k
Last Packager: Sonic-Y3k
Votes: 9
Popularity: 0.025682
First Submitted: 2011-10-13 10:56
Last Updated: 2016-08-16 14:40

Latest Comments

babatong commented on 2016-08-19 20:10

It works indeed, thank you very much.

Sonic-Y3k commented on 2016-08-16 14:39

Okay, does it work now?

babatong commented on 2016-08-16 12:51

Not sure why this is, but after install, when trying to print, it complained about missing libraries. Basically it was missing all the libcnbp ones of version 389. The PKGBUILD installs 393.

In order to temporary fix this, simply change the library installation bit of the PKGBUILD to reference the older libs (they also get built during compilation).

brofi commented on 2015-02-08 19:26

Fix: Missing package() function: http://pastebin.com/Ki9j6L49

hermes14 commented on 2013-04-12 17:54

You're welcome :)

Anonymous comment on 2013-04-12 17:46

Hi hermes, I am stealing your patches for my package: I am going to add you to the contributors' list. :-)

hermes14 commented on 2013-04-11 15:15

@yochaigal
The relevant changes are in build-fixes.patch.

yochaigal commented on 2013-04-11 12:56

Thanks so much!
What did you have to do?

hermes14 commented on 2013-04-11 11:42

Ok, it's working again.
Sorry for the huge delay.

yochaigal commented on 2013-04-10 00:13

I'm having problems because of automake... see here:

https://bbs.archlinux.org/viewtopic.php?id=160972

hermes14 commented on 2013-04-09 20:25

I get a massive amount of compilation errors. I solved some of them, but I'm still stuck.
I don't have time or knowledge to fix all of them, so I'd be glad it someone could help me. Otherwise I'll have to disown the package.

yochaigal commented on 2013-03-13 04:31

I'm having the same error halfur is having - I have not figured out which config headers to change yet.

halfur commented on 2013-01-11 17:27

I'm having trouble with compiling this under x86_64.

After automake and aclocal output this warning:
"autoconf input should be named 'configure.ac', not 'configure.in'"

real trouble begins here:
"configure.in:28: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:28: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1"

Here's the complete build output:
http://pastebin.com/HbqHzpXi

hermes14 commented on 2012-08-26 19:46

Glad to hear that!

keepitsimpleengr commented on 2012-08-26 18:52

Compiled and printed successfully on i686 & i86_64. Thanks!

hermes14 commented on 2012-08-26 02:31

Should compile now.

keepitsimpleengr commented on 2012-08-20 17:06

Full terminal output for x86_64 makepkg failure is posted here: http://pastebin.com/S2rpbMPE

keepitsimpleengr commented on 2012-08-19 23:22

I tried installing this driver in 32bit and 64bit got the error: "ERROR: A failure occurred in build(). Aborting..."

Lots of messages like these:
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type
bjcupsmon_cups.c:583:11: error: dereferencing pointer to incomplete type