Package Details: cobang 0.9.4-1

Git Clone URL: https://aur.archlinux.org/cobang.git (read-only, click to copy)
Package Base: cobang
Description: A QR code scanner desktop app for Linux
Upstream URL: https://github.com/hongquan/CoBang
Licenses: GPL3
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 6
Popularity: 0.22
First Submitted: 2020-06-08 02:49
Last Updated: 2021-09-14 16:53

Latest Comments

trung254 commented on 2021-09-20 14:32

thanks @yochananmarqos, i get it. Sorry for mess in my post

yochananmarqos commented on 2021-09-19 14:57

@trung254: Please use proper formatting when posting terminal output, it's very hard to read any of that.

You need to build the AUR dependencies first.

trung254 commented on 2021-09-19 08:38

I install from PKGBUILD get this error:

❯ makepkg -si ==> Making package: cobang 0.9.4-1 (Sun Sep 19 15:33:21 2021) ==> Checking runtime dependencies... ==> Installing missing dependencies... error: target not found: python-kiss-headers ==> ERROR: 'pacman' failed to install missing dependencies. ==> Missing dependencies: -> python-kiss-headers ==> Checking buildtime dependencies... ==> ERROR: Could not resolve all dependencies. ❯ sudo pacman -S python-kiss-headers error: target not found: python-kiss-headers

install from AUR get the same: ==> Starting check()... =================================== test session starts =================================== platform linux -- Python 3.9.7, pytest-6.2.5, py-1.10.0, pluggy-0.13.1 rootdir: /home/trung/.cache/yay/python-kiss-headers/src/kiss-headers-2.3.0, configfile: setup.cfg plugins: cov-2.12.1 collected 56 items
kiss_headers/init.py F [ 1%] kiss_headers/api.py . [ 3%] kiss_headers/builder.py ........... [ 23%] kiss_headers/models.py .......................... [ 69%] kiss_headers/utils.py ................. [100%] ======================================== FAILURES ========================================= _____ [doctest] kiss_headers _____ 001 002 Kiss-Headers 003 ~~~~~~~~~~~~~~ 004 005 Kiss-Headers is a headers, HTTP or IMAP4 (message, email)_ flavour, utility, written in pure Python, for humans. 006 Object oriented headers. Keep it sweet and simple. 007 Basic usage: 008 009 >>> import requests UNEXPECTED EXCEPTION: ModuleNotFoundError("No module named 'requests'") Traceback (most recent call last): File "/usr/lib/python3.9/doctest.py", line 1336, in run exec(compile(example.source, filename, "single", File "<doctest kiss_headers[0]>", line 1, in <module> ModuleNotFoundError: No module named 'requests' /home/trung/.cache/yay/python-kiss-headers/src/kiss-headers-2.3.0/kiss_headers/init.py:9: UnexpectedException

----------- coverage: platform linux, python 3.9.7-final-0 ----------- Name Stmts Miss Cover Missing


kiss_headers/init.py 5 0 100% kiss_headers/api.py 77 54 30% 32-105, 112-135, 154, 161-164, 168, 173, 179-180, 186 kiss_headers/builder.py 392 112 71% 43, 131, 183, 244, 313, 342, 350-353, 471, 509, 523, 538, 547, 563-570, 622-625, 638, 642, 648, 689-720, 724, 728, 740, 744, 748, 772-782, 786, 790, 794, 807, 828-843, 863, 881-885, 889, 905, 917, 946-955, 959, 963, 967, 971, 975, 1001-1005, 1022, 1041, 1058-1072, 1084, 1110-1114, 1121, 1144, 1167-1174, 1200-1211, 1254, 1284, 1300, 1317-1325, 1368, 1372, 1376, 1412-1432, 1446, 1461, 1474, 1497-1506, 1524, 1536, 1550, 1565 kiss_headers/models.py 581 109 81% 48, 80, 100, 105, 202-203, 274-277, 283-302, 308-311, 330-332, 341, 363, 386, 397-398, 406, 413, 436, 443, 455, 475, 504-507, 519, 530, 537, 544, 560, 578, 668, 681, 715, 739-748, 770, 794, 800, 827, 846-859, 871, 885, 897-898, 913-914, 933-936, 946, 975-981, 997, 1023, 1033, 1047-1050, 1054, 1067, 1072-1077, 1153, 1162, 1166, 1172-1173, 1180, 1218, 1236-1242, 1247, 1250, 1293, 1363, 1423, 1475 kiss_headers/serializer.py 37 33 11% 10-34, 41-66 kiss_headers/structures.py 33 7 79% 72, 75-80, 84, 87 kiss_headers/utils.py 144 14 90% 96, 172, 175, 205, 255, 331-333, 341-342, 359, 362, 430-433 kiss_headers/version.py 2 0 100%


TOTAL 1271 329 74% ============================== 1 failed, 55 passed in 0.34s =============================== ==> ERROR: A failure occurred in check(). Aborting... checking dependencies... Packages (8) python-apipkg-1.5-5 python-coverage-5.5-2 python-iniconfig-1.1.1-1 python-pluggy-0.13.1-4 python-py-1.10.0-1 python-pytest-6.2.5-1 python-pytest-cov-2.12.1-3 python-toml-0.10.2-3 Total Removed Size: 4.91 MiB :: Do you want to remove these packages? [Y/n] :: Processing package changes... (1/8) removing python-pytest-cov [-----------------------------] 100% (2/8) removing python-coverage [-----------------------------] 100% (3/8) removing python-pytest [-----------------------------] 100% (4/8) removing python-toml [-----------------------------] 100% (5/8) removing python-py [-----------------------------] 100% (6/8) removing python-apipkg [-----------------------------] 100% (7/8) removing python-pluggy [-----------------------------] 100% (8/8) removing python-iniconfig [-----------------------------] 100% :: Running post-transaction hooks... (1/1) Arming ConditionNeedsUpdate...

yochananmarqos commented on 2020-09-16 14:48

@rctath: Report the issue upstream, it has nothing to do with this package.

rcrath commented on 2020-09-16 09:12

Getting error:

cobang
[E][000383569.317193][core.c:71 core_event_error()] core 0x55afb836e6d0: proxy 0x55afb8381970 id:7: seq:24 res:-16 (Device or resource busy) msg:"enum params id:3 (Spa:Enum:ParamId:EnumFormat) failed"
[E][000383569.317204][gstpipewiredeviceprovider.c:298 on_core_error()] error id:7 seq:24 res:-16 (Device or resource busy): enum params id:3 (Spa:Enum:ParamId:EnumFormat) failed
Segmentation fault (core dumped)

Maybe it is looking for the (non-existent) camera? I wanted to read coads I have on my drive already.

MartinX3 commented on 2020-09-09 16:01

@yochananmarqos Thank you very much!

yochananmarqos commented on 2020-09-09 15:59

@MartinX3: Thanks for the heads up. I believe you're correct, adjusted accordingly.

MartinX3 commented on 2020-09-09 08:29

It misses a dependency on gst-plugin-gtk https://www.archlinux.org/packages/extra/x86_64/gst-plugin-gtk/ or the app won't get camera access.

Is gst-plugins-good still needed? Or is the needed lib moved to gst-plugin-gtk? (I can't remove it to test it, since other apps need it)