Package Details: cockatrice-client-git 2.9.0.r71.g2303880b-1

Git Clone URL: https://aur.archlinux.org/cockatrice-client-git.git (read-only, click to copy)
Package Base: cockatrice-client-git
Description: Open-source multiplatform supported program for playing tabletop card games over a network.
Upstream URL: https://cockatrice.github.io/
Keywords: card game gathering magic mtg
Licenses: GPL2
Conflicts: cockatrice-client
Provides: cockatrice-client
Submitter: shackra
Maintainer: skw
Last Packager: skw
Votes: 8
Popularity: 0.000000
First Submitted: 2015-10-26 20:55 (UTC)
Last Updated: 2024-05-29 05:14 (UTC)

Dependencies (18)

Required by (0)

Sources (1)

Pinned Comments

skw commented on 2023-07-08 18:49 (UTC) (edited on 2023-10-31 19:45 (UTC) by skw)

currently failing to build because upstream does not support protobuf 23.3 yet; see https://github.com/Cockatrice/Cockatrice/issues/4825

UPDATE: This is now fixed upstream and the package builds again.

Latest Comments

skw commented on 2023-07-08 18:49 (UTC) (edited on 2023-10-31 19:45 (UTC) by skw)

currently failing to build because upstream does not support protobuf 23.3 yet; see https://github.com/Cockatrice/Cockatrice/issues/4825

UPDATE: This is now fixed upstream and the package builds again.

FFY00 commented on 2019-03-12 15:06 (UTC)

Can you add qt5-websockets to the dependencies and remove the test/mkdir stuff for the build directory? Also, can you package the client and server in the same package? I don't see a reason why package them separately, even then they should use the same pkgbase.

You can use the official package as a model: https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/cockatrice

Grus commented on 2019-03-04 02:15 (UTC)

probably needs qt5-websockets in its dependencies now.

CanadianBakn commented on 2015-10-27 03:36 (UTC)

The main Cockatrice servers require a fairly up to date version of Cockatrice, and master is stable. This is the one you want to install.