Package Details: cockpit 146-1

Git Clone URL: https://aur.archlinux.org/cockpit.git (read-only)
Package Base: cockpit
Description: A systemd web based user interface for Linux servers
Upstream URL: http://www.cockpit-project.org/
Licenses: LGPL2.1
Conflicts: cockpit-git
Submitter: irtimmer
Maintainer: irtimmer
Last Packager: irtimmer
Votes: 38
Popularity: 2.618414
First Submitted: 2014-04-23 14:52
Last Updated: 2017-07-21 09:59

Latest Comments

fthiery commented on 2017-07-01 20:58

If anyone is interested, to auto enable cockpit at boot:

sudo systemctl enable cockpit.socket
sudo systemctl start cockpit.socket

rollenwiese commented on 2017-07-01 20:26

[EDIT - SOLVED]
At least to me this was not obvious, but you must go to your user context menu in the upper right>Authentication and explicity enable a SSH key to be used to authenticate against other systems. Now I can add my virtual machines without issue.

Aeyoun commented on 2017-07-01 03:31

Please add "packagekit" as an optdepends as of cockpit version 143.

fthiery commented on 2017-06-28 16:38

Hello there, any one else with this issue when trying to enable cockpit ?

# systemctl start cockpit.service
# systemctl enable cockpit.service
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
.wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
instance name specified.

For reference:

# cat /usr/lib/systemd/system/cockpit.service
[Unit]
Description=Cockpit Web Service
Documentation=man:cockpit-ws(8)
Requires=cockpit.socket

[Service]
ExecStartPre=/usr/bin/remotectl certificate --ensure --user=root --group= --selinux-type=
ExecStart=/usr/libexec/cockpit-ws
PermissionsStartOnly=true
User=root
Group=

balticer commented on 2016-12-03 20:30

Hi,

networkmanager is not a hard dependency. Please make it optional.

regards

mtcs commented on 2016-10-07 15:28

Getting this error on compilation(build()):

I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
cannot parse http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl

Yamakaky commented on 2016-09-30 20:27

Getting the following issue: https://github.com/cockpit-project/cockpit/issues/5103

klingt.net commented on 2016-02-29 15:27

This requires to install `wayland` as dependency on a headless server. Does anybody know where the wayland dependency comes from?

lantw44 commented on 2016-02-01 06:30

Can we add --localstatedir=/var to avoid creating /usr/var directory?

brightonbob commented on 2015-12-08 20:39

Thanks, just installed 86.1 - works on Firefox 42 - errors (as below, session expired etc) on latest nightly (45.0a1)

brightonbob commented on 2015-11-22 13:43

After issues with previous version and updating to latest version (0.84.2). I now cannot login completely i.e name/password is accepted but I get error:

"Disconnected
Your session has expired. Please log in again."
With options to "Try to reconnect" or "Login again"
(Neither option works)

gps1539 commented on 2015-11-21 19:48

Answering my own question. I have it running now by removing "--selinux-type=" from the cockpit.service file

gps1539 commented on 2015-11-21 01:47

Thanks for creating this package

It seems to install OK but I can not start it via systemctl and I see an error
Process: 929 ExecStartPre=/usr/bin/remotectl certificate --ensure --user=root --group= --selinux-type= (code=exited, status=1/FAILURE)

Am I missing a dependency? is selinux required?

edrex commented on 2015-10-03 06:58

Needs make dependency on automake:

+ autoreconf -f -i -I tools
sh: aclocal: command not found
autoreconf: aclocal failed with exit status: 127

ninhnq commented on 2015-08-12 04:06

Hi irtimmer,
Can you help me with the installation process? It seems to be installed successful, but not working on localhost:9090.
Should I install nginx or apache as well?

Conglezu commented on 2015-04-07 16:27

Cannot find it in aur for ARM. Is there a timeframe for poping it out there ?
Thx.

anatolik commented on 2015-02-07 17:08

Hi irtimmer, do you want to take over cockpit-git package that I currently own? It is better if one person will manage both packages.

johannvonperfect commented on 2015-02-01 02:39

Upstream has been updated to 0.38.
https://github.com/cockpit-project/cockpit/releases

GI_Jack commented on 2014-12-08 23:38

needs nodejs as a compile time dependency.

plz add

GI_Jack commented on 2014-12-08 23:38

needs nodejs as a dependency.

plz add.

PLum commented on 2014-12-08 12:25

0.33: Docker console
please update.

leedev commented on 2014-11-19 07:33

xmlto needs to be added as a make dependence. It builds fine after it is installed.

configure: error: the xmlto command was not found (perhaps --disable-doc)
==> ERROR: A failure occurred in build().
Aborting...

ImNtReal commented on 2014-09-08 17:41

Shouldn't the cockpit.pam file be copied to /etc/pam.d/cockpit instead of /etc/pam?

ato commented on 2014-04-26 08:59

need dependecy to perl-locale-po