Package Details: codec2-svn 2493-1

Git Clone URL: https://aur.archlinux.org/codec2-svn.git (read-only)
Package Base: codec2-svn
Description: Open source 2400 bit/s speech codec
Upstream URL: http://codec2.org/
Licenses: LGPL
Submitter: oneonfire
Maintainer: keenerd
Last Packager: keenerd
Votes: 4
Popularity: 0.164583
First Submitted: 2010-09-21 14:21
Last Updated: 2015-11-20 04:35

Dependencies (3)

Required by (1)

Sources (1)

Latest Comments

shtrom commented on 2016-04-03 10:35

This package should conflict/provide codec2

timofonic commented on 2015-11-04 08:38

Any updates? Please...

toddejohnson commented on 2015-09-22 06:11

I needed to make some changes to the PKGBUILD:
-pkgver=2027
+pkgver=2347
pkgrel=1
pkgdesc="Open source 2400 bit/s speech codec"
arch=('i686' 'x86_64')
@@ -10,9 +10,9 @@
url="http://codec2.org/"
depends=('glibc')
makedepends=('subversion' 'cmake')
-source=('svn+https://freetel.svn.sourceforge.net/svnroot/freetel/codec2')
+source=('svn+https://svn.code.sf.net/p/freetel/code/codec2-dev/')
md5sums=('SKIP')
-_svnmod=codec2
+_svnmod=codec2-dev

keenerd commented on 2015-01-26 20:47

Done. Thank you for figuring out the cmake flags, those are the trickiest part.

AxPU commented on 2015-01-15 23:40

It seems like the current snapshot requires building with cmake. It fails at the ./configure step.... Also there are some issues with the /usr/lib, /lib /lib64 locations that came along with one of the recent Arch base system updates.

I need codec2 as it is required by freedv (freedv-svn package) so i fixed the PKGBUILD and uploaded my working version to pastebin..

http://pastebin.com/mD3cDS4i

Hope it's acceptable :) Please update.
AxPU

AxPU commented on 2014-03-01 18:56

OK, I see.

I'm not yet too familiar with the specifics of building packages from version control. It seems that $pkgver is updated by makepkg. Since I've just built the package my $pkgver was already set to 1405 and thus I did not get noticed of the update.

So nothing to do and thanks for the information!
AxPU

keenerd commented on 2014-03-01 18:43

Why pkgrel? I updated the pkgver.

AxPU commented on 2014-03-01 18:19

Oh my, that is indeed a valid reason :)

Could you please also up the pkgrel value so that people using the package can find the updated PKGBUILD?

Thanks again!
AxPU

keenerd commented on 2014-02-27 23:57

Well, 1116 commits ago when the pkgbuild was written none of those existed. Fixed.

AxPU commented on 2014-02-27 23:05

Is there a reason for manually copying only the binary files in the package() function? This way all the header files are left out and it is not possible to build other packages depending on codec2 (e.g. freedv)

You could instead use the standard "make install" way whereby all needed files are put into place. I've changed the package() function of your PKGBUILD into the following:

package() {
cd $srcdir/$_svnmod
make install DESTDIR=$pkgdir
}

That does the trick.

Or is there a specific reason for not doing that?
Thanks for letting me know!

AxPU

All comments