Package Details: coin-or-hsl 2023.05.26-1

Git Clone URL: https://aur.archlinux.org/coin-or-hsl.git (read-only, click to copy)
Package Base: coin-or-hsl
Description: HSL Mathematical Software Library. Including solvers for sparse linear systems of equations and sparse eigenvalue problems. Compiled with coin-or-tools, supports Ipopt.
Upstream URL: http://www.hsl.rl.ac.uk/
Submitter: sbalula
Maintainer: sbalula (Maik93)
Last Packager: sbalula
Votes: 3
Popularity: 0.000033
First Submitted: 2021-05-10 10:47 (UTC)
Last Updated: 2023-06-19 16:39 (UTC)

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

sbalula commented on 2023-06-19 16:44 (UTC) (edited on 2023-06-19 16:44 (UTC) by sbalula)

Updated on 2023-06-19 with:

  • change depends openblas-lapack to blas-openblas
  • bump version to 2023.05.26

@FlyingJay1 the package version mirrors the coinhsl release, and not the ThirdParty-HSL git repo, where the latest version is used.

MarsSeed commented on 2023-06-15 11:54 (UTC)

TLDR; Please change depends openblas-lapack to blas-openblas.

Arch announced on June 14 a new blas-openblas repo package.

That is the same as the earlier AUR package openblas-lapack, providing the OpenBLAS implementation of blas, cblas, lapack, lapacke.

This means the openblas-lapack AUR package should be deleted, and replaced with the blas-openblas repo package.

FlyingJay1 commented on 2022-05-22 03:29 (UTC) (edited on 2022-07-31 16:52 (UTC) by FlyingJay1)

There's no 2021.05.05 tag in the repository. The current version is 2.2.1

Could you please correct the version?