Package Details: colord-git 1.2.1.r14.g5a9987b-1

Git Clone URL: https://aur.archlinux.org/colord-git.git (read-only)
Package Base: colord-git
Description: System daemon for managing color devices
Upstream URL: http://www.freedesktop.org/software/colord
Licenses: GPL2
Conflicts: colord
Provides: colord
Replaces: shared-color-profiles
Submitter: mlq
Maintainer: mlq
Last Packager: mlq
Votes: 0
Popularity: 0.000000
First Submitted: 2014-07-02 22:51
Last Updated: 2015-06-15 18:15

Required by (30)

Sources (3)

Latest Comments

cousinm commented on 2016-01-05 17:42

Manpage generation doesn't work anymore. A docbook error…

GEN cd-it8.1
cd-it8.sgml:1: parser error : StartTag: invalid element name
<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
^
cd-it8.sgml:1: parser error : Extra content at the end of the document
<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
^
unable to parse cd-it8.sgml

no element found at line 1, column 0, byte 0 at /usr/lib/perl5/vendor_perl/XML/Parser.pm line 187.
Makefile:661: recipe for target 'cd-it8.1' failed
make: *** [cd-it8.1] Error 255

Perry3D commented on 2015-03-08 10:47

Update the colord-git-docbook.patch:

diff --git a/man/cd-create-profile.sgml b/man/cd-create-profile.sgml
index 4933c86..212e96e 100644
--- a/man/cd-create-profile.sgml
+++ b/man/cd-create-profile.sgml
@@ -1,4 +1,6 @@
-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.5//EN"
+ "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!-- Please adjust the date whenever revising the manpage. -->
<!ENTITY date "<date>8 April,1011</date>">
<!ENTITY package "cd-create-profile">
diff --git a/man/cd-fix-profile.sgml b/man/cd-fix-profile.sgml
index 23c21b0..dc7adf7 100644
--- a/man/cd-fix-profile.sgml
+++ b/man/cd-fix-profile.sgml
@@ -1,4 +1,6 @@
-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.5//EN"
+ "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!-- Please adjust the date whenever revising the manpage. -->
<!ENTITY date "<date>8 April,1011</date>">
<!ENTITY package "cd-fix-profile">
diff --git a/man/cd-it8.sgml b/man/cd-it8.sgml
index e0ef56f..6e67ee1 100644
--- a/man/cd-it8.sgml
+++ b/man/cd-it8.sgml
@@ -1,4 +1,5 @@
-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.5//EN"
+ "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!-- Please adjust the date whenever revising the manpage. -->
<!ENTITY date "<date>7 November,2014</date>">
<!ENTITY package "cd-it8">
diff --git a/man/colormgr.sgml b/man/colormgr.sgml
index fbb6511..85eb03f 100644
--- a/man/colormgr.sgml
+++ b/man/colormgr.sgml
@@ -1,4 +1,6 @@
-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.5//EN"
+ "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
<!-- Please adjust the date whenever revising the manpage. -->
<!ENTITY date "<date>18 June,2013</date>">
<!ENTITY package "colormgr">

brittyazel commented on 2014-08-14 05:22

Tried to install to test a patch and was met with perl compile errors. Solved the problem by installing "perl-xml-libxml" and "perl-file-which"

You may wish to add these two packages as a dependency