Package Details: commander-wars 0.30.2.1-1

Git Clone URL: https://aur.archlinux.org/commander-wars.git (read-only, click to copy)
Package Base: commander-wars
Description: Advance Wars Clone with a lot of additions customizations and modding support
Upstream URL: https://github.com/Robosturm/Commander_Wars
Licenses: LGPL3
Submitter: LuckyTurtleDev
Maintainer: LuckyTurtleDev (msrd0, LuckyTurtleCI)
Last Packager: LuckyTurtleCI
Votes: 1
Popularity: 0.000010
First Submitted: 2022-03-11 11:33 (UTC)
Last Updated: 2023-03-18 11:26 (UTC)

Latest Comments

Namelessone1991 commented on 2023-10-20 20:46 (UTC) (edited on 2023-10-20 20:50 (UTC) by Namelessone1991)

Might be beneficial to work on a solution to the dependencies issue. I just wanna ask if anyone else is willing to try and figure it out, with me. Recent changes to the qt dependencies make it not run, unless the dependencies are downloaded from external sources, such as the aqt installer, or the GUI installer.

There's also issues where I have personally struggled to make it compile due to the SSL dependencies, specifically, the switching between 1.1 and 3.0 that was made from one commit and then rolled back. I have the commit info where that change was made, so I will be investigating on what happens with that dependency.

I still believe a self contained package might be best, but not sure how long will take me to try and bundle it like that.

LuckyTurtleDev commented on 2023-01-10 16:46 (UTC)

ℹ️ The lasted update has change the config/save game path back to the path of the original project. The path was change in early packages to avoid creating save games at the working directory. This was fix upstream. Existing save games must may be moved manual.

jimsey-pickles commented on 2023-01-10 15:56 (UTC)

@LuckyTurtleDev

Its running flawlessly with the current update. thanks!

LuckyTurtleDev commented on 2022-10-03 11:18 (UTC)

@jimsey-pickles I do not have any issues with the lasted version anymore. If you still have this issue, witch the lasted version, I recommend you to create a issue at the upstream.

jimsey-pickles commented on 2022-09-28 21:08 (UTC)

@LuckyTurtleDev Thanks for trying to solve it.

Updated the package but get a segfault now.

LuckyTurtleDev commented on 2022-09-28 17:31 (UTC)

@msrd0 I have update the package now. However I have still have ssl issues with the new version but the old builds fine on my pc.

msrd0 commented on 2022-09-26 14:58 (UTC)

@LuckyTurtleDev Version Beta_25_1 compiles perfectly fine on my computer

LuckyTurtleDev commented on 2022-09-26 10:12 (UTC)

@jimsey-pickles saddly I run at cmake issue with openssl while updating this package.

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the
  system variable OPENSSL_ROOT_DIR (missing: OPENSSL_CRYPTO_LIBRARY) (found
  version "1.1.1q")

I don not known why this happen and how I can fix this.