Package Details: compiz-fusion-plugins-main 0.8.18-2

Git Clone URL: (read-only, click to copy)
Package Base: compiz-fusion-plugins-main
Description: Compiz Main plugins
Upstream URL:
Licenses: GPL
Conflicts: compiz-fusion-plugins-main-git
Submitter: ShadowKyogre
Maintainer: ShadowKyogre (isseigx)
Last Packager: ShadowKyogre
Votes: 26
Popularity: 0.24
First Submitted: 2015-08-13 17:48 (UTC)
Last Updated: 2020-11-24 00:52 (UTC)

Latest Comments

u666sa commented on 2020-11-29 08:27 (UTC)

Whoever getting this error "installing libjpeg-turbo (2.0.6-1) breaks dependency 'libjpeg>=7' required by compiz-fusion-plugins-main"

Go ahead and open up pamac-aur and rebuild compiz-fusion-plugins-main, edit the build file, and remove dependency libjpeg-turbo, and rebuild. Then you can do pamac -Syu and your system will update without problem!

ShadowKyogre commented on 2020-11-24 00:54 (UTC)

@vs220 , @aquilarubra - Updated the libjpeg dependency to libjpeg-turbo to account for the update. You should be able to build it now.

vs220 commented on 2020-11-23 18:57 (UTC)

@aquilarubra new libjpeg-turbo provides libjpeg instead of libjpeg=*

edit PKGBUILD libjpeg-turbo vs libjpeg>=7

depends=("compiz-core>=${_pkgver}" 'libjpeg-turbo' ......

aquilarubra commented on 2020-11-22 09:16 (UTC)

With latest general update, I get the following error: Could not find all required packages: libjpeg>=7 (Wanted by: compiz-fusion-plugins-main

ShadowKyogre commented on 2019-08-22 18:49 (UTC)

Hey everyone.

Requesting for comaintainers on this package since there's been several circumstances that happened that make it hard to maintain all the packages I normally attend to.


for more information.

If you're interested in co-maintaining, don't forget to leave a comment (or email me, or toot me on Mastodon).

ShadowKyogre commented on 2018-05-31 22:27 (UTC)

Hey. Sorry for the long delay. A lot of scheduling's gone awry since I took up a job. Should be back on more regularly now.

Anyway, so I tried compiling this from scratch and it compiles fine. compiz-bcop has its pkg-config file calling itself bcop, so ./configure is looking for the right package.

However, there might be something on your installs that could be causing this.

The file that normally tells pkg-config this is located in:: /usr/share/pkgconfig/bcop.pc

Can either of you pastebin the contents of that file and if so, check which package is providing it? Here's what the contents look like on my test machine:

lorcopotia commented on 2018-05-27 11:09 (UTC)

I've got the same error... just now. Still no answer?

prometheus commented on 2018-03-04 19:55 (UTC) (edited on 2018-03-04 19:56 (UTC) by prometheus)

Is the package wrongly looking for compiz-bcop as bcop?

checking for bcop >= 0.7.3... no
configure: error: Package requirements (bcop >= 0.7.3) were not met:

No package 'bcop' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BCOP_CFLAGS
and BCOP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().