Package Details: complx-git 4.15.7.45abcf0-1

Git Clone URL: https://aur.archlinux.org/complx-git.git (read-only)
Package Base: complx-git
Description: Complx: LC-3 Simulator used in GT:CS2110, created by Brandon.
Upstream URL: https://www.github.com/TricksterGuy/complx
Licenses: GPL
Conflicts: complx
Provides: complx
Submitter: DeedleFake
Maintainer: barchl
Last Packager: barchl
Votes: 2
Popularity: 0.063362
First Submitted: 2015-09-30 17:53
Last Updated: 2017-10-19 20:09

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

ausbin commented on 2018-01-12 11:29

just gonna have to agree with Brandon here, not that he needs my backup but yea

I'm skeptical of a -git package like this. This package provides a different, possibly incompatible, version of a critical class tool. I would make a complx package instead which uses the latest release.

A bunch of students running around with different complxs all built from different commits is not my idea of a good time as a TA for this class hahaha

bwhitehead commented on 2018-01-12 08:35

Hi Brandon here,

Please don't update the package unless I make a official release on github.

4.15.7 was never officially released to students, and I want to eliminate the possibility that students are on different versions.

Can the PKGBUILD be configured to grab the latest release instead of from HEAD?

But yeah to whoever is maintaining this now there is 4.16.0 now. However I don't know if the TAs are going to be more strict on what's allowed this semester, but as far as I'm concerned I don't care if this exists on AUR, it just isn't going to be advertised to 2110 students I may refer to this later in the official readme / install instructions though.

barchl commented on 2017-10-04 14:16

No problem. I'm actually taking the class right now, so I figured I'd pick it up.

DeedleFake commented on 2017-10-04 14:15

Ah, sorry about that. I needed this for a class several years ago and kind of forgot about it after that. Thanks for taking it over.