Package Details: configuradorfnmt 4.0.5-1

Git Clone URL: https://aur.archlinux.org/configuradorfnmt.git (read-only, click to copy)
Package Base: configuradorfnmt
Description: Tool for request keys and certificates of FNMT
Upstream URL: https://www.sede.fnmt.gob.es/descargas/descarga-software/instalacion-software-generacion-de-claves
Keywords: ceres certificate fnmt
Licenses: LicenseRef-FNMT
Submitter: ogarcia
Maintainer: ogarcia
Last Packager: ogarcia
Votes: 13
Popularity: 0.005581
First Submitted: 2020-08-19 08:35 (UTC)
Last Updated: 2024-03-06 07:18 (UTC)

Dependencies (2)

Required by (0)

Sources (3)

Pinned Comments

ogarcia commented on 2020-08-19 13:08 (UTC) (edited on 2023-03-20 13:14 (UTC) by ogarcia)

Sugerencias, errores, etc. Por favor, ponerme un ticket en https://github.com/ogarcia/pkgbuilds/issues

Suggestions, bugs, etc. Please, put me an issue in https://github.com/ogarcia/pkgbuilds/issues

ATENCIÓN: Según nos comenta Xose en https://github.com/ogarcia/pkgbuilds/issues/3 el sistema solamente parece funcionar correctamente con Chromium, por lo que es importante tenerlo en cuenta a la hora de solicitar el certificado.

NOTA: Si no te funciona la renovación del certificado, prueba a instalar la dependencia opcional icedtea-web.

Latest Comments

1 2 3 Next › Last »

ogarcia commented on 2023-11-07 17:55 (UTC)

@vct he modificado el paquete para que exija como mínimo tener java 17 instalado, eso si lo de la configuración de java por defecto hay que hacerla ya que no hay forma sencilla de indicarle que debe ejecutarse con java 17 o posterior (el sistema va a ejecutar el comando java y a donde apunte ese comando con eso va)

vct commented on 2023-11-07 16:43 (UTC)

La version configuradorfnmt 4.0.2 necesita al menos el java 17 instalado. Para los que tienen una version de java correcta pero aun tengan problemas, puede estar por defecto otra version diferente, para ver las version que tenemos, y cual esta activa: @ sudo archlinux-java status

Para cambiar la version activa, por ej para activar java-17-openjdk: @ sudo archlinux-java set java-17-openjdk

ogarcia commented on 2023-03-20 13:19 (UTC)

@j1simon lo acabo de poner como dependencia opcional (porque en principio no deberías de necesitar icedtea-web) y he puesto una nota en el comentario fijado ;-)

j1simon commented on 2023-03-20 12:44 (UTC)

Vale, está resuelto, el problema era ( https://github.com/ogarcia/pkgbuilds/issues/2#issuecomment-1476138810 ):

En mi caso es que no tenía instalado icedtea-web para tener Java accesible desde el navegador (en mi caso, Firefox), debería ser una dependencia en el PKGBUILD, no?

xoan commented on 2023-03-20 12:04 (UTC)

@j1simon https://github.com/ogarcia/pkgbuilds/issues/2#issuecomment-728770304

j1simon commented on 2023-03-20 11:51 (UTC) (edited on 2023-03-20 11:51 (UTC) by j1simon)

Pues el programa se para ahí y no hace nada más. De hecho, lo muestra como un error grave: GRAVE: No se ha podido obtener la ultima version disponible desde... y GRAVE: No se puede comprobar si hay versiones nuevas del aplicativo.
La salida que he puesto es toda la salida de ejecutar este comando desde la consola.

ogarcia commented on 2023-03-19 11:13 (UTC)

@j1simon en principio el que no funcione esa petición no debería influir ya que esa URL se supone que es para ver si hay o no nuevas versiones del aplicativo, pero ya sabemos que con la administración hemos topado y lo lógico no suele ser siempre lo correcto.

En su momento lo que yo hice fue esperar a que me caducase el certificado y me saque uno nuevo con el certificado del DNI Electrónico (se sacaba al momento y no tenías que personarte en ninguna oficina), pero de esto ya hace un tiempo por lo que no puedo decirte si ahora eso va a funcionar.

j1simon commented on 2023-03-19 09:28 (UTC)

Lo de la administración digital en España es de pena. Mi certificado está a punto de caducar pero no puedo renovarlo y está claro que el error está en su servidor:

$ configuradorfnmt
NOTE: Picked up JDK_JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=lcd -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dswing.crossplatformlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dsun.java2d.opengl=true
mar 19, 2023 10:09:58 A. M. es.gob.fnmt.cert.certrequest.CertRequest main
INFORMACIÓN: Modo de depuracion desactivado
mar 19, 2023 10:09:58 A. M. es.gob.fnmt.cert.certrequest.CertRequest main
INFORMACIÓN: Version actual de la aplicacion: '1'
mar 19, 2023 10:09:58 A. M. es.gob.fnmt.cert.certrequest.CertRequest printSystemInfo
INFORMACIÓN: Aplicacion FNMT de solicitud de certificados version 1.
 Sistema operativo: Linux.
 Version del sistema operativo: 6.2.7-xanmod1-1.
 Version de Java: 19.0.2.
 Arquitectura del JRE: 64 bits.
 Fabricante de la JVM: Oracle Corporation.
 Idioma por defecto: es_ES.
 Tamano actual en memoria: 1008MB.
 Tamano maximo de memoria: 16048MB.
 Memoria actualmente libre: 923MB.
mar 19, 2023 10:09:58 A. M. es.gob.fnmt.cert.certrequest.ProxyUtil setDefaultProxy
INFORMACIÓN: No se usara proxy para las conexiones de red
mar 19, 2023 10:09:59 A. M. es.gob.fnmt.cert.certrequest.Updater$1 checkServerTrusted
INFORMACIÓN: Verificado correctamente el certificado SSL: www.sede.fnmt.gob.es
mar 19, 2023 10:09:59 A. M. es.gob.afirma.core.misc.http.UrlHttpManagerImpl enableSslChecks
INFORMACIÓN: Habilitadas comprobaciones SSL
mar 19, 2023 10:09:59 A. M. es.gob.fnmt.cert.certrequest.Updater getLatestVersion
GRAVE: No se ha podido obtener la ultima version disponible desde https://www.sede.fnmt.gob.es/documents/10445900/10528994/certrequest.version.linux: es.gob.afirma.core.misc.http.HttpError
mar 19, 2023 10:09:59 A. M. es.gob.fnmt.cert.certrequest.Updater isNewVersionAvailable
GRAVE: No se puede comprobar si hay versiones nuevas del aplicativo
mar 19, 2023 10:09:59 A. M. es.gob.fnmt.cert.certrequest.Updater lambda$checkForUpdates$1
INFORMACIÓN: No se ha podido comprobar la disponibilidad de nueva version: java.lang.UnsupportedOperationException: No se puede comprobar si hay versiones nuevas del aplicativo, no hay informacion sobre la ultima version disponible

La página https://www.sede.fnmt.gob.es/documents/10445900/10528994/certrequest.version.linux que usan para verificar la versión no existe. Les he escrito para ver si lo arreglan.

Jarshvor commented on 2023-01-17 11:25 (UTC)

Funciona también con Firefox 108.0.2

luhou commented on 2021-12-30 18:10 (UTC)

Worked fine with Firefox 95 too.