Package Details: congruity 18-3

Git Clone URL: https://aur.archlinux.org/congruity.git (read-only)
Package Base: congruity
Description: A GUI application for programming Logitech(R) Harmony(TM) remote controls.
Upstream URL: http://congruity.sourceforge.net/
Licenses: GPL3
Submitter: None
Maintainer: webmeister
Last Packager: webmeister
Votes: 16
Popularity: 0.415577
First Submitted: 2010-10-10 09:43
Last Updated: 2015-08-11 19:30

Required by (0)

Sources (2)

Latest Comments

kar commented on 2015-09-19 11:31

Yes, rebuilding was the solution! Now it's working perfectly!

Please see my other comment from today (11:24).

webmeister commented on 2015-09-19 11:26

congruity still works for me. Did you try rebuilding the package and its dependencies (python-libconcord and libconcord)? If that does not help, congruity is just Python code, so you can take a look at /usr/bin/congruity to try to figure out what goes wrong.

kar commented on 2015-09-19 11:24

Ok, I found the solution! ;-)

Reinstall of "libconcord" was the solution. But before, I have reinstall "congruty" and "python-libconcord". Maybe it's necessary to reinstall all 3 packages? I don't know!

But now, it's working!

kar commented on 2015-09-19 11:17

Congruity doesn't start anymore. But it's maybe one year ago, I have last time using this tool for update my Harmony One.

Today, there is only a error-message. Can anybody help?

#############################################
~ % congruity

(python2:26784): Gtk-WARNING **: Theme directory apps/system-power-actions of theme breeze has no size field


(python2:26784): Gtk-WARNING **: Theme directory apps/toolbar of theme breeze has no size field


(python2:26784): Gtk-WARNING **: Theme directory categories/kickoff-menu-tabs of theme breeze has no size field
#############################################

swt2c commented on 2015-08-10 19:10

Yes, that should be the only commit you need.

webmeister commented on 2015-08-10 14:41

Are you talking about this change? http://sourceforge.net/p/congruity/code/ci/9ae53766b3a3344653c9f9bc9be1ea36f81eadd3

Is this commit sufficient to fix your problem? Then I can include the patch in this package as well, so that it works everywhere until they release a new version. That's probably easier for everyone than maintaining an additional -git package.

parkerlreed commented on 2015-08-10 06:04

mhgui is broken in this release but works in git. Possibility if getting a -git package?

parkerlreed commented on 2015-08-10 06:03

mhgui is broken in this release but works in git. Possibility if getting a -git package? One thing that has to be done for both the congruity and mhgui python scripts is to change python to python2 in the first line.

andybz commented on 2014-01-26 01:25

Looks like wxGTK and wxPython have been updated to v3, so this now breaks Congruity.

Can you change the depends from wxpython to wxpython28?

TheCycoONE commented on 2013-12-27 14:42

mhgui (needed for some remotes because myharmony.com doesn't work on linux browsers) needs python-suds. Should be a dependency or at least opt-depend

All comments