Package Details: conky-lua-nv 1.10.5-1

Git Clone URL: https://aur.archlinux.org/conky-lua-nv.git (read-only)
Package Base: conky-lua-nv
Description: An advanced system monitor for X based on torsmo with lua and nvidia enabled
Upstream URL: https://github.com/brndnmtthws/conky
Licenses: GPL3, BSD
Conflicts: conky
Provides: conky, conky-lua
Replaces: conky, torsmo
Submitter: Andrwe
Maintainer: Foucault
Last Packager: Foucault
Votes: 106
Popularity: 1.635587
First Submitted: 2010-04-12 04:55
Last Updated: 2016-10-16 15:58

Latest Comments

oberon2007 commented on 2016-05-30 18:48

Thank you Foucault. You are right about man-db. However since 1.10.2 dependency libxinerama is needed! ;)

Foucault commented on 2016-03-17 09:52

man-db is in the base group, I believe base and base-devel packages are supposed to be installed anyway and not regarded as dependencies in AUR packages.

oberon2007 commented on 2016-03-17 00:18

Thank you for this great package! I just noticed that man-db is missing from makedepends.

kennypewpew commented on 2016-02-09 20:08

I got an "ERROR: install should not be an array". The fix was to edit the PKGBUILD and modify the install target from install=('conky-lua-nv.install') to install=conky-lua-nv.install

Foucault commented on 2015-12-03 11:11

Should be working now. Thanks!

FiyreWyrkz commented on 2015-12-02 22:49

CMake Error at cmake/ConkyPlatformChecks.cmake:370 (message):
Unable to find program 'tolua++'

However, I do have this package installed already.

hekel commented on 2015-11-20 17:40

Build fails with cmake-3.4.0

Solved with this patch: https://github.com/brndnmtthws/conky/issues/162

Foucault commented on 2015-09-22 09:07

I build it in a clean chroot with extra-x86_64-build and I have not installed perl-xml-sax-expat (but I do have perl-xml-sax, pulled by libxml). Are you sure that is required?

davidosomething commented on 2015-09-21 23:20

requires perl-xml-sax-expat to build docs

sad270 commented on 2015-08-15 14:55

Hi,
i get an error like this :

/tmp/yaourt-tmp-USER/aur-conky-lua-nv/./PKGBUILD: line 55: cmake: command

To fix it we should install cmake with pacman

I think you forget to add it in the Dependencies.

triax commented on 2015-08-13 05:54

Although it wasn't me i assume it is because Conky has merged some bug-fixes to the master branch. Although the maintainer of Conky stated with the release of 1.10 it's now a rolling release he later removed that statement so it's unclear the version number will still be altered in the future.

(but i also agree with you, the main Conky package in the arch repo's should be flagged if people want updates, not yours)

Foucault commented on 2015-08-12 18:12

Why was it flagged out of date? The latest version (as of today) is 1.10.0, as in arch repos.

triax commented on 2015-07-25 12:37

Would it be possible to enable the lua cairo, imlib and rsvg binding flags again, considering the conky19-lua-nv variant has them enabled and it would be more consistent.

You will have to use lua51 though since the bindings won't work with lua 5.3 or above. (just like you did in conky19-lua-nvidia)
See: https://github.com/brndnmtthws/conky/issues/116

Foucault commented on 2015-07-20 15:52

I know about 1.10 and the move to github. I have not updated it yet to 1.10 due to the incompatibilities between the two. I'll probably move this one to 1.10 and make a conky19 or something.

Foucault commented on 2015-07-20 15:51

I know about 1.10 and the move to github. I have not updated it yet to 1.10 due to the incompatibilities between the two. I'll probably move this one to 1.10 and make a conky19 or something.

triax commented on 2015-07-20 07:51

I would suggest making 2 packages, this for 1.10 and a second one for the 1.9 version since they broke backwards compatibility for the config files i can imagine people still want to use Conky 1.9. (1.10, currently, brings no new features anyway)

@Foucault
Small remark: why are you using lua51 instead of just lua (5.3.1) as a dependency?

Development has moved to: https://github.com/brndnmtthws/conky and he will not post releases any more, you just have to grab it from github.

triax commented on 2015-07-20 07:46

I would suggest making 2 packages, this for 1.10 and a second one for the 1.9 version since they broke backwards compatibility for the config files i can imagine people still want to use Conky 1.9. (1.10, currently, brings no new features anyway)

And a small remark: why are you using lua51 instead of just lua (5.3.1) as a dependency?

paramvir commented on 2015-07-02 02:04

Great work - Many thanks

The package conky 1.10 appears to have loads of bugs - perhaps we can continue with the 1.9.0-6 stream unless work-arounds turn up...

What do you think ???

Foucault commented on 2015-04-02 16:26

Please do not mark packages as out of date for build/runtime errors.

Upstream conky has not been updated for 3 years and this package has no major differences from either the [extra] package or the conky-lua package from AUR. So it's strange if it fails now but was working before. Since when is it failing? Is there any interesting information on the pacman log? Some relevant packages? We need more information than that to find out.

Personally all my lua routines work fine but they only do simple stuff like colorizing text etc.

mandog commented on 2015-04-02 13:49

Unfortunately this version has stopped drawing Lua on my conky only nvidia and other text are displayed

mandog commented on 2015-04-02 13:49

Unfortunately this version has stopped drawing Lua on my conky only nvidia and other text are displayed

Foucault commented on 2014-10-14 15:25

I suppose he's correct, although this is not the ideal solution, since there are version conditionals available for such cases. Anyway, since there are no direct dependencies in ldd for nvidia then let's leave at that and not over-complicate things for the package maintainer. This package is minor anyway. That also makes me wonder why extra/conky is not built with nvidia support since conky does not require any nvidia-specific libraries on runtime.

Foucault commented on 2014-10-14 15:23

I suppose he's correct, although this is not the ideal solution, since there are version conditionals available for such cases. Anyway, since there are no direct dependencies in ldd for nvidia then let's leave at that and not over-complicate things.

Chimyx commented on 2014-10-14 12:35

Here's what the packager thinks about this :
http://www.reddit.com/r/archlinux/comments/2ic9na/arch_linux_news_nvidia340xx_and_nvidia/cl1gg3m

Foucault commented on 2014-10-12 08:25

Yes, I am aware of that. In my opinion this is a problem with the nvidia packages, as they should all provide nvidia (and conflict with each other), but I am not sure this is possible to happen. However, since libxnvctrl is statically linked and no nvidia-specific libraries are present on ldd then I suppose the easiest thing to do would be to move nvidia to opt-depends (along with the 304, 340 packages)

gric commented on 2014-10-12 08:03

nvidia package 343.22 dropped support for G8x, G9x, and GT2xx GPUs [1]: we need to fallback on nvidia-340xx package, which does not provide 'nvidia' package anymore. Since conky-lua-nv requires 'nvidia' package as a dependency, it is not possible to use it anymore with G8x, G9x, and GT2xx GPUs.
Maybe nvidia should be an opt dependency ?

[1] https://www.archlinux.org/news/nvidia-340xx-and-nvidia/

Foucault commented on 2014-04-29 16:24

For people having problem with recent libxnvctrl update (337.12) it seems the libxnvctrl package is missing the shared library and only includes the static (not sure if it's a bug or a feature). Just rebuild the package and the linker will link against the static lib instead.

Foucault commented on 2014-02-08 16:20

Please do not flag out of date packages that fail to build/work but are otherwise up to date with upstream. Comments will suffice :)

Since AUR does not host binaries I believe there is no reason to increase package version for so bumps. Just reinstall/rebuild!

Alda commented on 2014-02-08 15:44

Because of a wireless_tools update, we need to recompile conky. Pkg version bump ?

Foucault commented on 2013-10-18 17:11

Done!

ImNtReal commented on 2013-10-18 16:52

Would it be problematic to add conky-lua as a provides for this, so that it will meet the requirements for conky-lua-arch?

archetypalsxe commented on 2013-08-13 15:06

My apologies again, I was using the locate command to see where the xcb-dri2.pc file was, and once I ran updatedb, it did find the file in the correct location. Thanks again for your assistance!

Foucault commented on 2013-08-13 15:01

If the .pc file is missing from the 64bit libxcb then is a packaging bug, but I doubt it. I'm also running 64bit and libxcb (1.9.1-2) contains the required file.

pacman -Ql libxcb |grep xcb-dri2.pc
libxcb /usr/lib/pkgconfig/xcb-dri2.pc

The 32bit package contains it under lib32
pacman -Ql lib32-libxcb|grep xcb-dri2.pc
lib32-libxcb /usr/lib32/pkgconfig/xcb-dri2.pc

And /usr/lib/pkgconfig/xcb-dri2.pc is owned by libxcb
pacman -Qo /usr/lib/pkgconfig/xcb-dri2.pc
/usr/lib/pkgconfig/xcb-dri2.pc is owned by libxcb 1.9.1-2

archetypalsxe commented on 2013-08-13 13:13

Thank you for your reply. False alarm, I just did a full system upgrade (including syncing the databases), and it installed just fine after.

In case someone wants to look into the potential issue for future users though.... here is the response I was typing:

I do have both libxcb and lib32-libxcb installed. The xcb-dri2.pc file was not present at the path you mentioned, but it is under /usr/lib32/pkgconfig/xcb-dri2.pc, which leads me to believe that the lib32-libxcb may be conflicting with the libxcb? I am in a 64 bit system if that matters at all.

Re-installing libxcb did not add the file, and when I tried removing libxcb (to reinstall it) I wasn't able to because lib32-libxcb has it as a dependency.

Foucault commented on 2013-08-13 12:55

This is strange. xcb-dri2.pc is provided by libxcb, which is required by libx11, which is required by libxrender, which is (finally) required by cairo. Since cairo is a very common package it should have pulled libxcb as well. Is libxcb installed? Does /usr/lib/pkgconfig/xcb-dri2.pc exist in your system? If not, try reinstalling libxcb.

archetypalsxe commented on 2013-08-13 09:56

When I try to install this package or conky-lua I receive this message:

"checking for cairo... configure: error: Package requirements (cairo) were not met:

Package 'xcb-dri2', required by 'egl', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables cairo_CFLAGS
and cairo_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details."

It looks like the package cairo is installed. I couldn't find a package called xcb-dri2 using either Pacman or Yaourt. I am pretty sure that my prefix is standard (although I'm not 100% sure what this is), and I have no clue how to adjust the cairo-CFLAGS or cairo_LIBS or what they should be set to. Please & thank you for any assistance!

Foucault commented on 2012-12-14 17:20

If conky fails to start please update your toluapp package for the lua update *PRIOR* to building conky (libtolua++ is statically linked into conky) as described in the comments of toluapp [1]

[1]: https://aur.archlinux.org/packages/toluapp/

Andrwe commented on 2011-10-01 10:02

Added fix of marcelohmoraes to PKGBUILD.

Unfortunately I can't test this package anymore that's why I'm disowning it.

stativ commented on 2011-09-13 09:51

Removing. It's almost exact (two comments deleted) duplicate of the conky-lua-nv package.

Anonymous comment on 2011-09-05 20:17

Adding to the comment from siriusb:

I don't quite understand the workings of makepkg, but I didn't know how to change the source code(because it downloads the source each time you run makepkg).

A quick fix was to:

touch /usr/include/curl/types.h
run makepkg
rm /usr/include/curl/types.h

So if you're a noob like me, that's one way to make this compile.

Anonymous comment on 2011-08-27 04:12

Ao que se indica está acontecendo um problema com o curl que deixou de ser compativel com as extenções types.h no kernel 3.0.3 (ou algo parecido)
Resolvi o problema com isso:
Quando falhar a primeira vez modifique o arquivo conky-1.8.1.tar.bz2 no gerenciador e pacote bzip mesmo : /src/ccurl_thread.c
Remova a linha: #include <curl/types.h> (deleta mesmo)
Modifique a md5 no PKGBUILD: md5sums=('0217dd07e093b8914eee9048f261d57d')
Agora pode preseguir com o makepkg

Google Translator =P

Indicates to what is happening is a problem with the curl is no longer compatible with the 3.0.3 kernel extensions Types.h (or something)
I solved the problem with that:
When you fail the first time modify the conky-1.8.1.tar.bz2 gzip package manager and the same: / src / ccurl_thread.c
Remove the line: # include <curl/types.h> (delete it)
Modify the md5sum in the PKGBUILD: md5sums = ('0217dd07e093b8914eee9048f261d57d ')
Now you can with makepkg preseguir

Anonymous comment on 2011-07-20 09:14

To get it built I had to remove the following line from ccurl_thread.c:
#include <curl/types.h>

http://projects.springlobby.info/issues/1575

Andrwe commented on 2010-10-17 20:17

Version bump