Package Details: conky-lua 1.10.6-1

Git Clone URL: (read-only)
Package Base: conky-lua
Description: Lightweight system monitor for X, with Lua support enabled
Upstream URL:
Keywords: conky conky-lua
Licenses: GPL3, BSD
Conflicts: conky
Provides: conky=1.10.6
Submitter: alexiobash
Maintainer: oberon2007
Last Packager: oberon2007
Votes: 34
Popularity: 1.155980
First Submitted: 2015-08-12 18:00
Last Updated: 2017-05-23 00:39

Latest Comments

oberon2007 commented on 2017-05-23 00:38

Thanks @fcolista. I've adopted the pkg

fcolista commented on 2017-02-09 09:45

This PKGBUILD seems abandoned, the maintainer does not respond.

A new PKGBUILD can be downloaded here, if needed:

bastelfreak commented on 2016-09-25 13:22

I'm unable to build the PKGBUILD in a fresh arch nspawn container:

-- Checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:646 (message):
None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):
cmake/ConkyPlatformChecks.cmake:252 (pkg_search_module)
CMakeLists.txt:37 (include)

-- Checking for modules 'cairo;cairo-xlib'
-- Found cairo, version 1.14.6
-- Found cairo-xlib, version 1.14.6
-- Checking for module 'imlib2'
-- Found imlib2, version 1.4.9
-- Checking for module 'librsvg-2.0'
-- No package 'librsvg-2.0' found
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:424 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:597 (_pkg_check_modules_internal)
cmake/ConkyPlatformChecks.cmake:274 (pkg_check_modules)
CMakeLists.txt:37 (include)

-- Configuring incomplete, errors occurred!
See also "/build/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
See also "/build/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().

7etc commented on 2016-08-13 22:03

I've installed first git, then pacman -U lua51-5.1.5-4-x86_64.pkg.tar.xz, and installation works fine. After installation there's no problem tu update lua

drxspace commented on 2016-08-01 07:23

What about this -or- this ?

ata commented on 2016-07-25 21:52

hi alls m fix

and saıd makepkg -sri after

opened here
sudo gedit /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake

and edit

# check whether version is given
if (_pkg_check_modules_pkg MATCHES "(.*[^><])(>=|=|<=)(.*)")
set(_pkg_check_modules_pkg_name "${CMAKE_MATCH_1}")
set(_pkg_check_modules_pkg_op "${CMAKE_MATCH_2}")
set(_pkg_check_modules_pkg_ver "${CMAKE_MATCH_3}")
set(_pkg_check_modules_pkg_name "${_pkg_check_modules_pkg}")

delate itis
set(_pkg_check_modules_pkg_name "${_pkg_check_modules_pkg}")
and try makepkg -sri

enjoy all

look at

or u want tar.xz here

techMod commented on 2016-07-20 10:57

Doesn´t build, cmke.patch didn´t pass check for sha1sum

m3thodic commented on 2016-07-04 21:40

The following PKGBUILD fixes lua5.1 compilation issues as well as speeding up compilation time:



dbenque commented on 2016-06-23 21:58

@firekage, I had the same problem.
If lua51 is installed on your system next to lua5.3 then what you can do:

clone the github repo:

in the file cmake/ConkyPlatformChecks.cmake, modify the check and library settings for LUA in the following way (close to line 259):
# If we need tolua++, we must compile against Lua 5.1
pkg_search_module(LUAAA REQUIRED lua51)
message(FATAL_ERROR "Unable to find lua51: version '${LUAAA_VERSION}'")
# Otherwise, use the most recent Lua version
pkg_search_module(LUA REQUIRED lua>=5.3 lua5.3 lua-5.3 lua53 lua5.2 lua-5.2 lua52 lua5.1 lua-5.1 lua51 lua>=5.1)
set(conky_libs ${conky_libs} ${LUAAA_LIBRARIES})
set(conky_includes ${conky_includes} ${LUAAA_INCLUDE_DIRS})

Then follow the make and install procedure under the wiki of the project.
At config time set option ON for BUILD_LUA_CAIRO (or IMLIB2 or RSVG)

firekage commented on 2016-06-19 15:34

I cant install it:

checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:574 (message):
None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):

I have lua installed in version 5.3, but it needs 5.1. Could somebody help?

argamanza commented on 2016-04-16 20:10

When i'm trying to install the package i get:

Scanning dependencies of target docs
[ 21%] Proccessing man page for docs
warning: failed to load external entity ""
cannot parse
doc/CMakeFiles/docs.dir/build.make:60: recipe for target 'doc/docs.html' failed
make[2]: *** [doc/docs.html] Error 4
make[2]: *** Deleting file 'doc/docs.html'
CMakeFiles/Makefile2:357: recipe for target 'doc/CMakeFiles/docs.dir/all' failed
make[1]: *** [doc/CMakeFiles/docs.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build conky-lua.

What's wrong and what can i do to repair it?

sdothum commented on 2016-04-01 19:21

Could you please add to the PKGBUILD


to the build() options? Would be a convenience for those of us monitoring wireless interfaces.

Thanks regardless, for the pkg.

ranger commented on 2016-03-31 08:51

Are you sure it builds correctly?

==> Retrieving sources...
-> Found v1.10.1.tar.gz
==> Validating source files with sha1sums...
v1.10.1.tar.gz ... Passed
==> Extracting sources...
-> Extracting v1.10.1.tar.gz with bsdtar
==> Starting prepare()...
patch: **** Can't open patch file ../../fix_build.patch : No such file or directory
==> ERROR: A failure occurred in prepare().

TidestManager1 commented on 2016-03-31 00:51

Thanks for the fixed PKGBUILD @petrucci4prez. I've merged your changes along with the fix_build.patch into the source.

It doesn't seem to SEGFAULT anymore, so at least there's that.

petrucci4prez commented on 2016-03-29 08:24

use this PKGBUILD with the "fix_build_patch" from segfault :)

# Maintainer: alexiobash < me (at) alexiobash (dot) com >
# Co-Maintainer: TidestManager1 < michaelpulliam1 (at) gmail (dot) com >
pkgdesc='Lightweight system monitor for X, with Lua support enabled'
license=('BSD' 'GPL3')
arch=('i686' 'x86_64')
makedepends=('docbook2x' 'perl-xml-libxml' 'cmake' 'docbook-xsl' 'docbook-xml')
depends=('alsa-lib' 'libxml2' 'curl' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51' 'cairo' 'tolua++')
backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')


build() {
cd "${srcdir}/${_pkgname}-${pkgver}"

CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" LUA_LIBS="-llua5.1" LUA_CFLAGS="-I/usr/include/lua5.1" \
cmake \


package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 LICENSE.BSD ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.BSD
install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim

prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i ../fix_build.patch

lukasm commented on 2016-03-29 06:17

Thanks for confirming.

Additionally tolua++ is not only a make-dependency, but a dependency needed for running conky. So tolua++ should be in depends rather than in makedepends.

mcaceres commented on 2016-03-28 20:03

@lukasm I have the same problem that lua_load gives segmentation fault. Installing conky-lua-nv seems to be a workaround for me

lukasm commented on 2016-03-28 11:10

@all Yes that's a huge update because syntax changed. Here you find a rough overview over the needed changes (post #7):

In /usr/share/doc/conky.../... you also find an example and you may also try the convert.lua given there.

My problem is that currently lua_load does not work (segmentation fault). Can this be confirmed by anybody? And whose bug would that be?

TidestManager1 commented on 2016-03-27 23:36

@ata, I'm not exactly sure but it was a HUGE update.

ata commented on 2016-03-27 21:56

ata commented on 2016-03-27 21:56

ata commented on 2016-03-27 21:16

Many conky does not work after update

moonarch commented on 2016-03-26 21:41

I am no longer on Arch and so can not generate the .SRCINFO for TidestManager1 update.

@TidestManager1 I have added you as maintainer. Can you push the new version?

bastelfreak commented on 2016-03-26 21:19

Hi, could someone please upload a new version of the PKGBUILD? It is currently broken:

TidestManager1 commented on 2016-03-15 09:15

Updated PKGBUILD at

Shamelessly bodged from this, gentoo's conky build script, and conky-lua-nv.

tiberiomoliveira commented on 2016-02-20 23:21

@scofi16 Just put it at the end of the PKGBUILD file.

@benjarobin It worked like a charm. Good job.

scofi16 commented on 2016-02-18 15:16

@benjarobin where to add this function?

benjarobin commented on 2016-02-13 14:31

Just add the following function to fix it:

prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
sed -i "s|tolua++ |toluapp |g" configure*

krs4keshara commented on 2016-02-02 07:05

as a workaround, install 'conky-lua-nv" from AUR.

ketzalv commented on 2016-01-25 03:49

Hello guys! i have a little solution with "configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras."

you need downgrade tolua++ 1.093-2

here the old versions!

eduncan911 commented on 2016-01-19 01:53

The problem with the 'tolua++' dependency is that the source configure is looking for a binary '/usr/bin/tolua++'.

It would appear that binary has been renamed to 'toluapp' in the latest version of 1.93-2. The maintained and updated package by arch, as well as in the manual download of 1.93-2, seems to have renamed it (not Arch's fault, the fault of the author of the code that renamed everything).

In addition, the library was changed (*.so instead of *.a).

Personally, I don't like to get away from Arch's repos and packages - would rather have it fixed in this package. So, there are two "real" solutions.

The original package of tolua++ should have explained the breaking change of the rename. I would suggestion creating a symlink of the old binary to the new one.

1) Perhaps the easiest solution is just to modify this package to 'sed' the source configure file and replace all instances looking for the binaries with the newer/correct one.

2) The real solution is to have conky update their source to configure with either binary.


TiglathAshur commented on 2015-12-13 00:08

Thanks Stormeye! Works well now

KevinHivert commented on 2015-12-04 10:08

@stormeye Thanks !

stormeye commented on 2015-12-03 00:14

For anyone who has issue with tolua++, use tolua++ 1.0.93-1 instead of tolua++ 1.0.93-2. You can find it at

ata commented on 2015-11-30 00:10

checking for LUA... yes
checking for cairo... yes
checking for cairo_xlib... yes
checking for tolua++... no
checking for tolua++5.1... no
checking for tolua++-5.1... no
configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.
==> HATA: build() içinde bir hata oluştu.
╚═══===═══[~/conky-lua]>> pacman -Q tolua++
tolua++ 1.0.93-2

ozky commented on 2015-11-28 08:18

Seems to be quite dead end as it needs 2008 released lua 5.1 and tolua++ is dead in upstream.

midfingr commented on 2015-11-27 19:19

All the conky-lua{-*} seem to fail with the aforementioned error:

configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.

Dea993 commented on 2015-11-24 18:39

checking for tolua++... no
checking for tolua++5.1... no
checking for tolua++-5.1... no
configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.

alexiobash commented on 2015-11-12 08:17

@vraskolnikov OK! :-)

vraskolnikov commented on 2015-11-11 20:16

Please disregard the last comment. Sorry.

vraskolnikov commented on 2015-11-11 20:11

Package fails the Sha1sums validity check as of now.

alexiobash commented on 2015-09-23 15:32

sorry! my fault! I will update as soon as possible!

moonarch commented on 2015-09-23 15:31


"As of 2015-08-18, this project may now be found at"

alexiobash commented on 2015-09-23 15:29

@all the last package is 1.9.0 visit this page
thank you
the problem is not a problem of conky-lua but ncurses package.

moonarch commented on 2015-09-23 15:23

@linuxista @salan54
Use makepkg again to link the new libraries.

This package is also out of data - 1.10 was released in June.

salan54 commented on 2015-09-23 15:19

conky: error while loading shared libraries: cannot open shared object file: No such file or directory

As said : upgrade to ncurses 6.0 has broken conky-lua

linuxista commented on 2015-09-22 22:12

Upgrade to ncurses 6.0 has broken conky-lua.

alexiobash commented on 2015-08-15 08:52

@pbl nothing!!!

pbl commented on 2015-08-14 23:10

Glad to see conky-lua finally made it to AUR4. Thanks for maintaining it!