Package Details: conky19-lua-nv 1.9.0-9

Git Clone URL: https://aur.archlinux.org/conky19-lua-nv.git (read-only)
Package Base: conky19-lua-nv
Description: An advanced system monitor for X based on torsmo with lua and nvidia enabled
Upstream URL: http://conky.sourceforge.net/
Licenses: custom
Conflicts: conky
Provides: conky, conky-lua
Replaces: conky, torsmo
Submitter: Foucault
Maintainer: Foucault
Last Packager: Foucault
Votes: 5
Popularity: 0.089535
First Submitted: 2015-07-20 17:14
Last Updated: 2015-12-05 10:17

Latest Comments

F1nny commented on 2015-12-05 17:57

Yup all good now, thanks Foucault for maintaining!

Foucault commented on 2015-12-05 10:18

Build should be working now.

F1nny commented on 2015-12-05 00:09

Anyone else getting any weird errors RE lua lately? Not sure when it started but suddenly conky stopped working throwing a bunch of errors related to unable to parse lua in the scripts/conkyrc's, when I tried reinstalling this package it's not able to finish configuring as it can't seem to find tolua++ even though it is definitely installed, any ideas?

checking for tolua++... no
checking for tolua++5.1... no
checking for tolua++-5.1... no
configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.

% pacman -Qs tolua
community/tolua++ 1.0.93-2
Tool to integrate C/C++ code with Lua

//edit:
Also note lua, lua51, and lua52 all installed as well. Weird as no major/minor version increases in anything lua related recently that I can tell, only the following which look to be more patch/bugfix release but maybe something interfered, also tried compiling on another computer with a working conky-lua but same issue (when building conky19-lua-nv)
[2015-11-27 18:47] [ALPM] upgraded tolua++ (1.0.93-1 -> 1.0.93-2)
[2015-12-03 13:47] [ALPM] upgraded lua (5.3.1-1 -> 5.3.2-1)

ondoho commented on 2015-09-19 08:58

this seems to be the best package providing conky 1.9.x atm.
(anyway, i use nvidia, so for me it is)
and i managed to tweak the PKGBUILD so that i can install it alongside conky 1.10
i think this will be necessary for some time, because the new and old syntax are incompatible.
here it is: http://pastebin.com/6QbZMtBD
it's not perfect, but mainstream conky does not complain when i installed it after this one.
provides a "conky19" binary in your $PATH, and some other "conky19" files.

toppy commented on 2015-08-18 13:49

[SOLVED]

Thank you Foucault ! Installed perfectly. Really appreciate the fast response.
Regards
Toppy

Foucault commented on 2015-08-18 13:35

Missing a makedepend. Try rebuilding now.

toppy commented on 2015-08-18 13:22

Hi Foucault

Tried to build & install but build failed with the following error ...

Making install in doc
make[1]: Entering directory '/tmp/yaourt-tmp-toppy/aur-conky19-lua-nv/src/conky-1.9.0/doc'
make[2]: Entering directory '/tmp/yaourt-tmp-toppy/aur-conky19-lua-nv/src/conky-1.9.0/doc'
make[2]: Nothing to be done for 'install-exec-am'.
/usr/bin/mkdir -p '/tmp/yaourt-tmp-toppy/aur-conky19-lua-nv/pkg/conky19-lua-nv/usr/share/man/man1'
/usr/bin/install -c -m 644 ./conky.1 '/tmp/yaourt-tmp-toppy/aur-conky19-lua-nv/pkg/conky19-lua-nv/usr/share/man/man1'
/usr/bin/install: cannot stat ‘./conky.1’: No such file or directory
Makefile:364: recipe for target 'install-man1' failed
make[2]: *** [install-man1] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp-toppy/aur-conky19-lua-nv/src/conky-1.9.0/doc'
Makefile:456: recipe for target 'install-am' failed
make[1]: *** [install-am] Error 2
make[1]: Leaving directory '/tmp/yaourt-tmp-toppy/aur-conky19-lua-nv/src/conky-1.9.0/doc'
Makefile:471: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build conky19-lua-nv.
==> Restart building conky19-lua-nv ? [y/N]
==> ---------------------------------------


I have the Testing Repos enabled on this Arch install, perhaps this is causing the issue ? I have used this package on my stable Arch install without problems.