Package Details: coolreader 3.1.2.71-1

Git Clone URL: https://aur.archlinux.org/coolreader.git (read-only)
Package Base: coolreader
Description: E-book reader for Linux, QT5 based
Upstream URL: http://sourceforge.net/projects/crengine/
Licenses: GPL2
Conflicts: coolreader-git, coolreader3, cr3
Provides: coolreader
Submitter: TopBrick
Maintainer: TopBrick
Last Packager: TopBrick
Votes: 10
Popularity: 1.373626
First Submitted: 2017-11-26 21:50
Last Updated: 2018-03-21 21:31

Latest Comments

roachsinai commented on 2018-08-22 00:51

Local package is newer than AUR: coolreader (3.1.2.71-2 -> 3.1.2.71-1)

TopBrick commented on 2018-08-18 10:08

Just have built it on freshly installed ARCH, it is fine... Really dont know what to suggest.

vertebrate commented on 2018-08-15 22:30

:: coolreader package(s) failed to install. :: ensure package version does not mismatch between .SRCINFO and PKGBUILD :: ensure package name has a VCS suffix if this is a devel package Anyone having this problem?

TopBrick commented on 2018-03-21 21:17

Thanks for feedback. Corrected typo error and dependency issue (qt5-tools).

egrupled commented on 2018-03-17 23:18

there is typo in build command "-DCMAKE_BUILD_TOQYPE=Release" should be "-DCMAKE_BUILD_TYPE=Release" Also .install file is redundant and can be dropped. "zlib" "libpng" "libjpeg" "freetype2" dependencies can be dropped too - check it with namcap.

qwertea commented on 2018-02-07 14:59

requires qt5-tools to build.

ninian commented on 2017-12-15 01:05

Many thanks for your work in creating this package.

TopBrick commented on 2017-11-26 21:54

This is my the very first release of coolreader package.
SRC are taken from gentoo repo and edited a little bit.
I plan to support it for a very long time and would be happy to share with people who is looking for good book reader.