Package Details: copy-agent 3.2.02.0496-1

Git Clone URL: https://aur.archlinux.org/copy-agent.git (read-only)
Package Base: copy-agent
Description: Copy.com sync agent
Upstream URL: http://www.copy.com
Keywords: cloud copy sync
Licenses: custom
Submitter: aitjcize
Maintainer: vorbote
Last Packager: FadeMind
Votes: 127
Popularity: 0.208083
First Submitted: 2013-03-12 13:38
Last Updated: 2016-01-21 18:33

Dependencies (4)

Required by (0)

Sources (8)

  • copy-agent.desktop
  • copy-agent.png
  • copy-agent.service
  • copy-agent.svg
  • copy-console.service
  • Copy.tgz
  • launch.sh
  • TERMS

Pinned Comments

vorbote commented on 2016-02-02 15:37

So that everybody knows:

Barracuda will discontinue the copy.com/cudadrive service on May 1st:. [1]

BTW, Barracuda is in financial trouble and has been selling itself to the best bidder for several months now. Morgan Stanley is agent in charge.[2] So, no. There is no hope. Move your files somewhere else using mover[3] or download and reupload to, say, mega[4], althogh the latter may not be a safer bet either...

[1] https://techlib.barracuda.com/display/COPY/Copy+End-of-Life https://blog.barracuda.com/2016/02/01/message-from-gm-of-storage/
[2] http://www.theregister.co.uk/2016/02/02/embattled_barracuda_looks_for_buyer/
[3] https://mover.io/
[4] https://mega.nz/

Latest Comments

vorbote commented on 2016-02-02 15:37

So that everybody knows:

Barracuda will discontinue the copy.com/cudadrive service on May 1st:. [1]

BTW, Barracuda is in financial trouble and has been selling itself to the best bidder for several months now. Morgan Stanley is agent in charge.[2] So, no. There is no hope. Move your files somewhere else using mover[3] or download and reupload to, say, mega[4], althogh the latter may not be a safer bet either...

[1] https://techlib.barracuda.com/display/COPY/Copy+End-of-Life https://blog.barracuda.com/2016/02/01/message-from-gm-of-storage/
[2] http://www.theregister.co.uk/2016/02/02/embattled_barracuda_looks_for_buyer/
[3] https://mover.io/
[4] https://mega.nz/

vorbote commented on 2016-02-02 15:21

I am adopting this package to be able to request its deletion on May 1st. If anyone wants to take over with the same goal, be my guest.

Cheers.

FadeMind commented on 2016-02-02 09:43

@All I orphan this package due SammysHP msg.
Regards

@SammysHP Thanks for this news.

SammysHP commented on 2016-02-02 08:44

Copy will be discontinued on May 1, 2016. This also makes this package obsolete then.

https://techlib.barracuda.com/display/COPY/Copy+End-of-Life

@FadeMind
IMHO it would be good to flag this package as out-of-date to make users aware of the EOL. Please do it yourself if you agree.

David-UPCT commented on 2016-01-02 21:35

I didn't noticed anything strange in my PC in previous versions, only in my tablet (where I use easystroke and onboard). I've installed 3.2.01.0481-5 and the problems with onboard and easystroke are gone. Thank you, Justin.

justin8 commented on 2016-01-01 12:01

Ok, removed it again. Odd that it caused issues for some users. I tested it on a couple of my machines and it was fine.

vorbote commented on 2015-12-26 17:58

@justin8 it seems with the latest changes to move to the new GNU C++ ABI, adding /opt/copy to the linker path breaks too many things. Copy is still at ABI version v18, while Arch is already at ABI v20. Mucking about with LD_LIBRARY_PATH could work in some cases, but imo it is too much effort for too little gain.

And BTW, new version: 3.2.02.0483 (for the impatient: use updpkgsums).

David-UPCT commented on 2015-12-26 15:01

Quick update: the problem with easystroke and onboard remains in 3.2.01.0481-4, I've had to downgrade to 3.2.01.0481-2.

David-UPCT commented on 2015-12-26 10:39

I have a completely different bug in version 3.2.01.0481-3, it breaks some programs such as easystroke and onboard, and they can't be loaded. Here's their error messages:

# easystroke
easystroke: /opt/copy/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by easystroke)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by easystroke)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libboost_serialization.so.1.60.0)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libgtkmm-3.0.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libgdkmm-3.0.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libgiomm-2.4.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libpangomm-1.4.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/libglibmm-2.4.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib/libglibmm-2.4.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libglibmm-2.4.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib/libcairomm-1.0.so.1)
easystroke: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libcairomm-1.0.so.1)

# onboard
sys:1: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
sys:1: PyGIWarning: GdkX11 was imported without specifying a version first. Use gi.require_version('GdkX11', '3.0') before import to ensure that the right version gets loaded.
Traceback (most recent call last):
File "/usr/bin/onboard", line 15, in <module>
from Onboard.OnboardGtk import OnboardGtk as Onboard
File "/usr/lib/python3.5/site-packages/Onboard/OnboardGtk.py", line 26, in <module>
from Onboard.KbdWindow import KbdWindow, KbdPlugWindow
File "/usr/lib/python3.5/site-packages/Onboard/KbdWindow.py", line 10, in <module>
from Onboard.WindowUtils import Orientation, WindowRectPersist, \
File "/usr/lib/python3.5/site-packages/Onboard/WindowUtils.py", line 14, in <module>
import Onboard.osk as osk
ImportError: /opt/copy/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/libhunspell-1.3.so.0)

Downgrading to in version 3.2.01.0481-2 solves the problem (easystroke and onboard works well).

FadeMind commented on 2015-12-25 09:27

PKGBUILD have missing install rules for launch.sh

current is:

install -Dm755 "$srcdir/launch.sh" "$pkgdir/usr/bin/$i"

schould be:

for i in Copy{Agent,Cmd,Console}; do
install -Dm755 "$srcdir/launch.sh" "$pkgdir/usr/bin/$i"
done

All comments