Package Details: couchapp-git 20140302-1

Git Clone URL: https://aur.archlinux.org/couchapp-git.git (read-only)
Package Base: couchapp-git
Description: A set of helpers and a jQuery plugin that conspire to get you up and running on CouchDB quickly and correctly.
Upstream URL: http://github.com/couchapp/couchapp/
Licenses: Apache
Provides: couchapp
Submitter: DerGuteMoritz
Maintainer: nickoe
Last Packager: nickoe
Votes: 6
Popularity: 0.000000
First Submitted: 2009-06-29 20:58
Last Updated: 2015-06-19 19:31

Required by (0)

Sources (0)

Latest Comments

10111 commented on 2014-03-02 18:38

Forgot some new dependencies, python2-restkit and python2-watchdog, now I do not get any complaints about missing modules anymore when starting couchapp:

# Contributors: Moritz Heidkamp <moritz@twoticketsplease.de>, Sebastian Sauer <info@dynpages.de>
pkgname=couchapp-git
pkgver=20140302
pkgrel=1
pkgdesc="A set of helpers and a jQuery plugin that conspire to get you up and running on CouchDB quickly and correctly."
arch=('i686' 'x86_64')
url="http://github.com/couchapp/couchapp/"
license=('APACHE')
depends=('python2' 'python2-restkit' 'python2-watchdog')
makedepends=('git' 'setuptools')
provides=(couchapp)

_gitroot="git://github.com/couchapp/couchapp.git"
_gitname="couchapp"

build() {
cd "$srcdir"
msg "Connecting to GIT server...."

if [ -d $_gitname ] ; then
cd $_gitname && git pull origin
msg "The local files are updated."
else
git clone $_gitroot
fi

msg "GIT checkout done or server timeout"
msg "Starting make..."

rm -rf "$srcdir/$_gitname-build"
git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"

python2 setup.py build
}

package() {
cd "$srcdir/$_gitname-build"
python2 setup.py install --root "$pkgdir/"
}

10111 commented on 2014-03-02 18:30

This worked for me:

# Contributors: Moritz Heidkamp <moritz@twoticketsplease.de>, Sebastian Sauer <info@dynpages.de>
pkgname=couchapp-git
pkgver=20140302
pkgrel=1
pkgdesc="A set of helpers and a jQuery plugin that conspire to get you up and running on CouchDB quickly and correctly."
arch=('i686' 'x86_64')
url="http://github.com/couchapp/couchapp/"
license=('APACHE')
depends=('python2')
makedepends=('git' 'setuptools')
provides=(couchapp)

_gitroot="git://github.com/couchapp/couchapp.git"
_gitname="couchapp"

build() {
cd "$srcdir"
msg "Connecting to GIT server...."

if [ -d $_gitname ] ; then
cd $_gitname && git pull origin
msg "The local files are updated."
else
git clone $_gitroot
fi

msg "GIT checkout done or server timeout"
msg "Starting make..."

rm -rf "$srcdir/$_gitname-build"
git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"

python2 setup.py build
}

package() {
cd "$srcdir/$_gitname-build"
python2 setup.py install --root "$pkgdir/"
}

Anonymous comment on 2011-01-22 19:51

I really don't feel like maintaining this atm, but this PKGBUILD worked for me:

pkgname=couchapp-git
pkgver=20110122
pkgrel=2
pkgdesc="A set of helpers and a jQuery plugin that conspire to get you up and running on CouchDB quickly and correctly."
arch=('i686')
url="http://github.com/couchapp/couchapp/"
license=('APACHE')
depends=('python2')
makedepends=('git' 'setuptools')
provides=(couchapp)

_gitroot="git://github.com/couchapp/couchapp.git"
_gitname="couchapp"

build() {
cd "$srcdir"
msg "Connecting to GIT server...."

if [ -d $_gitname ] ; then
cd $_gitname && git pull origin
msg "The local files are updated."
else
git clone $_gitroot
fi

msg "GIT checkout done or server timeout"
msg "Starting make..."

rm -rf "$srcdir/$_gitname-build"
git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"

mkdir -p $pkgdir/usr/lib/python2.7/site-packages
python2 setup.py install --root=$pkgdir --install-data=/usr/lib/python2.7/site-packages
}

Anonymous comment on 2010-10-19 19:09

Can you please update package for new Python releases in Arch? Also program itself isn't workinkg:

$ couchapp
Traceback (most recent call last):
File "/usr/bin/couchapp", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2603, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 666, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 565, in resolve
raise DistributionNotFound(req) # XXX put more info here
pkg_resources.DistributionNotFound: restkit>=2.2.0


Any ideas?

yotann commented on 2010-05-15 23:12

Actually, it should be arch=('any').

Anonymous comment on 2010-04-04 09:34

Hi,

You can add x86_64 to this package, it works too.

Byron