Package Details: cplex 12.10-2

Git Clone URL: (read-only, click to copy)
Package Base: cplex
Description: A commercial solver for mathematical optimization problems.
Upstream URL:
Licenses: custom
Submitter: Viech
Maintainer: Viech (alberto-santini)
Last Packager: Viech
Votes: 3
Popularity: 0.000352
First Submitted: 2017-10-24 11:46
Last Updated: 2020-01-05 21:21

Latest Comments

1 2 Next › Last »

carlosal1015 commented on 2020-07-21 20:24

It works :-), thanks @Viech.

fifr commented on 2020-01-28 15:02

@Viech: sure, I meant without messing around with the pkgbuild ;)

Viech commented on 2020-01-28 13:58

That should be easy: Just remove makedepends, optdepends, _pythonver and the "Install Python bindings." section.

fifr commented on 2020-01-28 13:56

@Viech: actually, I'm one of those who prefer to not install any python bindings at all ... is this easily possible with the current package?

Or maybe there should be two packages?

Viech commented on 2020-01-28 13:49

I tried myself to get it to work with Python 3.8 by patching the setup scripts, but CPLEX strongly refuses to run with it. If you urge me to I can implement @fifr's solution but I'm not sure if this is what many users want; some of you might prefer to not install any Python bindings at all instead. And maybe 12.11 shows up soon…

fifr commented on 2020-01-28 09:44

@alberto-santini: thanks. I modified the pkgbuild as follows and it seems to work (at least the package has been installed):

  • replaced dependencies python>=3.7 and python<3.8 by 'python37' (which is currently an aur package)
  • replaced the calls to 'python' and 'python3' by 'python3.7' everywhere

I have no idea if this has side effects, though.

alberto-santini commented on 2020-01-28 09:33

@fifr: As far as I remember, CPLEX 12.10 will refuse to work with python 3.8 and wants python 3.7. If your core's python is 3.8, no matter if you install 3.7, I think this still violates "python<3.8".

Maybe we could change the depends to "python<=3.7" only? But I am afraid there is no way to tell the cplex installer to use 3.7 and not the default on your system (3.8) so installation would still fail.

Could you try to change the pkgbuild to this end, and see if you manage to install and use cplex with a double 3.7/3.8 python install?

fifr commented on 2020-01-28 08:55

This is probably a dump question but ... when installing the package it complains about "python<3.8" required. I assume that means that Python 3.7 or so is needed.

The "python" package shipped from the core is 3.8, so I installed the "python37" aur package, but that seems to be insufficient.

So what is the preferred way to solve this problem?

Thanks in advance.

Viech commented on 2018-09-28 18:10

I can look into adding OPLIDE with the next CPLEX release where I have to make PKGBUILD changes anyway (as I'm expecting Python 3.7 support with that). While your approach does reliably install everyting, I'd rather not use /opt with this package.

gamezelda commented on 2018-09-27 23:12

After installing this package, I noticed that it does a "reduced" install, e.g. it does not install OPLIDE which is what I am interested in.

I decided to try to go for a more as-is install and changed all the copy commands in package() to:

mkdir -p "$pkgdir/opt/ibm/ILOG/CPLEX"
cp -R "." "$pkgdir/opt/ibm/ILOG/CPLEX/"

Except a few warnings, so far it seems to work, e.g. OPLIDE launches. I haven't had a chance to play too much with it yet, I will update if I have some improvement.

EDIT: If anyone is interested, this is the PKGBUILD I ended up using in the end to to get an unmodified, no warnings, install:

EDIT: With /usr/bin shortcuts for some tools to avoid having to type: