Package Details: cpuminer 2.5.1-1

Git Clone URL: https://aur.archlinux.org/cpuminer.git (read-only, click to copy)
Package Base: cpuminer
Description: pooler's Litecoin cpuminer
Upstream URL: https://github.com/pooler/cpuminer
Licenses: GPL
Submitter: gee
Maintainer: rpodgorny
Last Packager: rpodgorny
Votes: 66
Popularity: 0.000000
First Submitted: 2012-02-29 05:34 (UTC)
Last Updated: 2020-12-20 11:34 (UTC)

Required by (0)

Sources (2)

Latest Comments

rpodgorny commented on 2017-06-25 07:38 (UTC)

ah, mea culpa - i've commited the wrong version. fixed now. thanks for noticing...

codyps commented on 2017-06-23 18:45 (UTC)

Looks like the build() fails because `make` is no longer called at all. Probably a good idea to call it and just omit the cflags modification.

rpodgorny commented on 2017-06-23 09:17 (UTC)

version bumped. caution: the optimized compilation is now disabled by default (for portability reasons) - you can enable it by hand in the pkgbuild.

gee commented on 2017-02-19 17:41 (UTC)

Nah it's cool, I don't use this anymore, better for you to maintain it :)

rpodgorny commented on 2017-02-19 00:36 (UTC)

uh-oh, now i see the message was not for me... ;-) ...if you want this, gee, i'll orphan it for you...

rpodgorny commented on 2017-02-19 00:34 (UTC)

done

petronny commented on 2017-02-18 18:34 (UTC)

@gee this package is orphaned now. Could you adopt it?

gee commented on 2017-02-16 15:28 (UTC)

I was trying to update and then realized it wasn't mine anymore, sorry :/

rpodgorny commented on 2017-02-16 14:49 (UTC)

the maintaner seems to be no longer interested. if he/she will orphan it, i'll make the updates.

aztec102 commented on 2017-02-16 14:39 (UTC)

Where is update this package?

rpodgorny commented on 2016-06-08 19:57 (UTC)

[Unit] Description=Multi-threaded CPU miner for Bitcoin and Litecoin After=network.target [Service] Type=simple PIDFile=/run/minerd.pid ExecStart=/usr/bin/minerd --config /etc/cpuminer.json ExecStop=/bin/kill -TERM $MAINPID CPUShares=1 [Install] WantedBy=multi-user.target

gee commented on 2014-05-28 08:06 (UTC)

Please provide one and I'll add it.

Vash63 commented on 2014-03-13 03:07 (UTC)

It would be really helpful if this included a .service file by default like cpuminer-git

gee commented on 2013-12-04 01:20 (UTC)

Thank you!

giddie commented on 2013-12-03 15:54 (UTC)

Some PKGBUILD tidying: You can remove the "makedepends" line: boost, automoc4: not required gcc, make, gawk: in "base" group, so shouldn't be specified And "gcc-libs" can be removed from the "depends" line, because it's also in the "base" group.

gee commented on 2013-12-03 13:27 (UTC)

Using the system makeflags so that if it is properly defined, you may get a boost!

gee commented on 2013-12-01 13:21 (UTC)

you are very welcome! Do you guys still really cpu-mine though? Is it still worth anything? Maybe it is for alt scrypt coins hmmmmmm.

vinilox commented on 2013-12-01 13:19 (UTC)

@gee thanks a lot ! :)

gee commented on 2013-12-01 12:20 (UTC)

Alright, done!

vinilox commented on 2013-12-01 12:05 (UTC)

@gee It's not needed to build but it does need it to run ;) Please add jansson as a dependence

gee commented on 2013-11-21 01:50 (UTC)

Hmm are you sure? I don't have it installed on my computer and I am able to build just fine.

a304yuan commented on 2013-11-17 12:51 (UTC)

I think the package jansson should be in the dependence array.

gee commented on 2013-09-08 05:31 (UTC)

I see.

codyps commented on 2013-09-08 05:21 (UTC)

On the m4 file: https://bugs.archlinux.org/task/36598?cat%5B0%5D=31&percent%5B0%5D=&pri%5B0%5D=&reported%5B0%5D=&sev%5B0%5D=3&status%5B0%5D=closed&string= That a similar bug, which links to the removal of the m4 file, and the removal states that packages should include it themselves.

gee commented on 2013-09-08 03:09 (UTC)

Thanks, I updated the pkgbuild here accordingly. Is there a way to not depend on that m4 file and get it from another package instead?

codyps commented on 2013-09-08 02:28 (UTC)

I've updated this pkgbuild for 2.3.2 and placed the PKGBUILD here: https://github.com/jmesmon/pkgbuilds/tree/master/cpuminer

EtiennePerot commented on 2013-05-17 14:19 (UTC)

Derp, this is not the -git package. Please ignore me

EtiennePerot commented on 2013-05-17 14:13 (UTC)

https://github.com/pooler/cpuminer shows the last commit being one month old (d35050c05a76f293a368d2680560b5cb73341550)

gee commented on 2013-04-07 20:03 (UTC)

@EtiennePerot: The last commit is from 9 months ago, where is the newer version?

gee commented on 2013-03-06 03:26 (UTC)

Updated. But since gpuminers came out, this is not that useful anymore...

lappi commented on 2013-02-21 13:27 (UTC)

Version 2.2.3 released https://github.com/pooler/cpuminer/downloads