Package Details: crosstool-ng 1.23.0-1

Git Clone URL: https://aur.archlinux.org/crosstool-ng.git (read-only)
Package Base: crosstool-ng
Description: Versatile (cross-)toolchain generator
Upstream URL: http://crosstool-ng.org/
Licenses: GPL
Submitter: None
Maintainer: bwalle
Last Packager: bwalle
Votes: 94
Popularity: 0.052723
First Submitted: 2009-01-18 10:45
Last Updated: 2017-05-02 15:19

Latest Comments

1 2 3 4 5 Next › Last »

tlater commented on 2019-02-16 15:30

I don't know where in the stack of tools this needs to be amended, but I needed this patch to make the package work:

diff -ura package.orig/configure package.new/configure
--- package.orig/configure  2019-02-16 15:18:44.262786118 +0000
+++ package.new/configure   2019-02-16 15:19:39.149454280 +0000
@@ -5799,7 +5799,7 @@
     for ac_exec_ext in '' $ac_executable_extensions; do
       ac_path_BASH_SHELL="$as_dir/$ac_prog$ac_exec_ext"
       as_fn_executable_p "$ac_path_BASH_SHELL" || continue
-ver=`$ac_path_BASH_SHELL --version 2>/dev/null| $EGREP '^GNU bash, version (3\.[1-9]|4)'`
+ver=`$ac_path_BASH_SHELL --version 2>/dev/null| $EGREP '^GNU bash, version (3\.[1-9]|4|5)'`
                 test -z "$ac_cv_path_BASH_SHELL" && ac_cv_path_BASH_SHELL=$ac_path_BASH_SHELL
                 test -n "$ver" && ac_cv_path_BASH_SHELL="$ac_path_BASH_SHELL" ac_path_BASH_SHELL_found=: acx_version_BASH_SHELL_ok=:
       $ac_path_BASH_SHELL_found && break 3

It looks like some autoconf setup somewhere isn't quite with the times.

PyroDevil commented on 2017-03-02 08:15

No don't add flex, patch, make and bison to the makedepends. Please remove them. They are part of the base-devel group.
Read: https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

Also do you have any fix for this error?

DEP 'zconf.tab.dep'
CC 'zconf.tab.o'
In file included from zconf.tab.c:212:0:
zconf.hash.c:167:1: error: conflicting types for 'kconf_id_lookup'
kconf_id_lookup (register const char *str, register size_t len)
^~~~~~~~~~~~~~~
zconf.hash.c:34:31: note: previous declaration of 'kconf_id_lookup' was here
static const struct kconf_id *kconf_id_lookup(register const char *str, register unsigned int len);
^~~~~~~~~~~~~~~
make[2]: *** [Makefile:89: zconf.tab.o] Error 1
make[1]: *** [Makefile:167: build-lib-kconfig] Error 2
make: *** [Makefile:127: build] Error 2

egore911 commented on 2017-02-26 19:50

Please also add flex and patch as makedepends

egore911 commented on 2017-02-26 15:50

Please add bison to makedepends.

checking for bison... no
configure: error: missing required tool: bison

dummys commented on 2016-05-14 06:42

New commit to fix gcc 6.0 bug: https://github.com/crosstool-ng/crosstool-ng/pull/392

BluePeril commented on 2015-07-27 16:11

Could you please add the checksums for version 1.21.0? Currently the checksums are for version 1.20.0

enunes commented on 2015-05-27 02:40

1.21.0 is out

Barthalion commented on 2014-11-14 14:32

Why do you ask me and not yaourt developers?

Anonymous comment on 2014-11-14 11:23

Why isn't this package showing up in the search results/yaourt?

Barthalion commented on 2014-09-10 09:56

Oops. I really need more coffee today. Fixed, thanks.