Package Details: cubicsdr-git 2:r1486.490f72c-1

Git Clone URL: https://aur.archlinux.org/cubicsdr-git.git (read-only)
Package Base: cubicsdr-git
Description: Cross-Platform Software-Defined Radio Application
Upstream URL: https://github.com/cjcliffe/CubicSDR
Licenses: GPL
Conflicts: cubicsdr
Submitter: valvetime
Maintainer: MicroJoe
Last Packager: MicroJoe
Votes: 18
Popularity: 0.052902
First Submitted: 2015-12-25 13:38
Last Updated: 2018-04-03 18:42

Dependencies (19)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

MicroJoe commented on 2018-08-20 05:48

@eduardosm my bad it seems to work locally with the ln inside the package() step, still the result of the build is actually failing upon wx error as described, not sure if due to packaging or upstream

MicroJoe commented on 2018-08-20 05:41

Hello,

@PTBM133A4X I do also get this error too once I rebuilded it locally, still not sure how to fix it

@eduardosm I have tried to remove it and create it in the package() step, but the link will not be present once installed. Can you try to do it locally and submit me a patch if it works without .install file?

eduardosm commented on 2018-08-15 15:29

Why is the link created in the install script instead of the PKGBUILD?

PTBM133A4X commented on 2018-06-24 22:04

Trying to install this gives me this error:

Fatal Error: Mismatch between the program and library build versions detected. The library used 3.1.1 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 3.0), and your program used 3.1.1 (wchar_t,compiler with C++ ABI 1012,wx containers,compatible with 3.0). Aborted (core dumped)

Any ideas?

MicroJoe commented on 2018-04-03 18:42

Fixed, thanks for the included solution!

m3thodic commented on 2018-04-02 21:26

Can you please update the cubicsdr-git.install file to include a -f in the ln command? It will cause an error when upgrading otherwise:

(1/1) reinstalling cubicsdr-git                                                                [########################################################] 100%
ln: failed to create symbolic link '/usr/bin/cubicsdr': File exists
error: command failed to execute correctly

Thanks!

MicroJoe commented on 2018-03-21 21:45

I have updated the dependencies, can you try a build to confirm it is ok? I do not have access to a powerful-enough rig right now for building the dependencies.

I the meanwhile binaries of wxgtk are available for Ubuntu/Debian/Fedora, maybe someone can unpack the binaries from rpm or deb using a new PKGBUILD for this: http://codelite.org/LiteEditor/WxWidgets31Binaries

parkerlreed commented on 2018-03-21 17:59

https://aur.archlinux.org/packages/wxgtk2-dev/

and

https://aur.archlinux.org/packages/wxgtk-common-dev/

(part of one PGBUILD series)

probably need to be new requirements. The downside is even on a 4c/8t machine at -j10 it took nearly 7 minutes to build those deps.

parkerlreed commented on 2018-03-20 13:09

This doesn't build at the moment due to upstream making wxWidgets 3.10+ a requirement.

https://github.com/cjcliffe/CubicSDR/pull/633#issuecomment-374580640

MicroJoe commented on 2018-02-13 20:21

Added, thanks