Package Details: cubicsdr-git 2:r1486.490f72c-1

Git Clone URL: https://aur.archlinux.org/cubicsdr-git.git (read-only, click to copy)
Package Base: cubicsdr-git
Description: Cross-Platform Software-Defined Radio Application
Upstream URL: https://github.com/cjcliffe/CubicSDR
Licenses: GPL
Conflicts: cubicsdr
Submitter: valvetime
Maintainer: MicroJoe
Last Packager: MicroJoe
Votes: 17
Popularity: 0.000000
First Submitted: 2015-12-25 13:38
Last Updated: 2018-04-03 18:42

Dependencies (19)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

MicroJoe commented on 2018-03-21 21:45

I have updated the dependencies, can you try a build to confirm it is ok? I do not have access to a powerful-enough rig right now for building the dependencies.

I the meanwhile binaries of wxgtk are available for Ubuntu/Debian/Fedora, maybe someone can unpack the binaries from rpm or deb using a new PKGBUILD for this: http://codelite.org/LiteEditor/WxWidgets31Binaries

parkerlreed commented on 2018-03-21 17:59

https://aur.archlinux.org/packages/wxgtk2-dev/

and

https://aur.archlinux.org/packages/wxgtk-common-dev/

(part of one PGBUILD series)

probably need to be new requirements. The downside is even on a 4c/8t machine at -j10 it took nearly 7 minutes to build those deps.

parkerlreed commented on 2018-03-20 13:09

This doesn't build at the moment due to upstream making wxWidgets 3.10+ a requirement.

https://github.com/cjcliffe/CubicSDR/pull/633#issuecomment-374580640

MicroJoe commented on 2018-02-13 20:21

Added, thanks

darsor commented on 2018-02-12 18:53

I started maintaining an AUR repo for soapyplutosdr-git here: https://aur.archlinux.org/packages/soapyplutosdr-git/. Please add as an optional dependency.

MicroJoe commented on 2018-02-10 19:11

Hello all, just took ownership and fixed soapysdr-git dependency. This PGKBUILD should build fine from now.

hri commented on 2017-12-16 14:23

pansen commented on 2016-11-11 18:52 'soapysdr' in PKBUILD line 19 needs to be 'soapysdr-git'

He has a point there. Plz change.

Refutationalist commented on 2017-05-20 07:30

I added some stuff to the PKGBUILD to build with jack audio support, which is useful.

https://gist.github.com/anonymous/7377f1889d2a154e0d403fd00ff41d43

arthurulfeldt commented on 2016-12-06 03:40

This package also depends on liquid-dsp-git

:: Building cubicsdr-git package(s)...
==> Making package: cubicsdr-git 2:r1212.239f392-1 (Mon Dec 5 19:33:57 PST 2016)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: liquid-dsp-git
==> ERROR: 'pacman' failed to install missing dependencies.

Which seems to be broken for the last couple weeks.

pansen commented on 2016-11-11 18:52

'soapysdr' in PKBUILD line 19 needs to be 'soapysdr-git'