Package Details: cubieboard-livesuit 306-3

Git Clone URL: https://aur.archlinux.org/cubieboard-livesuit.git (read-only)
Package Base: cubieboard-livesuit
Description: LiveSuit is a tool to flash Images to the NAND of Allwinner devices, such as Cubieboard1, Cubieboard2, and Cubietruck. This package use the ZIP that comes from official Cubieboard download page.
Upstream URL: http://cubieboard.org
Licenses: GPL
Submitter: figue
Maintainer: figue (figuepluto)
Last Packager: figuepluto
Votes: 12
Popularity: 0.148534
First Submitted: 2014-11-23 20:36
Last Updated: 2017-05-24 20:22

Latest Comments

figue commented on 2017-06-22 10:23

@cylax I guess it could be done, but it's a common practice follow upstream, at least in AUR packages /opt is a valid install path.

If you want to move something to another location, submit a patch, I will be glad to include it!

cylax commented on 2017-06-21 12:00

@figue You might consider installing the libs and main script in an appropriate location.

grigruss commented on 2017-05-25 05:10

@figue Ok! That's works! Thank you!

grigruss commented on 2017-05-24 21:08

@figue sorry. Now 00:05am. :-) After 8 hours.

figue commented on 2017-05-24 20:22

@grigruss thanks. I've added a simple patch. Now should build fine. Can you test it?

grigruss commented on 2017-05-24 11:39

Hi!
I can't install this, because have an error on kernel module build.
But I find the project in github: https://github.com/linux-sunxi/sunxi-livesuite
And it's work.
It's require install dkms, and run make in awusb/
Then copy awusb.ko in to /lib/modules/`uname -r`/kernel/
That's easy!

Sorry!
I have no problem with kernel module.
Problem with awusb.
In awusb.c (line 376) used function "signal_pending()", but no one file have this in headers... If I will find solution, I will write.

figue commented on 2016-02-12 15:19

Thanks @fishbone222.
I've also added i686 arch (not tested).

fishbone222 commented on 2016-02-11 19:25

linux-headers should be added to dependencies

geripgeri commented on 2015-12-13 14:13

@sappel It's worked for me! Thanks! :)

sappel commented on 2015-12-13 10:43

I had the same problem. For me installing the linux-headers-4.2.5-1 did the trick!

All comments