Package Details: cuda_memtest 1.2.3-2

Git Clone URL: https://aur.archlinux.org/cuda_memtest.git (read-only)
Package Base: cuda_memtest
Description: A GPU memory test utility for NVIDIA and AMD GPUs. OpenCL version.
Upstream URL: http://cudagpumemtest.sourceforge.net/
Keywords: amd cuda gpu memory memtest nvidia opencl test
Licenses: Illinois Open Source License
Submitter: revel
Maintainer: revel
Last Packager: revel
Votes: 30
Popularity: 0.138522
First Submitted: 2011-06-24 23:18
Last Updated: 2016-05-29 05:25

Latest Comments

revel commented on 2016-05-29 05:26

The package works again!

revel commented on 2016-05-21 16:32

You're right, it's broken again. Someone needs to make it work with up-to-date compiler. Unfortunately, this project is not maintained anymore upstream. So, for the time being, this package is down.

mati865 commented on 2016-05-21 12:55

It doesn't build

http://pastebin.com/pzQ2zhqd

revel commented on 2015-12-15 23:34

After rebuild it works for me again.

revel commented on 2015-10-30 17:58

Well, it doesn't work for me anymore.
Unfortunately, I think this project is outdated/broken, it hasn't been updated upstream for a few years already.

[10/30/2015 18:53:27][arch][0]:Test0 [Walking 1 bit]
[10/30/2015 18:53:27][arch][0]:Test0: global walk test
[10/30/2015 18:53:27][arch][0]:Test0: local walk test
[10/30/2015 18:53:27][arch][0]:Test0 finished in 0.0 seconds
[10/30/2015 18:53:27][arch][0]:Test1 [Own address test]
ERROR: opencl call failed with rc(-5), line 39, file ocl_tests.cpp
Error: Out of resources

penetal commented on 2015-10-30 15:58

@ackalker:
I have the same problem as the others:
CL_PLATFORM_NAME: NVIDIA CUDA
CL_PLATFORM_VERSION: OpenCL 1.2 CUDA 7.5.0
Device 0 is CL_DEVICE_TYPE_GPU, "GeForce GTX 680"
allocated 3318 Mbytes from device 0
[10/30/2015 16:48:19][localhost][0]:Test0 [Walking 1 bit]
[10/30/2015 16:48:19][localhost][0]:Test0: global walk test
ERROR: opencl call failed with rc(-5), line 39, file ocl_tests.cpp
Error: Out of resources

I have these packages:
#pacman -Qs nvidia |grep local
local/cuda_memtest 1.2.3-1
local/lib32-nvidia-libgl 355.11-1
local/lib32-nvidia-utils 355.11-1
local/lib32-opencl-nvidia 355.11-1
local/libvdpau 1.1.1-1
local/nvidia 355.11-3
local/nvidia-libgl 355.11-1
local/nvidia-utils 355.11-1
local/opencl-nvidia 355.11-1

#pacman -Qs opencl |grep local
local/cuda_memtest 1.2.3-1
local/lib32-ocl-icd 2.2.7-1
local/lib32-opencl-nvidia 355.11-1
local/ocl-icd 2.2.7-1
local/opencl-headers 2:2.0.20150827-1
local/opencl-nvidia 355.11-1

Are you able to see if I am still missing something?

ackalker commented on 2015-03-15 17:00

@lesebas, @kbs1:
Please make sure that you have installed the proper OpenCL support libraries for your GPU (I'm guessing it's unwieldy to just include all of them in the package dependencies, the many different nvidia ones will probably conflict with each other anyway).

Match your video driver, then choose from:
- Mesa: opencl-mesa
- AMD/ATI (proprietary): opencl-catalyst
- NVIDIA (proprietary): opencl-nvidia, opencl-nvidia-XXXX

revel commented on 2014-10-26 07:53

I'm not sure how to help you, it works fine for me. Perhaps someone with a similar problem will figure it out and post a solution here. You could also try submitting a bug report upstream, maybe somebody would be able to help you there http://cudagpumemtest.sourceforge.net/

kbs1 commented on 2014-10-26 06:12

Exactly the same problem, any help?

lesebas commented on 2014-01-30 20:15

Hello, failed to run the test :

[sebastien@Lupus ~]$ ocl_memtest
hostname is Lupus
ERROR: opencl call failed with rc(-1001), line 112, file ocl_memtest.cpp
Error: Unknown

graysky commented on 2011-08-08 20:33

1.2.2 is out....