Package Details: cufflinks 2.2.1-3

Git Clone URL: https://aur.archlinux.org/cufflinks.git (read-only)
Package Base: cufflinks
Description: Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples..
Upstream URL: http://cole-trapnell-lab.github.io/projects/cufflinks/
Licenses: Artistic
Submitter: stratust
Maintainer: greyltc
Last Packager: greyltc
Votes: 2
Popularity: 0.000036
First Submitted: 2012-01-20 01:13
Last Updated: 2016-07-01 16:09

Latest Comments

greyltc commented on 2015-06-07 14:37

What's partial about this solution?

khughitt commented on 2015-06-07 11:11

Partial solution:
1. fix url
2. modify LDFLAGS:
export LDFLAGS="-L/usr/lib -lboost_system -lboost_filesystem -lboost_thread"

khughitt commented on 2015-06-05 16:07

After fixing URL, compilation still fails:

/usr/include/boost/smart_ptr/shared_ptr.hpp:467:14: error: no type named ‘type’ in ‘struct boost::detail::sp_enable_if_auto_ptr<boost::shared_ptr<const ReadGroupProperties>, int>’
common.h:387:5: error: ‘LocusCount::LocusCount()’ is private
LocusCount() {} //needs an empty constructor for serialization
^
In file included from common.h:34:0,
from hits.h:23,
from abundances.h:23,
from abundances.cpp:16:
/usr/include/boost/serialization/vector.hpp:90:9: error: within this context
t.resize(count);

Makefile:1418: recipe for target 'abundances.o' failed
make[2]: *** [abundances.o] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp-keith/aur-cufflinks/src/cufflinks-2.2.1/src'
Makefile:258: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-keith/aur-cufflinks/src/cufflinks-2.2.1'
Makefile:196: recipe for target 'all' failed
make: *** [all] Error 2

Looks like many of the issues are related to BOOST.

greyltc commented on 2015-03-10 17:04

@stratust can you please update the PKGBUILD?
I'm getting
==> ERROR: Failure while downloading cufflinks-2.2.1.tar.gz
and I assume this is because the repo was moved (see below).
Or feel free to orphan this package and I'll happily pick it up.

gilesc commented on 2015-01-15 21:09

Apparently the source has been moved to Github, and the files at the URL referred to in the PKGBUILD removed. So this package no longer builds.

alexpe87 commented on 2014-12-16 10:35

They moved the repository to somewhere else, you should add this as the new URL:

http://cole-trapnell-lab.github.io/cufflinks/assets/downloads/cufflinks-2.2.1.tar.gz

wookietreiber commented on 2014-12-11 13:56

I narrowed it down to the relevant change being introduced in boost 1.56 (see github issue). Until the issue is fixed, I recommend to update the PKGBUILD to reflect depends boost<1.56.0

wookietreiber commented on 2014-12-11 13:02

currently does not compile, see

https://github.com/cole-trapnell-lab/cufflinks/issues/3

vejnar commented on 2013-06-06 00:15

With 2.1.1, the gcc and foreach patches are no longer needed as far as I can tell.

Could you please update the PKGBUILD?