Package Details: cups-ipp14 2.3.3-1

Git Clone URL: https://aur.archlinux.org/cups-ipp14.git (read-only, click to copy)
Package Base: cups-ipp14
Description: The CUPS Printing System - client libraries and headers
Upstream URL: https://www.cups.org/
Licenses: GPL
Conflicts: cups
Provides: cups
Replaces: cups
Submitter: Medved
Maintainer: None
Last Packager: TheGoliath
Votes: 3
Popularity: 0.000000
First Submitted: 2012-12-30 22:01 (UTC)
Last Updated: 2020-05-12 13:01 (UTC)

Required by (620)

Sources (10)

Pinned Comments

Latest Comments

patrick commented on 2018-02-12 13:44 (UTC)

"That's right " , après quelques difficultés , en passant par ce type de lien : https://aur.archlinux.org/cgit/aur.git/snapshot/cups-ipp14.tar.gz pour cups et libcups . Celui ci n'a pas fonctionné :https://github.com/apple/cups/releases/download/v2.2.6/cups-2.2.6-source.tar.gz . Add the missing CUPS.org GPG keys : n'a pas résolu le problème de clé ( KEY). Donc installation :(dirty) . Merci , thank .

Medved commented on 2018-02-12 07:34 (UTC) (edited on 2018-02-12 07:35 (UTC) by Medved)

@patrick, alright - there is nothing wrong with the package. It's just that the CUPS GPG key is not known to your system. You can read more about how GPG keys are used by "pacman" and "makepkg" here:

https://wiki.archlinux.org/index.php/GnuPG#Import_a_public_key

Now you have 2 options:

1) (dirty) use the "--skippgpcheck" option when calling "makepkg". That will skip GPG checks alltogether. This is not recommended for security reason, but it's the simplest way to go.

2) (the right way) Add the missing CUPS.org GPG keys. To do to, go to this link:

https://www.cups.org/pgp.html

Then copy the 2 GPG keys (current and previous) into 2 distinct files on your local machine: "cups.gpg.key" and "cups.prev.gpg.key"

Then import these files using the "gpg" utility:

gpg --import cups.gpg.key

gpg --import cups.prev.gpg.key

After this the "makepkg" will recognize the CUPS GPG key and will be able to verify the downloaded CUPS sources.

patrick commented on 2018-02-12 06:48 (UTC)

Voila ce que j'ai : makepkg ==> Création du paquet cups-ipp14 2.2.6-4 (lun. févr. 12 10:46:03 +04 2018) ==> Vérification des dépendances pour l’exécution... ==> Vérification des dépendances pour la compilation... ==> Récupération des sources... -> Téléchargement de cups-2.2.6-source.tar.gz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 614 0 614 0 0 399 0 --:--:-- 0:00:01 --:--:-- 399 100 9.8M 100 9.8M 0 0 552k 0 0:00:18 0:00:18 --:--:-- 740k -> Téléchargement de cups-2.2.6-source.tar.gz.sig... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 618 0 618 0 0 497 0 --:--:-- 0:00:01 --:--:-- 497 100 543 100 543 0 0 195 0 0:00:02 0:00:02 --:--:-- 560 -> cups.logrotate trouvé -> cups.pam trouvé -> cups.sysusers trouvé -> guid.patch trouvé -> cups-no-export-ssllibs.patch trouvé -> cups-no-gzip-man.patch trouvé -> cups-1.6.2-statedir.patch trouvé -> cups-systemd-socket.patch trouvé -> add-ipp-backend-of-cups-1.4.patch trouvé ==> Validation des fichiers source avec sha256sums... cups-2.2.6-source.tar.gz ... Réussite cups-2.2.6-source.tar.gz.sig ... Ignoré cups.logrotate ... Réussite cups.pam ... Réussite cups.sysusers ... Réussite guid.patch ... Réussite cups-no-export-ssllibs.patch ... Réussite cups-no-gzip-man.patch ... Réussite cups-1.6.2-statedir.patch ... Réussite cups-systemd-socket.patch ... Réussite add-ipp-backend-of-cups-1.4.patch ... Réussite ==> Vérification des signatures des fichiers sources grâce à gpg... cups-2.2.6-source.tar.gz ... ÉCHEC (Clé publique inconnue DBA3A7AB08D76223) ==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées. Patrick

Medved commented on 2018-02-11 20:54 (UTC) (edited on 2018-02-11 20:55 (UTC) by Medved)

@patrick, that is just not possible - PKGBUILD is the single file present in any Arch package. You're doing something wrong or your "makepkg" is broken. Try this (just did on my PC):

wget https://aur.archlinux.org/cgit/aur.git/snapshot/cups-ipp14.tar.gz

bsdtar -xf cups-ipp14.tar.gz

cd cups-ipp14

makepkg

patrick commented on 2018-02-11 17:37 (UTC)

Bonjour . Même soucis pas de fichier PKGBUILD dans l'archive . makepkg ==> ERREUR : PKGBUILD n’existe pas.

==> ERREUR : An unknown error has occurred. Exiting... Ce fichier existait dans l'archive 1.2.3 conservé sur mon ordi .

Medved commented on 2018-02-10 21:49 (UTC)

Updated to 2.2.6.

@patrick: Can you check with the new version please? Peux-tu vérifier avec la nouvelle version s'il te plaît ?

patrick commented on 2018-02-07 13:18 (UTC)

Ne fonctionne pas . makepkg indique PGKBUILD n'existe pas . libcups-ipp14 à la même archive.

Denshou commented on 2017-03-28 07:17 (UTC)

Merci pour le paquet l'ami ! Il y a juste un soucis avec la dépendance libcups-ipp144>=2.2.2 il me semble. En tout cas, je ne parviens pas à mettre cups-ipp14 à jour. Peux-tu m'aider s'il te plaît ?

patrick commented on 2016-06-01 19:11 (UTC)

It's OK for me !!! Merci pour la mise à jour ... Patrick

Medved commented on 2016-05-30 00:03 (UTC)

@Patrick, j'ai MAJ jusqu'à la version 2.1.3. Chez moi ça fonctionne pour les protocoles standard. Pas contre je ne peux pas vérifier si le protocole IPP14 fonctionne (je ne suis plus chez Orange). Il est bien dans la liste de protocoles disponibles par contre. Veux tu être mon beta-testeur ? I've update the package to 2.1.3 version. It works for me for official protocols. However I can't check if IPP14 protocol still works (I don't have an Orange box anymore). Anyhow, the IPP14 is present in the avalable protocol list. Just need somebody to test it. Would you mind be my beta-tester?

patrick commented on 2016-05-28 20:31 (UTC)

Semble ne pas être à jour ... ne fonctionne pas.

hickop commented on 2013-11-16 07:05 (UTC)

Thank you for quick update !

Medved commented on 2013-11-14 17:44 (UTC)

@hickop, yup... the package should be updated to 1.7 source code. I already did that the last week-end. I still have a small issue to solve for systemd to start CUPS properly, otherwise it's working. In a few hours you'll have your update, just wait for me to get home.

hickop commented on 2013-11-14 17:13 (UTC)

Starting daemon and then trying to access it inside browser at 127.0.0.1:631 makes cupsd to crash with this log: Nov 14 18:03:11 moineau systemd[1]: cups.service: main process exited, code=dumped, status=11/SEGV Nov 14 18:03:11 moineau systemd[1]: Unit cups.service entered failed state. Nov 14 18:03:11 moineau systemd-coredump[3056]: Process 2966 (cupsd) dumped core.

Medved commented on 2013-06-03 08:57 (UTC)

@notthesun, updated to 1.6.2. Should work now.

notthesun commented on 2013-06-01 07:47 (UTC)

hi guys, this host is down ftp://ftp.easysw.com/pub/cups/1.6.1/cups-1.6.1-source.tar.bz2 i can't install this package...

Medved commented on 2012-12-30 22:14 (UTC)

This package contains the Debian/Ubuntu patch that ads the cups 1.4 IPP backend. This backend is needed for some printer servers that cannot be upgraded (especially for Orange Livebox distributed in France). The old ipp backend is accessed through an URL of the form ipp14://<server>[:<port>]/<path_to_ipp> If you ever upgraded your cups from 1.4 to 1.5 and up, and noticed that you cannot print anymore with a message like "missing validate job", you should be a victim of this "regression". Of course, first of all check out if the vendor has released an update to the driver in order to make it work with newer cups. If it's not the case, than this package that includes the old backend is your only reasonable choice. More on the bug: https://bugs.launchpad.net/ubuntu/+source/cups/+bug/945028