Package Details: cura 5.3.0-1

Git Clone URL: https://aur.archlinux.org/cura.git (read-only, click to copy)
Package Base: cura
Description: A software solution for 3D printing aimed at RepRaps and the Ultimaker.
Upstream URL: https://ultimaker.com/software/ultimaker-cura
Keywords: 3d cura printing
Licenses: LGPL
Provides: cura
Submitter: jelly
Maintainer: batot
Last Packager: batot
Votes: 7
Popularity: 0.54
First Submitted: 2022-09-01 19:30 (UTC)
Last Updated: 2023-04-08 08:32 (UTC)

Latest Comments

1 2 3 Next › Last »

MountainKing73 commented on 2024-01-20 21:58 (UTC)

The error below is from libarcus-git, which appears to be orphaned.

whatever888 commented on 2024-01-14 14:08 (UTC)

Issue with build stage:

CMake Error at CMakeLists.txt:4 (find_package):
  By not providing "Findstandardprojectsettings.cmake" in CMAKE_MODULE_PATH
  this project has asked CMake to find a package configuration file provided
  by "standardprojectsettings", but CMake did not find one.

  Could not find a package configuration file provided by
  "standardprojectsettings" with any of the following names:

    standardprojectsettingsConfig.cmake
    standardprojectsettings-config.cmake

  Add the installation prefix of "standardprojectsettings" to
  CMAKE_PREFIX_PATH or set "standardprojectsettings_DIR" to a directory
  containing one of the above files.  If "standardprojectsettings" provides a
  separate development package or SDK, be sure it has been installed.

MarsSeed commented on 2023-08-07 19:44 (UTC) (edited on 2024-01-07 04:59 (UTC) by MarsSeed)

Hi. The new release 5.4.0 (Jul 4, 2023) now requires python-pyqt6 and its python-pyqt6-sip module.

fenugrec commented on 2023-07-11 00:16 (UTC)

Recent build problems seem to be due to some recent upstream changes to their buildsys ; CMakeLists.txt states "only used to build translations". The previous file was deleted at some point between 4.x and 5.2 : https://github.com/Ultimaker/Cura/commit/ec4c18f09a03de43dff884a4a4f2cce37bbad795

dbrgn commented on 2023-06-30 13:25 (UTC) (edited on 2023-06-30 13:25 (UTC) by dbrgn)

Same issue as tinitus, no binary is contained when clean-building this package:

danilo@c3po:~$ pacman -Ql cura
cura /usr/
cura /usr/share/
cura /usr/share/cura/
cura /usr/share/cura/resources/
cura /usr/share/cura/resources/i18n/
cura /usr/share/cura/resources/i18n/cs_CZ/
...
cura /usr/share/cura/resources/i18n/zh_TW/LC_MESSAGES/fdmprinter.def.json.mo
danilo@c3po:~$

batot commented on 2023-06-21 21:39 (UTC) (edited on 2023-06-21 21:40 (UTC) by batot)

@Sm112 @deimosfr If you have problems with the package arcus, please contact the maintainer of this package for help.
I don't have time testing this with all on the world installers.

Cura was tested with yay and working property.

]$ pacman -Q cura
cura 5.3.0-1
]$ pacman -Q python
python 3.11.3-1

Sml112 commented on 2023-06-21 18:33 (UTC)

Hi everybody,

no any updates? I'm still facing this issue :-( :-(

Sml112 commented on 2023-06-07 18:28 (UTC) (edited on 2023-06-07 18:31 (UTC) by Sml112)

@deimosfr @batot

I have exactly the sane problem while installing arcus, even if python is already on new version

  ]$ pacman -Q python
  python 3.11.3-1

still getting the same error

  CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230       (message):
    Could NOT find Python (missing: Python_EXECUTABLE Python_INCLUDE_DIRS
    Python_LIBRARIES Interpreter Development Development.Module
    Development.Embed) (found suitable exact version "3.10")

        Reason given by package: 
       Interpreter: Wrong version for the interpreter "/sbin/python"

  Call Stack (most recent call first):
    /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600       (_FPHSA_FAILURE_MESSAGE)
    /usr/share/cmake/Modules/FindPython/Support.cmake:3766       (find_package_handle_standard_args)
    /usr/share/cmake/Modules/FindPython.cmake:580 (include)
    CMakeLists.txt:118 (find_package)

Any idea, please?

batot commented on 2023-05-29 08:18 (UTC) (edited on 2023-05-29 09:04 (UTC) by batot)

@deimosfr If you have problems with the package arcus, please contact the maintainer of this package for help.

==> Finished making: cura 5.3.0-1 (Mon, May 29, 2023, 10:13:49)
]$ pacman -Q python
python 3.10.8-3

as you see working on python 3.10 too. I'm using yay not arcus.

In the AUR and PKGBUILD scripts, there are no restrictions on the PYTHON version. There are two possibilities, either you have something wrong with your system or the arcus is faulty. As you can see YAY works fine.

BTW: Archlinux it is Rolling Release distribution. Therefore, I am not responsible for not working if you do not have up-to-date packages.

deimosfr commented on 2023-05-26 14:25 (UTC)

Hi, I can't install this version because arcus is looking for python 3.11 while 3.10 is the current one on Arch is 3.11. Is there any quick way to avoid this?

Thanks

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Python (missing: Python_EXECUTABLE Python_INCLUDE_DIRS
  Python_LIBRARIES Interpreter Development Development.Module
  Development.Embed) (found suitable exact version "3.10")

      Reason given by package: 
          Interpreter: Wrong version for the interpreter "/sbin/python"

Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindPython/Support.cmake:3766 (find_package_handle_standard_args)
  /usr/share/cmake/Modules/FindPython.cmake:580 (include)
  CMakeLists.txt:118 (find_package)