Package Details: curl-git 7.47.0.18.g0515e49-1

Git Clone URL: https://aur.archlinux.org/curl-git.git (read-only)
Package Base: curl-git
Description: A URL retrieval utility and library
Upstream URL: http://curl.haxx.se/
Licenses: MIT
Conflicts: curl
Provides: curl=999
Submitter: falconindy
Maintainer: falconindy
Last Packager: falconindy
Votes: 6
Popularity: 0.030225
First Submitted: 2010-10-24 14:17
Last Updated: 2016-02-03 15:43

Required by (871)

Sources (2)

Latest Comments

falconindy commented on 2013-01-23 11:02

No... maybe you should take the advice of configure and fix your flags in /etc/makepkg.conf.

Anonymous comment on 2013-01-23 05:09

Anyone else getting this?

configure: using CFLAGS: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2
configure: CFLAGS error: CFLAGS may only be used to specify C compiler flags, not macro definitions. Use CPPFLAGS for: -D_FORTIFY_SOURCE=2
configure: error: Can not continue. Fix errors mentioned immediately above this line.

Anonymous comment on 2012-04-24 14:49

OK, the new PKGBUILD works.

falconindy commented on 2012-04-19 09:56

If you'd care to look at the PKGBUILD, you would have noticed that this was already done. I've just not kept up to date with it. I've fixed it in the laziest way possible.

Anonymous comment on 2012-04-19 09:53

When installing the package the system complains of curl-git conflicting with many other packages that depend on a minimum version of curl. Maybe the PKGBUILD should specify which minimum version it is offering to avoid such conflicts.

falconindy commented on 2011-10-19 18:49

And m4, and gcc, and binutils... All are part of the base-devel group and as such, it's assumed that you have these installed.

https://wiki.archlinux.org/index.php/ABS#Details

shaurz commented on 2011-10-19 18:39

Also automake.

shaurz commented on 2011-10-19 18:38

Needs autoconf adding to makedepends.

falconindy commented on 2011-02-13 15:20

Now building with --enable-threaded-resolver