Package Details: cutegram-git 2.9.5.dev.r26.g20690bd-1

Git Clone URL: https://aur.archlinux.org/cutegram-git.git (read-only)
Package Base: cutegram-git
Description: Telegram client by Aseman Land
Upstream URL: http://aseman.co/cutegram
Licenses: GPL
Submitter: Llumex03
Maintainer: None
Last Packager: farseerfc
Votes: 17
Popularity: 0.000000
First Submitted: 2015-02-06 15:41
Last Updated: 2016-09-24 08:09

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

JZA commented on 2016-05-13 12:05

I have issues with supergroups, the app crash when trying to type on them. Here is the coredump:
http://dpaste.com/1MYJ6G7

farseerfc commented on 2016-01-25 09:15

@dawnson updated AUR and [community] packages:
cutegram-2.7.1-3-x86_64.pkg.tar.xz (x86_64)
libqtelegram-ae-3:6.1-2-x86_64.pkg.tar.xz (x86_64)
telegramqml-0.9.2-2-x86_64.pkg.tar.xz (x86_64)
They should work with qt5-base-git now.
BTW the packages in [community] are only 8 commits behind the master branch. The -git packages only updated russian language translations after 2.7.1 is released. The stable packages are more recommended than -git ones.

farseerfc commented on 2016-01-25 08:42

@dawnson It should be provided by qt5-base ... Hang on for a minute, I am removing the version checks on all cutegram related packages (AUR and [community]). It will work with qt5-base-git after then.

dawnson commented on 2016-01-25 08:31

Ok, building qt5 myself worked, but now i get:

/tmp/yaourt-tmp-dawnson/aur-cutegram-git/./PKGBUILD: line 43: qmake-qt5: command not found

I am not sure which package does provide this, but using qmake isntead of qmake-qt5 worked.

dawnson commented on 2016-01-25 07:31

Thanks for the quick reply, i will report it to qt5-base-git

//edit

It looks like i am using a qt5-base-git package from the papyros repo, which might be causing the issue. I will try the libqtelegram-ae-git option.

farseerfc commented on 2016-01-25 07:03

@dawnson I think the problem here is cutegram-git (actually libqtelegram-ae-git) requires a specific version of qt5 (qt5-base >= 5.5), while qt5-base-git provides "qt5-base" rather than "qt5-base==5.5.1". One way to solve this problem is to edit the line in qt5-base-git/PKGBUILD as:
provides=("$_pkgname==$pkgver")
But this solution requires a rebuild of qt5 (potentially a waste of time).

Another way is to edit libqtelegram-ae-git/PKGBUILD and remove the version check on qt5-base. Make sure to check the right qt5 version by yourself.
The same modification is needed for qt5-webkit.
(Maybe we should report this problem to qt5-*-git package as this will affect all other packages that require a specific version of qt5)

dawnson commented on 2016-01-25 06:48

I always get :: qt5-base and qt5-base-git are in conflict. Remove qt5-base-git? [y/N]
which is strange because qt5-base-git should be working?

farseerfc commented on 2015-07-09 08:33

@nylocx thanks a lot! I have updated the PKGBUILD of the stable versions add add a new package telegramqml in aur. I will update the git version packages soon.

nylocx commented on 2015-07-09 07:53

I just noticed that they changed there version scheme, minimal libqtelegram-ae is now in Version 0.5.0 and minimal telegramqml 0.8.0
My cCurrent build is:
Name : libqtelegram-ae-git
Version : 1:0.5.0.stable.r0.g07872f5-1

Name : telegramqml-git
Version : 0.8.0.stable.r0.gc8a2956-1

Name : cutegram-git
Version : 2.5.0.stable.r2.g865c835-1

This combination seems to work.

farseerfc commented on 2015-06-27 10:55

@nylocx thank you a lot for writing this package.
I use your PKGBUILD and have uploaded https://aur4.archlinux.org/packages/telegramqml-git/ .
Hope it will fix the building process. Thank you again!