Package Details: cutelyst-docs 3.0.0-1

Git Clone URL: https://aur.archlinux.org/cutelyst.git (read-only, click to copy)
Package Base: cutelyst
Description: Doxygen HTML API Documentation
Upstream URL: http://cutelyst.org
Keywords: mvc web
Licenses: LGPL2.1
Submitter: majewsky
Maintainer: sxw
Last Packager: sxw
Votes: 4
Popularity: 0.000000
First Submitted: 2014-12-27 17:02
Last Updated: 2021-07-06 12:06

Latest Comments

1 2 Next › Last »

gdamjan commented on 2021-07-07 17:17

this'll break my https://aur.archlinux.org/packages/virtlyst/ package now I guess

sxw commented on 2021-07-06 12:14

Cutelyst 3 got released. Unfortunately it does not build with the uwsgi plugin turned on and Grantlee/Cutelee have not seen an update to build with Qt6 yet. So I guess we have to wait for upstream or somebody has to create a cutelyst-qt5 package or something.

gdamjan commented on 2021-07-05 23:42

or (found a better way)

just add

-DCMAKE_PREFIX_PATH=/usr/lib/cmake/Qt5/ \

to the cmake options

gdamjan commented on 2021-07-05 21:02

Hi, when building the package on an Arch systemd that also has qt6 installed, but grantlee 5.2.0-3 too - the cmake fails with:

CMake Error: The INTERFACE_QT_MAJOR_VERSION property of "Qt6::Core" does
not agree with the value of QT_MAJOR_VERSION already determined
for "grantlee_cutelyst".

CMake Error: The INTERFACE_QT_MAJOR_VERSION property of "Qt6::Core" does
not agree with the value of QT_MAJOR_VERSION already determined
for "Cutelyst2Qt5ViewGrantlee".

ie, it first selects Qt6, but then conflicts with grantlee depending on Qt5.

I've had to add the following patch:

--- a/CMakeLists.txt    2021-01-19 13:47:57.000000000 +0100
+++ b/CMakeLists.txt    2021-07-05 22:43:30.139701433 +0200
@@ -15,7 +15,7 @@

 include(GNUInstallDirs)

-find_package(QT NAMES Qt6 Qt5 COMPONENTS Core Network Sql REQUIRED)
+find_package(QT NAMES Qt5 COMPONENTS Core Network Sql REQUIRED)
 find_package(Qt${QT_VERSION_MAJOR} 5.6.0 COMPONENTS Core Network Sql REQUIRED)

 set(CUTELYST_API_LEVEL "2")

sxw commented on 2018-11-13 18:28

Done

lilmike commented on 2018-11-13 02:57

Package should probably makedepend on pkgconf, since cmake refuses to build without it.

sxw commented on 2018-05-05 20:43

@gdamjan Thx, sorry. I wasn't sure if the uwsgi plugin was dropped in favour of the cutelyst-wsgi tool.

gdamjan commented on 2018-05-03 12:31

maybe the PLUGIN_UWSGI should be enabled too? (since the package already depends on it)

sxw commented on 2018-04-24 18:41

@gdamjan Should be fixed in rel 2.

gdamjan commented on 2018-04-23 16:35

CMake Warning:                                                                                                                                                           
  Manually-specified variables were not used by the project:

  UWSGI_PLUGINS_DIR


-- Build files have been written to: /tmp/cutelyst/build