Package Details: d-tracker 1.3.r1.g3481fc4-1

Git Clone URL: (read-only, click to copy)
Package Base: d-tracker
Description: Lightweight, cross-platform and simple to setup timetracker. Similar to hamster but uses about 10MB of RAM and has a small quantity of dependencies.
Upstream URL:
Keywords: timetracker
Licenses: MIT
Submitter: drmargarido
Maintainer: drmargarido
Last Packager: drmargarido
Votes: 2
Popularity: 0.000000
First Submitted: 2020-02-05 01:15 (UTC)
Last Updated: 2020-04-14 20:11 (UTC)

Dependencies (8)

Required by (1)

Sources (1)

Latest Comments

Cork commented on 2021-05-10 05:37 (UTC)

Well this is interesting, building base directly from PKGBUILD works on first try..

@@ -18,7 +18,18 @@ pkgver() {

 build() {
        cd "${srcdir}/${pkgname}"
-       make
+       make structure
+       make linux_platform
+       make luajit
+       make date
+       make argparse
+       make freetype2
+       make tekui
+       make lsqlite
+       make luafilesystem
+       make lnotify
+       make lclipboard
+       make timetracker

 package() {

Cork commented on 2021-05-10 05:15 (UTC)

Can verify that running makepkg twice works for me.

E3LDDfrK commented on 2021-02-07 08:14 (UTC) (edited on 2021-02-07 08:14 (UTC) by E3LDDfrK)

Failed to build at the same step as nipsky's comment.

nipsky commented on 2020-09-11 11:02 (UTC)

Hmm, that didn’t change anything. I can compile the git version fine manually.

drmargarido commented on 2020-09-07 23:08 (UTC)

I'm not sure yet what is causing the problem. I get that error the first time I run the makepkg command, but the second time I run it, the build process works without problem. Can you try running the makepkg command twice?

nipsky commented on 2020-09-06 00:06 (UTC)

Hi, I’m trying to install d-tracker on a new machine and running into trouble. Here are the last lines:

libtool: link: ( cd "/home/andre/.cache/pikaur/build/d-tracker/src/d-tracker/external/freetype2/objs/.libs" && rm -f "" && ln -s "../" "" )
rm -f builds/unix/freetype-config builds/unix/freetype-config.tmp
sed -e 's|%LIBSSTATIC_CONFIG%|-lfreetype -lz -lbz2 -lpng16 -lm -lm -lz -lharfbuzz -pthread -lm -lfreetype -lbz2 -lz -lpng16 -lm -lm -lz -lgraphite2 -lglib-2.0 -pthread -lpcre -pthread -lbrotlidec -lbrotlicommon|'   \
    -e 's|%PKG_CONFIG%|/usr/bin/pkg-config|'                 \
    -e 's|%build_libtool_libs%||' \
    -e 's|%exec_prefix%|/usr/local|'               \
    -e 's|%ft_version%|23.1.17|'                 \
    -e 's|%includedir%|/usr/local/include|'                 \
    -e 's|%libdir%|/usr/local/lib|'                         \
    -e 's|%prefix%|/usr/local|'                         \
    /home/andre/.cache/pikaur/build/d-tracker/src/d-tracker/external/freetype2/builds/unix/                                                 \
    > builds/unix/freetype-config.tmp
chmod +x builds/unix/freetype-config.tmp
chmod go-w builds/unix/freetype-config.tmp
mv builds/unix/freetype-config.tmp builds/unix/freetype-config
rm -f builds/unix/freetype2.pc builds/unix/freetype2.pc.tmp
sed -e 's|%REQUIRES_PRIVATE%|zlib, libpng, harfbuzz >= 1.3.0, libbrotlidec|'     \
    -e 's|%LIBS_PRIVATE%|-lbz2|'             \
    -e 's|%build_libtool_libs%||' \
    -e 's|%exec_prefix%|/usr/local|'             \
    -e 's|%ft_version%|23.1.17|'                 \
    -e 's|%includedir%|/usr/local/include|'               \
    -e 's|%libdir%|/usr/local/lib|'                       \
    -e 's|%prefix%|/usr/local|'                       \
    /home/andre/.cache/pikaur/build/d-tracker/src/d-tracker/external/freetype2/builds/unix/                                                 \
    > builds/unix/freetype2.pc.tmp
chmod a-w builds/unix/freetype2.pc.tmp
mv builds/unix/freetype2.pc.tmp builds/unix/freetype2.pc
make[1]: Leaving directory '/home/andre/.cache/pikaur/build/d-tracker/src/d-tracker/external/freetype2'
cp external/freetype2/objs/.libs/ build/
==> ERROR: A failure occurred in build().

Command 'makepkg --force' failed to execute.

Can't build 'd-tracker'.

marsoft commented on 2020-08-05 19:02 (UTC)

Cannot build... Here is the log: Latest message: error making: %!s(func() string=0x5564f0516e80) I cannot understand what could it mean. Maybe related to russian locale being used? Although I tried to build with LANG=C and it didn't help.

SanskritFritz commented on 2020-03-24 15:11 (UTC)

Lovely package, thanks! Thanks for writing this Hamster alternative.