Package Details: d9vk-mingw-git 0.21.r0.ed797f8f7-1

Git Clone URL: https://aur.archlinux.org/d9vk-mingw-git.git (read-only)
Package Base: d9vk-mingw-git
Description: A d3d9 to vk layer based off DXVK's codebase, mingw version
Upstream URL: https://github.com/Joshua-Ashton/d9vk
Licenses: zlib/libpng
Conflicts: d9vk
Provides: d9vk
Submitter: loathingkernel
Maintainer: loathingkernel
Last Packager: loathingkernel
Votes: 2
Popularity: 0.103902
First Submitted: 2019-04-14 16:27
Last Updated: 2019-09-27 12:55

Latest Comments

PedroHLC commented on 2019-05-21 15:58

"Reversed (or previously applied) patched detected"

SilverSynch commented on 2019-05-16 04:53

The extraops patch provided is failing to apply due to changes to build-wine32.txt and build-wine64.txt. The following commit changed them: https://github.com/Joshua-Ashton/d9vk/commit/8c2709a1c62641370bfb4118024460cb05677a1e

loathingkernel commented on 2019-05-12 09:38

That's because something messed up the tags in the upstream repo. Will update shortly

katt commented on 2019-05-12 08:54

Suddenly unable to build, getting this error:

==> Starting pkgver()...
fatal: No tags can describe 'da392277550446f2d037a3dcfd6fb15e59654daf'.
Try --always, or create some tags.
==> ERROR: pkgver is not allowed to be empty.
==> ERROR: pkgver() generated an invalid version: 
~/d9vk-mingw-git [master●] » 

zfkerr commented on 2019-05-08 19:28

Hi, @loathingkernel! Published the first release of D9VK! In this regard, would you like to create a package in AUR that offers stable releases of D9VK? Thnak you very much for your great work!

https://github.com/Joshua-Ashton/d9vk/releases

loathingkernel commented on 2019-04-23 22:43

Disable the extraopts.patch and try again please. Comment the line with the patch command in the PKGBUILD. But I believe it is the fstack-protector-strong flag which causes the fail. Can you filter it out?

Edit: winelib version compiles correctly with fstack-protector-strong, mingw fails to link dxgi.dll. Meson is concurrent by default, so the last message is not always where the error occured.

damachine commented on 2019-04-23 22:11

hallo can not install failed with:

[150/241] x86_64-w64-mingw32-g++ -Isrc/d3d11/bca5607@@d3d11@sha -Isrc/d3d11 -I../../d9vk/src/d3d11 -I../../d9vk/./include -fdiagnostics-color=always -pipe -Wall -Winvalid-pch -Wnon-virtual-dtor -std=c++1z -O3 -DNOMINMAX -D_FORTIFY_SOURCE=2 -march=native -O2 -fstack-protector-strong -fno-plt -MD -MQ 'src/d3d11/bca5607@@d3d11@sha/d3d11_context.cpp.obj' -MF 'src/d3d11/bca5607@@d3d11@sha/d3d11_context.cpp.obj.d' -o 'src/d3d11/bca5607@@d3d11@sha/d3d11_context.cpp.obj' -c ../../d9vk/src/d3d11/d3d11_context.cpp ninja: build stopped: subcommand failed. ==> FEHLER: Ein Fehler geschah in build(). Breche ab... :: Unable to build d9vk-mingw-git - makepkg exited with code: 4