Package Details: daggerfall-fixes 20120413-1

Git Clone URL: https://aur.archlinux.org/daggerfall-fixes.git (read-only)
Package Base: daggerfall-fixes
Description: The Elder Scrolls II: Daggerfall, unofficial fixes
Upstream URL: http://www.uesp.net/wiki/Daggerfall:Files#Unofficial_Patches_and_Fixes
Licenses: custom:daggerfall
Submitter: giniu
Maintainer: giniu
Last Packager: giniu
Votes: 6
Popularity: 0.000000
First Submitted: 2011-07-03 18:58
Last Updated: 2015-07-07 19:33

Latest Comments

giniu commented on 2016-07-30 18:11

Again, some new fixed are there to add, but I have to rewrite mod support before that. The daggerfall/arena launcher will probably someday become separate python project - I just have to find some time. As of now, I hope it works as it is.

giniu commented on 2016-07-30 18:07

@PiroXiline - with daggerfall 1.07.213-13 you should not see those perl errors anymore.

PiroXiline commented on 2016-07-20 08:40

After link I've fixed to AUR daggerfall package https://aur.archlinux.org/packages/daggerfall/ (commented on 2016-07-19)

Witch must be not related to changing daggerfall PKGBUILD (DFInstall.zip must be the same) I've got an error in this package:

...
(1/1) installing daggerfall-fixes [#######################################] 100%
Experimental push on scalar is now forbidden at /usr/bin/daggerfall line 729, near "$date)"
BEGIN not safe after errors--compilation aborted at /usr/bin/daggerfall line 1335.
error: command failed to execute correctly
~>

Looks like some problem because of new Perl version.

giniu commented on 2013-04-13 17:21

Dunmerfall indeed was deleted, because it was old version of fix created by Andy Polis that later got updated by DelphiSnake - and is now merged into his Dark-elves.zip

To make minimal changes for now, I just made version updated by DelphiSnake install/enable as andyfall-fixes mod. I've also updated DFQFIX to latest version.

Anyway I'm leaving this as out of date, because those are not all fixes, but it still requires rewriting of launches script to incorporate them.

aphirst commented on 2013-03-25 18:54

Apparently the Dunmerfall file has been removed from the server:
http://www.uesp.net/wiki/UESPWiki_talk:Deletion_Policy
Hence, this package now fails to build.

giniu commented on 2012-07-16 06:11

Thanks for noticing, URL changed and what was downloaded was actually 404 html page. It should work now.

Anonymous comment on 2012-07-15 22:33

It would seem that one of the packages needs updating/fixing

...
Q0C00Y03.ZIP ... Passed
magicdef.zip ... FAILED
andyfall-fixes.patch ... Passed
magical_effects_fix.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
notice: daggerfall-fixes failed while building, remove source files (/home/user/daggerfall-fixes)?

giniu commented on 2012-04-05 12:10

I only had time to update links so it builds again. New launcher which will allow to integrate new, recently released fixes is in the works. Sorry for delay!

giniu commented on 2011-12-22 17:12

There are new fixes and addons to pick from uesp.net, but they require changes to launcher (ability to patch large files using same method we patch FALL.EXE right now). I'm leaving those on "Out-of-date" to remind me I have to implement this feature, and then update those.

giniu commented on 2011-09-16 19:04

I did not bumped package version, because I only adjusted download archives - resulting package is same (some extensions were repackaged, resulting in smaller download).

All comments