Package Details: dargui 0.7.2-2

Git Clone URL: https://aur.archlinux.org/dargui.git (read-only)
Package Base: dargui
Description: GUI for the backup tool dar (disk archiver).
Upstream URL: http://dargui.sourceforge.net/
Licenses: GPL
Submitter: None
Maintainer: arthurzam
Last Packager: arthurzam
Votes: 13
Popularity: 0.336590
First Submitted: 2009-06-12 14:09
Last Updated: 2016-02-13 10:17

Latest Comments

hyshka commented on 2015-02-17 18:59

Seems to run fine for me with blackhole's adjustments.

blackhole commented on 2013-09-23 12:06

It can be improved...but his will work with last version 0.7.2. This has compiled right on my x86_64 arch. I suppose because I have 32 libraries installed. Please check permissions on /usr/share/dargui/scripts. If I remebember one of the scripts was not executable.

pkgname=dargui
pkgver=0.7.2
pkgrel=1
pkgdesc="GUI for the backup tool dar (disk archiver)."
arch=('i686' 'x86_64')
url="http://dargui.sourceforge.net/"
license=('GPL')
depends=('dar' 'xterm' 'at' 'gtk2' 'vte')
source=("http://downloads.sourceforge.net/$pkgname/${pkgname}-${pkgver}-bin.tar.gz")
md5sums=('7ba48a2c0656434178a13e1e5a0dcaf2')

package() {
cd "$srcdir/$pkgname-$pkgver/"

mkdir -p "$pkgdir/"usr/share/doc/dargui
mkdir -p "$pkgdir/"usr/share/man/man1
mkdir -p "$pkgdir/"usr/share/dargui/locales
mkdir "$pkgdir/"usr/share/menu
mkdir "$pkgdir/"usr/share/applications
mkdir "$pkgdir/"usr/share/pixmaps
mkdir "$pkgdir/"usr/bin

cp -vR doc/* "$pkgdir/"usr/share/doc/dargui/
#cp -v doc/copyright "$pkgdir/"usr/share/doc/dargui/
cp -v man/dargui.1.gz "$pkgdir/"usr/share/man/man1/

cp -v menu/* "$pkgdir/"usr/share/menu/
chmod 644 "$pkgdir/"usr/share/menu/dargui
cp -v applications/* "$pkgdir/"usr/share/applications/
chmod 644 "$pkgdir/"usr/share/applications/dargui.desktop
cp -v pixmaps/* "$pkgdir/"usr/share/pixmaps/

cp -v scripts/* "$pkgdir/"usr/share/dargui/
cp -v darlogger "$pkgdir"/usr/share/dargui/

cp -v locales/* "$pkgdir/"usr/share/dargui/locales/
cp -v dargui "$pkgdir"/usr/bin/
}

post_install() {
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

Phlogiston commented on 2012-01-11 22:10

dargui: error while loading shared libraries: libgdk_pixbuf-2.0.so.0: cannot open shared object file: No such file or directory

on a arch=('x86_64') system...

fod commented on 2012-01-02 17:25

@xganesh - can you confirm that you have /usr/lib/libvte.so.9? -- If you have a current vte(0.28.2-3) you should have /usr/lib/libvte.so, /usr/lib/libvte.so.9, /usr/lib/libvte.so.9.2800.2 as per package file list (http://www.archlinux.org/packages/extra/i686/vte/).

xganesh commented on 2011-12-24 00:20

# pacman -Qsq ^vte
vte
vte-common

$ dargui
dargui: error while loading shared libraries: libvte.so.9: cannot open shared object file: No such file or directory

### sorry, what am I missing here? ##

salan54 commented on 2011-12-17 10:32

Just a trick for those using dargui with a localised system (eg: LOCALE = fr_FR.utf8).
To benefit the full features of dargui, you must use an english localised version of dar.
I set this alias in ~/.bashrc :

alias dargui='LANG=en_US.UTF-8; /usr/bin/dargui'

Hope this helps.

capoeira commented on 2011-12-16 14:14

thanks, finaly builds.

I hope I can get rid of "Back in Time" now

fod commented on 2011-12-16 00:44

Apologies - should work now - it was missing a dependency (vte)

fod commented on 2011-12-15 23:44

Apologies - just adopted this package - I suspect this is down to a missing dependency -- vte. I'm going to make sure before I add it to the PKGBUILD but in the meantime pacman -S vte might allow you to install.

fod commented on 2011-12-15 21:58

Apologies - just adopted this package - I suspect this is down to a missing dependency -- vte. I'm going to make sure before I add it to the PKGBUILD but in the meantime pacman -S vte might allow you to install.

All comments