Package Details: darkplaces 20140513-2

Git Clone URL: https://aur.archlinux.org/darkplaces.git (read-only)
Package Base: darkplaces
Description: An advanced Quake 1 game engine
Upstream URL: http://icculus.org/twilight/darkplaces/
Licenses: GPL2
Submitter: None
Maintainer: chungy
Last Packager: chungy
Votes: 77
Popularity: 2.559030
First Submitted: 2005-12-18 06:30
Last Updated: 2016-05-16 12:47

Latest Comments

parkerlreed commented on 2016-06-21 14:12

Found a working link on archive.org

https://web.archive.org/web/20160316040726/http://icculus.org/twilight/darkplaces/files/darkplacesengine20140513.zip

parkerlreed commented on 2016-06-21 14:10

Site is down at the moment http://www.downforeveryoneorjustme.com/http://icculus.org

Anybody have a backup of the zip?

FredBezies commented on 2014-05-08 21:36

Latest version is 20140507

Source file : http://icculus.org/twilight/darkplaces/files/darkplacesengine20140507.zip

sha256sums=('80fa52b2d5eb8b3c90a16d4937697f114a253e81df5151d7e0334ea2914b5e7c'
'476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')

Anonymous comment on 2013-04-14 06:01

Latest version is 20130304; builds fine with no changes but pkgver and sha256sums.

tea commented on 2012-12-23 17:15

Latest version is 20121222

doragasu commented on 2012-08-16 09:01

Thanks, I'll try again when I get some time (I'll be two weeks far from my PC starting tomorrow).

chungy commented on 2012-08-15 21:15

You need the dependency from the AUR as well; I highly recommend a program such as packer or yaourt to install AUR packages (many have rather large dependency trees on other AUR packages).

doragasu commented on 2012-08-15 18:15

Doesn't build:

$ makepkg -s
==> Making package: darkplaces 20110628-2 (Wed Aug 15 20:14:33 CEST 2012)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: libjpeg6
==> ERROR: 'pacman' failed to install missing dependencies.

hellpe commented on 2011-12-18 23:57

Thanks, the lowercase trick works. I've got yet another question : is there a way to configurate Darkplaces to use modern WASD controls with Quake 1 instead of the default ones ?

chungy commented on 2011-12-18 00:06

You need to make sure that your directory and file names are all lower-case. You should have an id1 directory with at least pak0.pak inside it (the retail version of Quake also has pak1.pak for the other three episodes).

hellpe commented on 2011-12-17 16:40

I just copied my ID1 folder to /usr/share/quake/, but Darkplaces still tells me there is "missing or unlocatable content/data". What did I do wrong ?

chungy commented on 2011-08-06 03:07

Another updated package that fixes the desktop launcher: http://dl.dropbox.com/u/13513277/darkplaces-20110628-0.1.src.tar.gz

chungy commented on 2011-08-05 12:04

I've made an updated package if anybody's interested: http://dl.dropbox.com/u/13513277/darkplaces-20110628-0.src.tar.gz

tea commented on 2011-08-03 14:39

Please update or disown this package.

jose1711 commented on 2011-07-30 10:06

6c6
< pkgver=20100408
---
> pkgver=20110628
17c17
< md5sums=('24e7e417b32cfb06ff915f6d8f251e80'
---
> md5sums=('c42103732cedfcf385ee959db9db6cb4'

FredBezies commented on 2011-07-30 07:59

Last version is from june 2011 :

http://icculus.org/twilight/darkplaces/files/darkplacesengine20110628.zip

jose1711 commented on 2010-06-23 14:57

@mjr4077au: try removing those spaces before EOF in darkplaces.install. anyway this has nothing to do with the package and is completely harmless.

Anonymous comment on 2010-06-23 14:01

Upon installation via Pacman, I get this error:

/tmp/alpm_TOlEmi/.INSTALL: line 12: warning: here-document at line 2 delimited by end-of-file (wanted `EOF')
/tmp/alpm_TOlEmi/.INSTALL: line 13: syntax error: unexpected end of file
/tmp/alpm_TOlEmi/.INSTALL: line 13: warning: syntax errors in . or eval will cause future versions of the shell to abort as Posix requires
sh: post_install: command not found
error: command failed to execute correctly

Package seemed to compile fine from what I saw. Any ideas?

chungy commented on 2010-06-06 18:30

For compatibility with some mods, this would be best to depend on libjpeg6 and have a "sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile" line right before building. This makes it so you don't get messages of "Found libjpeg version 80, expected 62" (or something of that sort) when using JPEGs :-)

Arkham commented on 2010-06-04 08:44

Oh, it must have been a once-in-a-lifetime-problem :)
I've added some more information in the install file, in order to make the desktop file work; instead of adding two different desktop files, I'd prefer to let the user create a link to the desired one. In this way, the menus won't get too messy ;)

jose1711 commented on 2010-06-03 15:29

20100408 also compiles fine on my system. jose

hatred commented on 2010-06-02 13:01

I compiled 20100408 without troubles... What is errors that you have?

Arkham commented on 2010-06-01 15:49

There are a couple of compiling errors that I haven't been able to fix yet. Has anybody of you guys succeeded in doing that?

jose1711 commented on 2010-05-26 19:09

bump.. is this still maintained?

hatred commented on 2010-05-22 03:04

> furthermore .desktopfile is incorrect

confirm.

jose1711 commented on 2010-05-21 20:04

furthermore .desktopfile is incorrect

hatred commented on 2010-05-20 07:57

20100408 is avail :-)