Package Details: darling-extra-git r4178.fe0da1407-1

Git Clone URL: https://aur.archlinux.org/darling-git.git (read-only, click to copy)
Package Base: darling-git
Description: Extra components for Darling that are not part of a typical ("stock") installation
Upstream URL: https://www.darlinghq.org
Keywords: Darwin Emulator macOS OSX Wine
Licenses: GPL3
Conflicts: darling-extra
Provides: darling-extra
Submitter: UnicornDarkness
Maintainer: ralphptorres
Last Packager: facekapow
Votes: 41
Popularity: 0.012060
First Submitted: 2013-06-29 15:19 (UTC)
Last Updated: 2023-10-15 18:57 (UTC)

Dependencies (43)

Required by (0)

Sources (155)

Pinned Comments

jamesbrink commented on 2019-07-10 02:27 (UTC)

Please use this package for stable more reliable builds

https://aur.archlinux.org/packages/darling/

This one is identical but locked in on a last known working git ref and I will update as often as I can.

I have also raised an issue about versioning so maybe we can get some kind of tags for future versions and stable working builds

https://github.com/darlinghq/darling/issues/537

Latest Comments

1 2 3 4 5 6 .. 17 Next › Last »

facekapow commented on 2023-10-14 17:32 (UTC) (edited on 2023-10-14 17:33 (UTC) by facekapow)

@SodachiLover420 libsystemd was listed because Darling requires libudev, which is provided by systemd-libs on standard Arch installs. I could change the dependency to libudev.so instead which should satisfy both Arch and Artix, but there's a problem: this works for the 64-bit version, since both Artix and Arch have a package that provides libudev.so=1-64, but for the 32-bit version, Arch provides libudev.so=1-32 (as one would expect) but Artix doesn't provide anything (just lib32-udev and lib32-eudev).

I'll go ahead and change it, but be aware that it still probably won't work for you on Artix because of this.

jclsn commented on 2023-09-08 07:21 (UTC)

Please remove python2 from the makedepends. It is not required anymore according to the darling developers. This will also make it possible to have darling accepted in the chaotic-aur package list.

<deleted-account> commented on 2023-08-15 12:17 (UTC)

This package has hard dependency on libsystemd, however the darling-bin does not and seems to be functionally equivalent (despite obviously being less bleeding edge).

on arch-derivatives like Artix that do not use systemd this results in failure to build. unless there is something in the upstream branch of this package that requires systemd, perhaps libsystemd should to an optional dependency?

Also since systemd is a fundamental component of archlinux, what is the benefit of having it as a dependency in the first place?

:) have a nice day.

spacekobold commented on 2023-07-03 04:01 (UTC)

The most recent commit to the PKGBUILD appears to have broken updating some of the recursive submodules. The names of the submodules were changed in the PKGBUILD but have not changed in the source repositories. Reverting the changes should fix the issue.

@@ -367,13 +368,13 @@ prepare() {

     cd "$srcdir/$_gitname/src/external/openpam/"
     git submodule init
-    git config submodule.pam_modules.url "$srcdir/darling-pam_modules"
+    git config submodule.darling/submodules/pam_modules.url "$srcdir/darling-pam_modules"
     git -c protocol.file.allow=always submodule update

     cd "$srcdir/$_gitname/src/external/IOKitUser"
     git submodule init
-    git config submodule.IOGraphics.url "$srcdir/darling-IOGraphics"
-    git config submodule.IOHIDFamily.url "$srcdir/darling-IOHIDFamily"
+    git config submodule.darling/submodules/IOGraphics.url "$srcdir/darling-IOGraphics"
+    git config submodule.darling/submodules/IOHIDFamily.url "$srcdir/darling-IOHIDFamily"
     git -c protocol.file.allow=always submodule update

     cd "$srcdir/$_gitname/src/external/metal"

https://bbs.archlinux.org/viewtopic.php?pid=2107703#p2107703

Kutay commented on 2023-05-25 20:35 (UTC)

I'm getting this error

fatal: repository '/home/kutay/.cache/yay/darling-git/darling-xnu.git' does not exist
fatal: clone of '/home/kutay/.cache/yay/darling-git/darling-xnu.git' into submodule path '/home/kutay/.cache/yay/darling-git/src/darling/src/external/xnu' failed
Failed to clone 'src/external/xnu' a second time, aborting
==> ERROR: A failure occurred in prepare().
    Aborting...
 -> error making: darling-git

atrujillo commented on 2023-02-10 09:30 (UTC) (edited on 2023-02-10 09:31 (UTC) by atrujillo)

architecture submodule fails

hecho.
fatal: repositorio '/home/user/.cache/yay/darling-git/darling-architecture' no existe
fatal: clonación de '/home/user/.cache/yay/darling-git/darling-architecture' en la ruta de submódulo '/home/user/.cache/yay/darling-git/src/darling/src/external/architecture' falló
Falló al clonar 'src/external/architecture' una segunda vez, abortando
==> ERROR: Se produjo un fallo en prepare().
    Cancelando...

soloturn commented on 2023-01-15 08:03 (UTC) (edited on 2023-01-15 08:04 (UTC) by soloturn)

thank you so much facekapw, very cool! why does this require python2, if macos already transitioned 3 years ago to python3 ?

facekapow commented on 2023-01-11 02:40 (UTC)

I apologize; I know the build has been broken for about a week now. I've been away from my Arch machine for a bit, but I should have a chance to get this updated tomorrow.

lucas commented on 2023-01-02 23:52 (UTC) (edited on 2023-01-02 23:53 (UTC) by lucas)

It fails ..... .....

Switched to a new branch 'makepkg'
  -> Creating working copy of fmdb git repo...
Switched to a new branch 'makepkg'
  -> Creating working copy of lzfse git repo...
Switched to a new branch 'makepkg'
  -> Creating working copy of xcbuild git repo...
Switched to a new branch 'makepkg'
==> Starting prepare()...
Initialize git submodules.
Updating git submodule paths.
Updating git submodules
fatal: repository '/var/cache/private/pikaur/build/darling-git/darling-Libinfo.git' does not exist
fatal: clone of '/var/cache/private/pikaur/build/darling-git/darling-Libinfo.git' into submodule path '/var/cache/private/pikaur/build/darling-git/src/darling/src/external/Libinfo' failed
Failed to clone 'src/external/Libinfo'. Retry scheduled
fatal: repository '/var/cache/private/pikaur/build/darling-git/darling-librpcsvc.git' does not exist
fatal: clone of '/var/cache/private/pikaur/build/darling-git/darling-librpcsvc.git' into submodule path '/var/cache/private/pikaur/build/darling-git/src/darling/src/external/librpcsvc' failed
Failed to clone 'src/external/librpcsvc'. Retry scheduled
fatal: repository '/var/cache/private/pikaur/build/darling-git/darling-Libinfo.git' does not exist
fatal: clone of '/var/cache/private/pikaur/build/darling-git/darling-Libinfo.git' into submodule path '/var/cache/private/pikaur/build/darling-git/src/darling/src/external/Libinfo' failed
Failed to clone 'src/external/Libinfo' a second time, aborting
==> ERROR: A failure occurred in prepare().
    Aborting...
Finished with result: exit-code
Main processes terminated with: code=exited/status=4

MiketsuSmasher commented on 2022-11-06 09:53 (UTC) (edited on 2022-11-06 09:57 (UTC) by MiketsuSmasher)

Package build failed because no submodules could be cloned during prepare():

Updating git submodule paths.
Updating git submodules
Cloning into '/home/miketsu/.cache/paru/clone/darling-git/src/darling/src/external/AvailabilityVersions'...
fatal: transport 'file' not allowed
fatal: clone of '/home/miketsu/.cache/paru/clone/darling-git/src/darling-AvailabilityVersions' into submodule path '/home/miketsu/.cache/paru/clone/darling-git/src/darling/src/external/AvailabilityVersions' failed
Failed to clone 'src/external/AvailabilityVersions'. Retry scheduled
Cloning into '/home/miketsu/.cache/paru/clone/darling-git/src/darling/src/external/BerkeleyDB'...
fatal: transport 'file' not allowed
fatal: clone of '/home/miketsu/.cache/paru/clone/darling-git/src/darling-BerkeleyDB' into submodule path '/home/miketsu/.cache/paru/clone/darling-git/src/darling/src/external/BerkeleyDB' failed
Failed to clone 'src/external/BerkeleyDB'. Retry scheduled
Cloning into '/home/miketsu/.cache/paru/clone/darling-git/src/darling/src/external/DSTools'...
fatal: transport 'file' not allowed
fatal: clone of '/home/miketsu/.cache/paru/clone/darling-git/src/darling-DSTools' into submodule path '/home/miketsu/.cache/paru/clone/darling-git/src/darling/src/external/DSTools' failed
Failed to clone 'src/external/DSTools'. Retry scheduled